Mounting Droid to PC via USB

Discussion in 'Android General Discussions' started by bd1212, Mar 15, 2010.

  1. bd1212

    bd1212 Member

    Joined:
    Dec 21, 2009
    Messages:
    424
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Whenever I try to mount my Droid to my computer using the USB cable, nothing happens on my PC.

    No folder opens, nothing. Please help as now I can no longer transfer files to my Droid via USB or use adb to do commands.
     
  2. warrior21

    warrior21 Active Member

    Joined:
    Mar 15, 2010
    Messages:
    1,287
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    NY
    Ratings:
    +0
    Does it show the USB is connected on your notification bar?
     
  3. deubster

    deubster Member

    Joined:
    Dec 12, 2009
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Assuming you have pulled down the task bar and mounted your Droid after connecting the USB cable, the problem is likely that your pc is using the drive letter(s) that would normally be assigned to the Droid.

    When I mount my Droid, it usually displays in Windows Explorer as "Removable Disk F:". If, for example, you have C: and D: hard drives, E: and F: CD and DVD writers, G:, H:, I:, and J: taken by the memory reader slots on your HP printer, then the Droid may not appear.

    To remedy, in XP, Vista, or Windows 7, go into Computer Manager, Disk Management, and change some drive letters - for example, move your F: and G: drives to M: and N:. Then remount the Droid.
     
  4. drbonz

    drbonz New Member

    Joined:
    Mar 20, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I have the same trouble. I plug in the cable to my phone then to the USB on the computer. You get that "usb device is now connected" sound you hear on the computer when you plug in any USB device so it does seem to recognize that I plugged something in. Then my phone beeps.

    I pull down the USB notification and the drop down menu says "USB connected, select to copy files to and from your computer". I then click on that and get the "mount" or "don't mount" screen on my phone. I hit MOUNT, and see "turning off USB storage",then "preparing SD card", then "USB connected" on my phone.

    That's it. Nothing else happens. I see nothing on my computer. I look in "my computer" and see my hard drive (under Drive C), my external HD (under Drive G) and my DVD drive (under Drive D). No other drives or devices are listed.

    Any ideas?
     
  5. sddenizen

    sddenizen Member

    Joined:
    Mar 2, 2010
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    San Diego
    Ratings:
    +0
    I don't know what operating system you are using, but I was experiencing the same problem on my Win 7 64-bit desktop. I would connect the Droid, hear the confirming connection sound from my pc, mount the Droid and it would not show up as a separate drive in "computer". I would then go to device manager and I would find that the Droid was installed under disk drives and was "working properly". So what to do?

    Well, after playing around with device manager, I found that if you right click on the Droid (under disk drives) and select properties, then click on the "Policies" tab and change the choice from "quick removal" to "better performance", the Droid would then show up as a separate removable drive in "computer".

    I have to do this every time I connect my Droid via USB but at least I can now transfer files from my pc to the Droid.

    I have no problem with my laptop (also Win 7 64-bit) recognizing my Droid as a disk drive after mounting my Droid. Go figure.
     
  6. drbonz

    drbonz New Member

    Joined:
    Mar 20, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I too am running Windows 7, 64 bit version.

    I see it says Motorola A855 device under disk drives. I assume that's the one, right?

    I tried your suggestion and didn't have any luck. Can you tell me exactly what sequence you used?

    Do I change the setting in device manager before or after I connect the phone via USB? Do I mount first? Can you give me a step by step?

    Thanks for your help!

    Ed
     
    #6 drbonz, Mar 21, 2010
    Last edited: Mar 21, 2010
  7. sddenizen

    sddenizen Member

    Joined:
    Mar 2, 2010
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    San Diego
    Ratings:
    +0
    Connect phone via usb. Mount phone. Go to device manager and determine if phone is recognized as a disk drive. If so, right click on phone, go to properties, click on policies tab and change setting. Always works for me even if a pain.
     
  8. drbonz

    drbonz New Member

    Joined:
    Mar 20, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thanks but no luck. Still nothing in Computer. When yours DOES show up, what letter does your computer designate to it (i.e. D drive, F drive etc)?

    I also tried something different. I took out my SD card and used a card reader/flash drive and again, the computer sounds as though it recognizes that I plug in the SD card (I hear the USB sound) but again, nothing else. I cannot see the flash drive listed in Computer. I do see it in device manager however.

    It's almost as though there is something wrong with my SD card. :(

    In the 3rd post in this thread Deubster mentioned changing the designation of the drives. How exactly do you do that? He mentioned "Computer Manager" I'm not familiar with that. I tried device manager and can't do it there and I can't seem to do it with the Computer folder either.
     
    #8 drbonz, Mar 21, 2010
    Last edited: Mar 21, 2010
  9. drbonz

    drbonz New Member

    Joined:
    Mar 20, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hooked up to my laptop (running Vista) and it works like a charm. Transferred everything on my phone to my laptop, then to a flash drive, then onto my PC.

    Seems like a royal pain to do this every time though.

    I just don't understand what is wrong with my PC that it will not recognize my phone. :(
     
  10. hookbill

    hookbill Premium Member
    Premium Member

    Joined:
    Nov 30, 2009
    Messages:
    19,502
    Likes Received:
    8
    Trophy Points:
    168
    Location:
    N.E. Ohio
    Ratings:
    +8
    I can't resist. My Mac running Snow Leopard 10.6.2 has no problems mounting my droid.:icon_ devil:

    Guys I see this problem all the time. 2 most common answers I see are changing the drive letter, which to me seems incredible, and the other is that you need the right set of drivers in your PC to get it to work.

    Take a look at the Moto page they have updated drivers.

    DROID by Motorola Support - Motorola USA
     
  11. urklegrue

    urklegrue Member

    Joined:
    Nov 19, 2009
    Messages:
    123
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
  12. Retire36

    Retire36 New Member

    Joined:
    Mar 20, 2010
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    USB Connecton

    I just plug in the usb cord, swipe down on the task bar then click on usb connection.
     
Search tags for this page
connect your mobile to pc with a usb cable and mount as disk
,
droid 4 mount drives usb
,

motorola droid mount disk drive

,

mount droid ultra to computer

,
mount usb disk for droid bionic
,

my phone no longer alows pc to mount drive

,
pc does not recognize samsung fascinate
,
pc says connected andriod something wrong with drive
,
transfer files from android to pc mount usb not showing
,

why does my droid hard drive does not show in my computer