mount error trying to use Koush's AnyKernel Updater

Discussion in 'Android Hacks and Help' started by gnychis, Mar 11, 2011.

  1. gnychis

    gnychis Member

    Joined:
    Feb 24, 2011
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I am trying Koush's AnyKernel Updater, but I'm getting an error. Maybe I am doing something wrong.

    I checked out his git source, then I replaced kernel/zImage with my own zImage. Then I created an update.zip:
    Code:
    $ zip -r update.zip *
      adding: META-INF/ (stored 0%)
      adding: META-INF/CERT.RSA (deflated 33%)
      adding: META-INF/CERT.SF (deflated 61%)
      adding: META-INF/com/ (stored 0%)
      adding: META-INF/com/google/ (stored 0%)
      adding: META-INF/com/google/android/ (stored 0%)
      adding: META-INF/com/google/android/update-binary (deflated 34%)
      adding: META-INF/com/google/android/updater-script (deflated 63%)
      adding: META-INF/MANIFEST.MF (deflated 61%)
      adding: kernel/ (stored 0%)
      adding: kernel/dump_image (deflated 32%)
      adding: kernel/mkbootimg (deflated 35%)
      adding: kernel/mkbootimg.sh (deflated 52%)
      adding: kernel/unpackbootimg (deflated 32%)
      adding: kernel/zImage (deflated 1%)
      adding: system/ (stored 0%)
      adding: system/lib/ (stored 0%)
      adding: system/lib/modules/ (stored 0%)
    
    I put it on my sdcard and I tried to install it, but I get the following error:
    Code:
    -- Installing: /sdcard/update.zip
    Finding update package...
    Opening update package...
    Installing update...
    AnyKernel Updater by Koush.
    Extracting System Files...
    mount() expects 4 args, got 3
    E:Error in /sdcard/update.zip
    (Status 7)
    Installation aborted.
    
    My guess is that the source of this error comes in META-INF/com/google/android/updater-script at this line:
    Code:
    mount("MTD", "system", "/system");
    
    But I'm assuming that was not meant to be changed by me...
     
  2. gnychis

    gnychis Member

    Joined:
    Feb 24, 2011
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
  3. onyx_64

    onyx_64 New Member

    Joined:
    Jul 21, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    It gives me a mount error when i try to use this method for my thunderbolt. Says it needs 4 args and not 3.

    Is there a newer version for anykernel?
     
Search tags for this page
anykernel2 error 1
,
anykernel2 errror 1
,
custom rom error format () expects 4 args, got 5
,
expects 4 args got 3 error
,
expects 5 args got 4
,
format () 4 args got 5
,
format expects 3 args
,
format expects 4 args got 5 updater script
,
mount expect 4 args got 5
,

mount expects 4 args got 3