Motorola Assist & 4.4.4

Discussion in 'Motorola Moto X' started by beachdaze, Aug 14, 2014.

  1. beachdaze
    Offline

    beachdaze New Member

    Joined:
    Jun 25, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Morning all, The update to 4.4.4 seems to have broken my Assist. It will no longer read my texts when driving. I did have Commandr for Google Now installed at the upgrade time, but had never even opened the app to set it up. So I don't really know if the update or the app screwed things up. I gone thru what I think are the correct steps to troubleshoot this, turned the Assist off, reboot turn it back on and such. Anybody have any additional steps to try or check boxes to check?

    Thanks,
    B
  2. GoCliffGo05
    Offline

    GoCliffGo05 Developer Relations Staff Member Premium Member

    Joined:
    Aug 16, 2012
    Messages:
    2,821
    Likes Received:
    312
    Trophy Points:
    83
    Location:
    Maryland
    Assist works fine here after the update... Have you tried going into setting and clearing data for assist? Are all your GPS settings on?

    Could Uninstall the update and re-download it as well.

    Worse comes to worst a factory reset would fix it, but obviously that's a last resort.

    Sent from my XT1060
  3. beachdaze
    Offline

    beachdaze New Member

    Joined:
    Jun 25, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Yes I have cleared data and it didn't help. I just cleared it again and will have the wife text me while I drive home tonite to test. I really, really don't want to do a factory reset. Really I don't.
  4. GoCliffGo05
    Offline

    GoCliffGo05 Developer Relations Staff Member Premium Member

    Joined:
    Aug 16, 2012
    Messages:
    2,821
    Likes Received:
    312
    Trophy Points:
    83
    Location:
    Maryland
    Try Uninstalling the update to assist in settings - apps...

    Are you using Bluetooth? There is a setting in assist settings for that.

    Try clearing cache for the entire phone in recovery.

    Also, sleep isn't activated in assist right?

    Sent from my XT1060
  5. beachdaze
    Offline

    beachdaze New Member

    Joined:
    Jun 25, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Will try that. Thanks for the ideas.
  6. GoCliffGo05
    Offline

    GoCliffGo05 Developer Relations Staff Member Premium Member

    Joined:
    Aug 16, 2012
    Messages:
    2,821
    Likes Received:
    312
    Trophy Points:
    83
    Location:
    Maryland
    Report back. I'm curious as to what's going on.

    Sent from my XT1060
  7. beachdaze
    Offline

    beachdaze New Member

    Joined:
    Jun 25, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    UPDATE: Wiped the app cache and uninstall the Assist updates with no affect. Still not reading my texts while in drive mode.

    Sleep is not on.

    Wiped the phone cache just now (had to Google how to do it), and will test next time I'm driving.

    Otherwise I guess a factory restore is my only other option. Sigh....
  8. GoCliffGo05
    Offline

    GoCliffGo05 Developer Relations Staff Member Premium Member

    Joined:
    Aug 16, 2012
    Messages:
    2,821
    Likes Received:
    312
    Trophy Points:
    83
    Location:
    Maryland
    Could try flashing the factory image without a data wipe... Though if you've never done this before you need to Google it, as most methods will erase data. Get familiar with ADB

    Sent from my XT1060
  9. grenefroggie
    Offline

    grenefroggie DF Super Moderator

    Joined:
    May 18, 2011
    Messages:
    197
    Likes Received:
    85
    Trophy Points:
    28
    When you go in to the Assist app, is "Talk to me" checked?
  10. LoudRam
    Offline

    LoudRam Well-Known Member

    Joined:
    Dec 18, 2010
    Messages:
    1,290
    Likes Received:
    59
    Trophy Points:
    48
    Location:
    Southern NJ
    Also check the Google text to speech output settings under language and inputs.
  11. LoudRam
    Offline

    LoudRam Well-Known Member

    Joined:
    Dec 18, 2010
    Messages:
    1,290
    Likes Received:
    59
    Trophy Points:
    48
    Location:
    Southern NJ
    So have you figured out the problem? I haven't received a text while driving for a while until yesterday and today. Both times assist did not read it. It answers the phone fine but it doesn't announce or read the text. I tried everything suggested in this thread except for factory reset and nothing worked.
  12. LoneWolfArcher
    Offline

    LoneWolfArcher Well-Known Member

    Joined:
    Dec 29, 2009
    Messages:
    1,176
    Likes Received:
    115
    Trophy Points:
    63
    Location:
    Michigan
    Works on mine, just did it several times Friday. I would do the reset.
  13. LoudRam
    Offline

    LoudRam Well-Known Member

    Joined:
    Dec 18, 2010
    Messages:
    1,290
    Likes Received:
    59
    Trophy Points:
    48
    Location:
    Southern NJ
    I'm going to wait. There are a few comments in the play store reviews that lead me to believe that it's a bug. I can live without the text reading for a bit. The phone answering still works and that's what I need.