Market Loads SLOWWWWW

Discussion in 'Project Elite' started by yakitori, Oct 20, 2010.

  1. yakitori

    yakitori Premium Member
    Theme Developer Premium Member

    Joined:
    Sep 7, 2010
    Messages:
    2,548
    Likes Received:
    10
    Trophy Points:
    103
    Location:
    DFW Texas
    Ratings:
    +10
    Just curious why this is. Installed clean per instructions in clockworkmod recovery. Flashed galas them.

    Everything else is pretty quick, but when I go to market...it takes forever and a day for the market to load up. I just get the little hamster wheel and loading for a minute or two.

    That and the app drawer scrolling is laggy in ADW launcher.

    Other than that...working GREAT!
     
  2. BlackDiamond

    BlackDiamond Member

    Joined:
    Jun 3, 2010
    Messages:
    303
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Delaware
    Ratings:
    +0
    Click setting/manage application/All/ then scroll down to Market click on it and clear Data..

    Should do the trick for you!
     
  3. yakitori

    yakitori Premium Member
    Theme Developer Premium Member

    Joined:
    Sep 7, 2010
    Messages:
    2,548
    Likes Received:
    10
    Trophy Points:
    103
    Location:
    DFW Texas
    Ratings:
    +10
    ok, will do...thank you.

    EDIT: This fixed it...at least she said it did. She is at work..and said its faster loading now.
     
    #3 yakitori, Oct 20, 2010
    Last edited: Oct 20, 2010
  4. luv2golf

    luv2golf Member

    Joined:
    Aug 12, 2010
    Messages:
    136
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    So Cal
    Ratings:
    +0
    I used to have those issues until I started following GirLuvsDroid's guide:

    I ALWAYS wipe and start clean when downloading a new ROM. When I DL the final release version later today, I'll wipe again and start fresh even though I'm now running the really close to final test 1.7 version from Saturday. It takes a little extra time and effort, but it's so worth it in the problems you avoid.

    Here's how I do it:

    1. Purchase the license for Titanium Backup (TiBu) if you don't already have it -- it's worth it -- and go to Batch and use "Backup all user apps + system data."

    2. Do a nandroid backup of your current setup, then, using ClockworkMod Recovery, do a factory reset (wipe data and cache), then go into the partitions menu and do a wipe of boot, then of system (even though 1.7 will wipe system and boot for you, I do it myself anyway).

    3. Install the ROM zip file.

    4. Touch the top left, then the top right, then the bottom right, then the bottom left (in a square pattern) of the screen to skip Google sign in.

    5. Make sure you have "Unknown sources" checked in System>Applications.

    6. Open TiBu and go into Preferences and make sure you have "Force to same location" checked (this will then make sure your apps and data are restored to the device and SD card, as applicable, exactly as they were when you did your backup).

    7. Go into Batch and and start with "Restore missing apps + all system data" -- but here's the important thing: press "Deselect all" and ONLY check the items in GREEN (this will restore all your call log, SMS/MMS, accounts, wifi and bluetooth connections, etc.). If you restore the stuff in red, you're restoring system data from prior ROMs, which could cause you all kinds of issues. We'll do apps and data in the next step.

    8. After you've finished restoring the items in green, run "Restore missing apps with data" and go through the list and make sure you've got only the items you really want to restore checked.

    9. Go to Settings>Accounts & sync, Add account and sign in to Google. Make sure Auto-sync is checked and that Sync Contacts, Sync Gmail and Sync Calendar, etc. are checked, and allow them to sync. It's possible that the Accounts restore in Step 7 already restored your account, but you should still look to be sure all your items are checked.

    10. Make a backup of this setup BEFORE you start adding themes and kernels -- that way, it's easy to revert back to stock and start over if a theme or kernel messes you up.

    If you run across any apps that restore from Market without your data, because you missed them in your TiBu restore, just go into TiBu and go to filters, type the name of the app, and restore data only.

    The only thing left is that you'll likely have to set up your widgets again (at least I do in Sweeter Home 2) and you may have to restore some of your ringtones in contacts, Gmail, calendar and Gtalk.

    One other note: if you have Swype, I've found that TiBu restore doesn't work right. You'll want to reinstall the Swype installer, then Swype FIRST, before your full TiBu restore, to avoid the memory issues that plague Swype installs.

    I found that if the ROM doesn't have a restore apps function, I would log on to Gmail, download TB then restore. I'm sure there is another way but that has worked for me and I flash ROM's at least twice a week.
     
  5. yakitori

    yakitori Premium Member
    Theme Developer Premium Member

    Joined:
    Sep 7, 2010
    Messages:
    2,548
    Likes Received:
    10
    Trophy Points:
    103
    Location:
    DFW Texas
    Ratings:
    +10
    uhhhhh....ok...clearing data worked for me.

    I did wipe and install clean. Thanks though. PE running flawless for me. Never had any fc's or anything other than a laggy load for market, which went away after a clear data....and BAM. snaps up like flash gordon.

    Superb ROM actngrezy!

    dancedroid
     
  6. chomorro

    chomorro Member

    Joined:
    Nov 21, 2009
    Messages:
    315
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Diego
    Ratings:
    +1
    Excellent guide there. I never knew about the force to same location option on TiBu, that will definitely come in handy :)