lock screen problems

Discussion in 'Samsung Galaxy S4' started by Bugsyros, Nov 8, 2013.

  1. Bugsyros

    Bugsyros New Member

    Joined:
    Nov 8, 2013
    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    3
    Ratings:
    +1
    I am going crazy cos I cannot find a way to lock the screen when I am taking/making calls. I must be touching it with my face and without my knowledge it is performing all sorts of tasks....it even managed to enable my 'block calls' setting. Please can someone help as the shop says that all my settings were in order and it should not be happening. ....................? Thanks
     
  2. GVLBob

    GVLBob Member

    Joined:
    Dec 7, 2009
    Messages:
    427
    Likes Received:
    16
    Trophy Points:
    18
    Location:
    Greenville, SC
    Ratings:
    +16
    I think this is what you want to do:

    1. Open the phone app
    2. Call settings
    3. Press "Turn off screen during calls" (AKA turn on proximity sensor during calls)

    If it is already checked, then we need to understand your problem further.


    Sent from my iPad using Tapatalk HD
     
    • Like Like x 1
  3. Neoart

    Neoart Member

    Joined:
    Sep 14, 2013
    Messages:
    186
    Likes Received:
    19
    Trophy Points:
    18
    Location:
    Mpls
    Ratings:
    +20
    Current Phone Model:
    S4 White SCH1545
    It's a shame when they never come back to confirm tested result an hour later.
     
  4. Bugsyros

    Bugsyros New Member

    Joined:
    Nov 8, 2013
    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    3
    Ratings:
    +1
    Thank you so much for getting back to me. Yes, that box is checked so would there be a fault with my phone ??? I feel as though I am being incredibly thick!!!
     
  5. GVLBob

    GVLBob Member

    Joined:
    Dec 7, 2009
    Messages:
    427
    Likes Received:
    16
    Trophy Points:
    18
    Location:
    Greenville, SC
    Ratings:
    +16
    When you hold your phone to your face, the screen should lock. And then unlock once you move the phone away from your face. If that doesn't happen, it may be that the proximity sensor isn't working or is blocked by your case.

    This works fine on my phone. Originally, I had the same problem you did until I "checked the box".
     
  6. Bugsyros

    Bugsyros New Member

    Joined:
    Nov 8, 2013
    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    3
    Ratings:
    +1
    THANKS....!
    I have come to the conclusion that I have a fault with the sensor so will take it to the shop. Even without the case it fails to function but thanks for all your time.......x
     
  7. FoxKat

    FoxKat Premium Member
    Premium Member

    Joined:
    Apr 2, 2010
    Messages:
    14,806
    Likes Received:
    4,751
    Trophy Points:
    838
    Location:
    Pennsylvania
    Ratings:
    +5,290
    Current Phone Model:
    Droid Turbo 2 & Galaxy S7
    Go to the play store and download https://play.google.com/store/apps/details?id=com.tigermonster.proxfinder.

    Once run, place your finger above the top of the screen, horizontally parallel to and just to the left of the earpiece. If your finger is within about 3cm above the screen, the software should change from indicating 100cm to 3cm indicating it's signaling to the phone to lock the screen. And as you move your finger away it should change back to 100cm signaling to unlock the screen, this all-on, all-off indication is how it responds if the sensor only supports on and off.


    [​IMG]
    Covered

    [​IMG]
    Uncovered

    If it supports variable distance it should read a constantly variable distance depending on how far or near to the sensor you are. It will also show in milliseconds hi long you have it within range to be detected.

    If this test is successful it's not the sensor that's faulty.

    Sent from my XT1080 using Tapatalk
     
    • Like Like x 1
  8. Bugsyros

    Bugsyros New Member

    Joined:
    Nov 8, 2013
    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    3
    Ratings:
    +1
    Gosh...getting technical for me........!

    OK. I downloaded the prox sensor finder and uncovered it read 8.0 cm. Covered went to 0.0 so I assume that the sensor is OK. So what on earth can be wrong??????

    Thank you sooooh much for the advice.
     
  9. GVLBob

    GVLBob Member

    Joined:
    Dec 7, 2009
    Messages:
    427
    Likes Received:
    16
    Trophy Points:
    18
    Location:
    Greenville, SC
    Ratings:
    +16
    If you checked the box I suggested in post #2 and you are holding the phone close enough to your face, then I have no idea.


    Sent from my iPad using Tapatalk HD
     
  10. bbtkd

    bbtkd Active Member

    Joined:
    Nov 16, 2009
    Messages:
    651
    Likes Received:
    26
    Trophy Points:
    28
    Location:
    Earth
    Ratings:
    +26
    First of all, are you a zombie?

    Failing that, can't tell from your posts, but are you male? If so, have a beard? I have a beard and no problems, so maybe the beard isolates it. Then again, I suspect guys with beards are a minority of users of the S4. Do you think your skin is making contact?
     
  11. FoxKat

    FoxKat Premium Member
    Premium Member

    Joined:
    Apr 2, 2010
    Messages:
    14,806
    Likes Received:
    4,751
    Trophy Points:
    838
    Location:
    Pennsylvania
    Ratings:
    +5,290
    Current Phone Model:
    Droid Turbo 2 & Galaxy S7
    Well, yes then, the sensor is working properly. I don't know why some consider 3cm to be the threshold distance and others use any number of other distances, but 8cm is a good bit farther than 3cm, so if anything I would think it might blank out too soon (such as if you were trying to shade the screen from sun for instance), rather than not at all.

    I can't troubleshoot it more from here than I have already, but since this is a computer and since any number of apps can influence how the computer responds to sensor input, it could easily be an app. Do you have anything installed that is perhaps designed to 'keep screen awake'? Often times things like navigation, video players, craigslist apps, any number of other types of apps which require extended viewing time will essentially turn off the sensor and interrupt the timeout schedule so the app doesn't go black while you are using it.

    I would go through all your user-installed apps first and check each one's settings to see if a stay awake setting is checked. Then go through the factory installed ones to see if the same are in those. Aside from that, and this may sound stupid but if you have a screen protector on the phone it can interfere with the sensor working properly. I left the one on the phone that came on it and after about 2 weeks it wouldn't turn on when in a call...power button, volume controls, nothing worked to wake up the screen. I couldn't change it from earpiece to speaker or turn on Bluetooth, I couldn't get the dialpad to select menu prompts, I couldn't even end a call. The only thing that worked was once the other party hung up the screen would wake again.

    Once I cut out a section of the screen protector over the sensor it worked perfectly. This can happen with cases too but I know you tried it without the case. You should look to see if the screen protector is over the sensor.

    Finally you may be forced to try a FDR (Factory Data Reset), but first I would like you to try the phone in safe mode and see if the same thing happens while in a call.

    First, power down the phone by pressing and holding the power button while the screen is on. A menu will pop up and you will select "Power off". Then confirm in the next prompt.

    fixedbyvonnie-galaxy-s4-power-off.png

    fixedbyvonnie-galaxy-s4-power-down-confirmation.png


    Then press and hold the power button until the phone vibrates shortly and release power button. Next, as soon as you see the Samsung Galaxy S4 logo, press and hold the Volume Down button. Continue holding that Volume down button until the screen awakes and you'll see a black box with white letters showing at the lower left corner of the screen saying "Safe mode". In this mode, the phone will only run those apps which are set to run from those pre-installed. It will not run any of the user-installed apps, and they won't even be in your screen positions or in the app tray.

    fixedbyvonnie-galaxy-s4-safemode-boot-2.png

    Now try the phone calls and see if the problem persists. If it doesn't that confirms a third party app's the culprit. If the problem persists, it may be time for an FDR, and if that doesn't work...it's a lemon IMHO.

    To get out of Safe mode, simply reboot the phone.

    Sorry for the edit to the instructions above, my original source was incorrect. I've tested these instructions on a S4 that I have laying around and they work properly to invoke Safe mode.
     
    • Like Like x 1
  12. Bugsyros

    Bugsyros New Member

    Joined:
    Nov 8, 2013
    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    3
    Ratings:
    +1
    I hope I haven't got a beard !!!!!!!!!! as I am a woman !!!!!!!!!!!!!!!!

    Point taken though and I am as confused as the best of us. Many thanks for your time..............!
     
Search tags for this page

black box pops up on samsung s4 lock screen

,
galaxy s4 lock theme
,
problem with lock screen and home screen mode of s4
,

problem with wrong date on lockscreen samsung galaxy4

,
s4 lock screen blank box
,

samsung galaxy s4 black box on lock screen

,
samsung lock screen off too quickly
,
samsung s4 lock screen troubleshooting
,
turn off screen on s4 when holding phone to face
,

watch on tv app off lock screen on s4