Link2SD - missing apps after reboot

Discussion in 'Android Tech Support' started by sixwordslong, Jul 14, 2014.

  1. sixwordslong

    sixwordslong New Member

    Joined:
    Jul 14, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Edmonton AB
    Ratings:
    +0
    Current Phone Model:
    Samsung Galaxy S4 (SGH-I337M)
    Twitter:
    @sixwordslong
    I was running into the 'insufficient storage' errors on my S4, so after doing some research I decided to try Link2SD to move my apps and app data to a secondary partition on my external SD card.

    I was able to create a 10 GB ext4 partition and then used Link2SD to select as many apps as it would and then did a Create Link - application file, dalvik-cache file, library files and internal data. It went through the list successfully, and I rebooted after it was done.

    After the reboot, all the apps that I had moved over to my SD card no longer show up in the Launcher or the App Drawer. If I open Link2SD and look at Storage Info, I do see my "SD Card 2nd Part" mounted at /data/sdext2, and it's about half full. If I look in /data/sdext2, I do see all the .apk files for all the apps that got moved, and /data/sdext2/data has a ton of subfolders for all the apps as well (I'm assuming that's where the 'internal data' got moved to)?

    I've read all the threads that say to do a Quick Reboot after the full reboot, but that hasn't helped me... all my apps stay gone. Doing a 'Recreate Mount Scripts' says that they're created successfully, but no change after a reboot. If I try to 'Relink all application files', it tells me that it found no files to link.

    Samsung Galaxy S4 SGH-I337M
    CyanogenMod 11-20140708-SNAPSHOT-M8-jflte
    Android 4.4.4
    Link2SD Plus 3.5.1

    Can anyone lend a hand?

    Greg

    P.S. I've also posted over at AndroidForums but no replies yet :(
     
  2. leeshor

    leeshor Gold Member

    Joined:
    Jan 30, 2012
    Messages:
    4,363
    Likes Received:
    1,437
    Trophy Points:
    358
    Location:
    Norcross, GA - USA
    Ratings:
    +1,676
    Welcome to the forum Greg

    Is your SD card by any chance a 64GB card?
     
  3. sixwordslong

    sixwordslong New Member

    Joined:
    Jul 14, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Edmonton AB
    Ratings:
    +0
    Current Phone Model:
    Samsung Galaxy S4 (SGH-I337M)
    Twitter:
    @sixwordslong
    Thanks leeshor! I've gotten lots of great advice from the threads here but haven't needed to actually create an account until now.

    Yes, the card is 64 GB. Will that cause problems with the mounting script?
     
  4. leeshor

    leeshor Gold Member

    Joined:
    Jan 30, 2012
    Messages:
    4,363
    Likes Received:
    1,437
    Trophy Points:
    358
    Location:
    Norcross, GA - USA
    Ratings:
    +1,676
    The problem is that the S4s are prone to not like 64GB cards, at all, unless it was a really old card. (it was a guess on my part that you had one due to problems others have had). Once the S4 has not seen the card properly it may be trashed beyond recovering.
     
    • Like Like x 1
  5. cr6

    cr6 Super Moderator
    Staff Member

    Joined:
    Apr 1, 2011
    Messages:
    8,354
    Likes Received:
    5,877
    Trophy Points:
    1,778
    Location:
    NW Rocky Mtn region
    Ratings:
    +6,707
    Current Phone Model:
    Galaxy S7 Edge
    Twitter:
    @dronewolfmedia
    Welcome to the forum Greg!

    tap'n on my S5
     
  6. sixwordslong

    sixwordslong New Member

    Joined:
    Jul 14, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Edmonton AB
    Ratings:
    +0
    Current Phone Model:
    Samsung Galaxy S4 (SGH-I337M)
    Twitter:
    @sixwordslong
    Erg, that is definitely not an answer I was hoping for. So you're thinking that even though the phone is mounting the partition properly at /data/sdext2 and I can see all the files, the actual data might be hosed? Blech.

    I've been doing some poking around in adb with installer packages. I downloaded the .apk for IMDB as a tester package and saved it on internal storage (/sdcard/Download/com.imdb.mobile.apk). I tried doing a "pm install /sdcard/Download/com.imdb.mobile.apk" and got "Failure [INSTALL_FAILED_INTERNAL_ERROR]". Then I did a "pm uninstall com.imdb.mobile" which was successful and I saw that /data/sdext2/com.imdb.mobile-2.apk was gone, so it does seem to know that the app was there. Then I tried "pm install /sdcard/Download/com.imdb.mobile.apk" again and it was successful this time.

    Complicating all of this is that one of the missing apps is the Google Play Store which I didn't notice was included in the list of apps to link with Link2SD. I think its app package is com.android.vending? I've tried removing that one but I just get a generic 'Failure' message.

    I'm getting the feeling that a factory reset might be in my near future....
     
  7. leeshor

    leeshor Gold Member

    Joined:
    Jan 30, 2012
    Messages:
    4,363
    Likes Received:
    1,437
    Trophy Points:
    358
    Location:
    Norcross, GA - USA
    Ratings:
    +1,676
  8. sixwordslong

    sixwordslong New Member

    Joined:
    Jul 14, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Edmonton AB
    Ratings:
    +0
    Current Phone Model:
    Samsung Galaxy S4 (SGH-I337M)
    Twitter:
    @sixwordslong
    Hey leeshor,

    Thanks for all your advice so far! I ended up re-loading my CM ROM so that now at least I have Google Play Services and the Play Store working again... it was getting too frustrating trying to run without them and being unable to reinstall them. The ROM reload was successful and now at least I have Play Services/Store working again!

    I'll run my card through the utility you posted when I get home today and see how it turns out. Maybe I'll eventually try Link2SD again, but I'll be more careful with testing this time around and maybe pick up a 32 GB SD card instead!
     
  9. Kynztechy

    Kynztechy Member

    Joined:
    Mar 10, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Ratings:
    +0
    Current Phone Model:
    MICROMAX CANVAS JUICE 2 AQ5001
    Hello , I am new here so basically my problem is similar to @sixwordslong I have change the sdcard(before 16 gb) to 32 gb and I've created a partition of 4 FB with fat32 to both partition since I'm running stock ROM,after successful mount I linked some of the apps but after reboot they all disappeared and tried quick reboot from the app also no luck. If I check to /data/ext2 I can see all those apps . Can anyone help me please.

    Phone model : MICROMAX CANVAS JUICE 2 AQ5001 running lollipop 5.0 with stock ROM.
     
Search tags for this page
apps are not installd link2sd success
,
i lost all my apps on the 2nd partition of my sdcard after a reboot
,
link2sd app not installed
,
link2sd apps disappear
,

link2sd apps disappear after reboot

,
link2sd apps gone after reboot
,
link2sd google play services
,
link2sd linked apps missing
,
link2sd missing apps after reboot
,
link2sd not working after reboot