LED not working? Read this for the "fix"

Discussion in 'Bugless' started by gszeman, May 17, 2010.

  1. gszeman

    gszeman Member

    Joined:
    Apr 8, 2010
    Messages:
    506
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Novi, MI
    Ratings:
    +0
    Ok, so my LED used to work when I was on 0.9, I updated to 1.0 when it came out and they still worked. I was experimenting with some different ROMs, but quickly returned to BB...however, when I did my LED no longer worked. Yes, I wiped wiped wiped each time I switched ROMs, and did a clean install of BB1.0 and still nothing...

    After reading through all of the fixes, applying V1fixes.zip, and having no luck, I read a thread where someone mentioned an app for switching the trackball LED. I figured why not give it a try.

    Here is what I did, and now I have a working LED!

    1) Download "Nexus TrackBall Switcher" from the Market and install it.
    2) Open the program and select "enable trackball now" in the bottom left corner.
    3) Enjoy your working LED!

    I am afraid to mess with anything, but I have tested it and it works for e-mail and texts so far...I haven't received FB or Twitter updates, so I am not sure about those yet...but I'm not as concerned with those as e-mail and text.

    Let me know if this works for you guys as well...

    Good luck.
     
  2. GirLuvsDroid

    GirLuvsDroid Senior Member

    Joined:
    Feb 18, 2010
    Messages:
    1,551
    Likes Received:
    1
    Trophy Points:
    68
    Location:
    Wilmington, DE
    Ratings:
    +1
    Thanks for this gszeman! My LEDs were working fine until I did an experiment with a kernel and an older version of SetCPU and my Droid heated up to 160F in nothing flat and went into a boot loop. When I got my Droid running again, everything was fine except that my LEDs weren't working anymore.

    Your "fix" worked for me. One caution to anyone trying this -- don't change the settings from 00:00 and 00:00 -- I tried to do so and the LEDs stopped working again. I had to unistall Nexus Trackball Switcher and reinstall it, but everything's working now.
     
  3. droiddadi

    droiddadi Member

    Joined:
    Apr 24, 2010
    Messages:
    222
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Thanks OP. Will give it a try and report back
     
  4. superglen99

    superglen99 Member

    Joined:
    Nov 15, 2009
    Messages:
    779
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Auburn,WA
    Ratings:
    +0
    Hey thanks for the info. My LED works on and off so I just DL this, hope it works :)
     
  5. droiddadi

    droiddadi Member

    Joined:
    Apr 24, 2010
    Messages:
    222
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Led notification from touchdown email works. Missed call didn't work
     
  6. GirLuvsDroid

    GirLuvsDroid Senior Member

    Joined:
    Feb 18, 2010
    Messages:
    1,551
    Likes Received:
    1
    Trophy Points:
    68
    Location:
    Wilmington, DE
    Ratings:
    +1
    Unfortunately, this fix doesn't survive a reboot, at least for me. I've uninstalled the Nexus Trackball Switcher. Thanks for the tip, though!
     
  7. gszeman

    gszeman Member

    Joined:
    Apr 8, 2010
    Messages:
    506
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Novi, MI
    Ratings:
    +0
    Bleh...that sucks...I had my hopes up that this would work...I'll just hold out on rebooting for as long as I can :p

    Running BB, it isn't like I really need to reboot much anyways! :)
     
  8. shamus

    shamus Member

    Joined:
    Nov 20, 2009
    Messages:
    345
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    Pennsylvania
    Ratings:
    +3
  9. santos.moreno3

    santos.moreno3 New Member

    Joined:
    Mar 11, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    this didnt work for me unfortunately.... does anyone know why this happens
     
  10. thatguychuck

    thatguychuck Member

    Joined:
    Oct 31, 2009
    Messages:
    433
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    SD
    Ratings:
    +0
    Along the line somewhere (I think in ROM's build from source,) there is a setting for "trackball behavior." Depending on what you install, you loose access to change this setting. I think that's the ticket,
     
  11. shamus

    shamus Member

    Joined:
    Nov 20, 2009
    Messages:
    345
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    Pennsylvania
    Ratings:
    +3
    I think you're onto something.
    What I don't get is how that setting is still factored into the equation ever wiping, SBFing, installing new ROMs, etc.
     
  12. gszeman

    gszeman Member

    Joined:
    Apr 8, 2010
    Messages:
    506
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Novi, MI
    Ratings:
    +0
    I agree...I remember when I first got my Droid that there was a setting for the trackball. I remember thinking it was odd that it was there since there is no trackball on the Droid. When I started rooting and installing ROMs I couldn't find that setting anymore...

    Hopefully some people with pay grades higher than mine can figure this out for us...cause I like my LEDs!
     
  13. shamus

    shamus Member

    Joined:
    Nov 20, 2009
    Messages:
    345
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    Pennsylvania
    Ratings:
    +3
    Look on the first page towards the bottom.
    There is a link in my post. It's how I got around the same LED problem.
     
  14. gszeman

    gszeman Member

    Joined:
    Apr 8, 2010
    Messages:
    506
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Novi, MI
    Ratings:
    +0
    I just tested it, when you reboot, it defaults back to "disabled"...you just have to re-enable the trackball. Personally, I would rather have a working LED and deal with clicking the enable button once in a while (as I stated earlier I rarely reboot now that I have it set to how I want it), than to not have it at all.

    But hopefully this can be figured out without having to do a work-around.

    @shamus, thank you for your replies...I did try the nandroid backup and for some reason that didn't work for me either. I wiped, installed UD and didn't have any LED with that either...so I restored from one of my backups and that's when I tried the Nexus trackball "fix/workaround"
     
  15. sir2545

    sir2545 Member

    Joined:
    Nov 24, 2009
    Messages:
    249
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Charlotte, NC
    Ratings:
    +0
    My LED is working, but it only works when the screen is off/phone is locked. I never paid enough attention before I started rooting, is this normal?
     
Search tags for this page
how do you fix the led light on an android
,
how to fix android led
,
how to fix android phone led light
,
how to fix led light on an android
,

how to fix led light on android

,

how to fix led light on droid

,
how to fix led on droid
,
how to fix notification light on android
,
led fix on droid 4
,
led not working