1. DroidForums.net is currently undergoing a major software upgrade. If you are experiencing any problems logging in please: Contact Us

Landscape keyboard won't pop up

Discussion in 'Motorola Droid Pro' started by Kaos2flo, Feb 3, 2011.

  1. Kaos2flo
    Offline

    Kaos2flo New Member

    Joined:
    Mar 13, 2010
    Messages:
    264
    Likes Received:
    4
    Trophy Points:
    0
    Location:
    Tampa, FL
    Hey I'm using a third party keyboard and it won't pop up when in landscape. I'm not using the multi-touch keyboard that comes with the phone but one I downloaded from the market. I have tried a couple of different third party keyboard and none of them pop up. Is there anyway to fix this?
  2. guidot
    Offline

    guidot Developer Relations Staff Member Premium Member

    Joined:
    Feb 10, 2010
    Messages:
    7,350
    Likes Received:
    270
    Trophy Points:
    0
    Location:
    Massachusetts
    You need to activate them in keyboard&language.

    Sent from my GimpDroid (Installed by RZR).
  3. Kaos2flo
    Offline

    Kaos2flo New Member

    Joined:
    Mar 13, 2010
    Messages:
    264
    Likes Received:
    4
    Trophy Points:
    0
    Location:
    Tampa, FL
    I did this. I also long hold on the text field to change it to the third party keyboard. It's just that the Pro has something that prevents other third party keyboard from poping up. Does anyone know a fix for this?
  4. semya
    Offline

    semya New Member

    Joined:
    Jan 9, 2011
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    0
    it's a known issue. and there's already another thread on this here and on motorola forums. no help from them at all, btw. i have the fix. but i'm not entitled to post it here until the official release of the app. i'll do in a couple of days.
  5. google123
    Offline

    google123 New Member

    Joined:
    Sep 23, 2010
    Messages:
    472
    Likes Received:
    0
    Trophy Points:
    0
    Semya, can you PM this info to us??????
  6. semya
    Offline

    semya New Member

    Joined:
    Jan 9, 2011
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    0
    so, it's all about hardware keyboard which is constantly present in droid pro. soft keyboards just don't show up if your hardware keyboard is reported as being active. that's kind of normal I suppose, but not in case of the pro.

    this hint was actually posted by someone here. i then contacted Cyril from smart keyboard dev team. he promised to consider this feature to be added to his alternative keyboard. and he did! a couple of days ago i tested a beta version for him. it worked right away. then he just added the trigger to not show the soft keyboard in portrait mode. and that's it! it works like a charm.

    bought his smart keyboard pro 3.13 right away. the needed option is in Advanced Settings (called 'Ignore hard keyboard'). that's it. the guess of other user was correct. and Cyril was very fast to implement the fix. unlike the motorola guys, which I find very unprofessional and careless.

    so the solution for all of us is Smart Keyboard PRO: Smart Keyboard for Android
  7. google123
    Offline

    google123 New Member

    Joined:
    Sep 23, 2010
    Messages:
    472
    Likes Received:
    0
    Trophy Points:
    0
    Finally, alternate landscape keyboards..thanks semya

    [​IMG]

    I think I'm gonna start emailing other keyboard developers to see if we can get their software keyboards also working on the Pro in landscape such as TouchPal, Better Keyboard, and Swiftkey.[​IMG]
    Last edited: Feb 5, 2011
  8. Kaos2flo
    Offline

    Kaos2flo New Member

    Joined:
    Mar 13, 2010
    Messages:
    264
    Likes Received:
    4
    Trophy Points:
    0
    Location:
    Tampa, FL
    I tried the free version and it doesn't work. Do I have to get the pro version?
  9. mbd4524
    Offline

    mbd4524 New Member

    Joined:
    Nov 20, 2010
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    0
    I downloaded the trial version for pro in order to test out, however, I do not see the "disable hard keyboard" option.

    Sent from my DROID PRO using DroidForums App
  10. semya
    Offline

    semya New Member

    Joined:
    Jan 9, 2011
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    0
    check that it's version 3.13.0. and you can always email the author. it's so simple in android.
Search tags for this page

android keyboard won't pop up

,
droid charge how to pop up keyboard
,
droid pro landscape keyboard
,
how do i make my keyboard turn sideways on the droid m
,
how do you make your keyboard sideways on droid charge
,
how to fix keyboard side ways wont pop up
,
keyboard won't pop up for url search in portrait mode
,
kiis keyboard landscape
,
landscape wont work on motorola x
,
motorola droid x keyboard wont pop up
,
my landscape keyboard won't work
,
smart keyboard pro horizontal
,
smart keyboard pro landscape
,
surface pro keyboard won't pop up
,
why won't my droid landscape keyboard