Lags like a noob

Discussion in 'Droid RAZR MAXX' started by jman8526, Nov 23, 2013.

  1. jman8526

    jman8526 New Member

    Joined:
    Oct 28, 2010
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I'm running jellybean, and my Maxx lags HARD. So hard it drops signal sometimes. I notice it's especially bad when updating apps. Any suggestions? This is driving me nuts.
     
  2. leeshor

    leeshor Gold Member

    Joined:
    Jan 30, 2012
    Messages:
    4,363
    Likes Received:
    1,437
    Trophy Points:
    358
    Location:
    Norcross, GA - USA
    Ratings:
    +1,676
    The best solution, if not the really the easiest is a factory reset. If you have uncooperative apps or corrupt cache you could fight for a long time trying to find the problem(s). I don't suggest factory resets lightly.
     
  3. jman8526

    jman8526 New Member

    Joined:
    Oct 28, 2010
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Did that. It was good for a week. Then right back.
     
  4. leeshor

    leeshor Gold Member

    Joined:
    Jan 30, 2012
    Messages:
    4,363
    Likes Received:
    1,437
    Trophy Points:
    358
    Location:
    Norcross, GA - USA
    Ratings:
    +1,676
    That says a lot. If that worked for any length of time it's likely you have an app sucking up your processor. It could also be a problem if you use an SD card that is having issues. Install gSam Battery Monitor. It may give you some info on what's struggling.
     
  5. jman8526

    jman8526 New Member

    Joined:
    Oct 28, 2010
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Sounds good! I'm on it.
     
  6. jman8526

    jman8526 New Member

    Joined:
    Oct 28, 2010
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Weird that it locks up after updates, too.