Kernels battery drain and stuff

Discussion in 'Samsung Galaxy Nexus' started by swagmonster, Jan 29, 2012.

  1. swagmonster
    Offline

    swagmonster New Member

    Joined:
    Nov 4, 2010
    Messages:
    738
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    worcester,MA
    My android OS is taking up most of my battery on my dx it was last on list

    Attached Files:

  2. swagmonster
    Offline

    swagmonster New Member

    Joined:
    Nov 4, 2010
    Messages:
    738
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    worcester,MA
    Sorry bout the double post but I ment to include this pic as well
    Sent from my Galaxy Nexus using DroidForums

    Attached Files:

  3. untoothedyouth
    Offline

    untoothedyouth New Member

    Joined:
    Jun 18, 2011
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    0
    I have the same problem as a lot of us using the Verizon Nexus do. Waiting for an update to clear that up.

    Sent from my DROIDX using DroidForums
  4. BayouFlyFisher
    Offline

    BayouFlyFisher Rescue Squad Rescue Squad

    Joined:
    Dec 10, 2009
    Messages:
    4,966
    Likes Received:
    17
    Trophy Points:
    38
    Location:
    Baton Rouge, LA
    As noted in a lot threads on a lot of forums, there are some phones that have a problem with the Android OS and the "Keep Awake" time. There seems to be an issue with some phones not truly going to sleep when the power button is used to turn off the screen as opposed to letting the screen turn off automatically when the screen times out. This results in a very high time in the Settings/Battery/Android OS/Keep Awake menu.

    In stock form and with every rom that I have installed, my "Keep Awake" time was always about 50-60% of my total battery time. If the phone had been off charger for 8 hours, I'd have 4-6 hours of Andorid OS "Keep Awake" time. This was true even if the phone had been in my pocket unused and seems to be exacerbated by my habit of turning the screen off manually with the power button every single time. I used to never let the screen timeout.

    There seems to be two "fixes" according to Franco (of kernel fame). One concerns the camera. Seems the camera is started and then turned off during startup. But in so doing, it leaves a sensor active and this prevents the phone from actually going to sleep. So he recommends starting and using the back button to go back to the home screen. The other is DRM Protected Content. He recommends this be disabled or frozen. A third, that I don't believe I recall seeing him recommend but that I have seen on his thread at XDA (down for blackout right now) is to disable Maps.

    I have done all three of those and my Keep Awake time has gone from 40-50% of my total battery time down to a few percentage points. I mean if I don't use my phone it will now show less than a minute of Keep Awake time per hour.

    And of course you can try to help with this issue buy not using the power button to put the phone to sleep. Set the Screen Off time to about 30 seconds and then let the phone time out and turn the screen off automatically.
    Good luck
    [FONT=&quot][/FONT]
Search tags for this page

android kernel battery drain

,

android kernel draining battery

,
android kernel taking lots of battery
,
android os kernel draining battery in note 2
,
kernel (android os) battery drain
,

kernel android os battery drain

,
kernel android os keep awake
,
kernel battery drain
,
kernel battery drain android
,
kernel draining battery
,
kernel sucking kindle battery
,
note 3 android kernal killing battery