K-9 Mail can not send email

Discussion in 'Android General Discussions' started by jhanasik, Dec 22, 2009.

  1. jhanasik

    jhanasik New Member

    Joined:
    Dec 22, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hi All,

    I have downloaded and installed K-9 mail (I grew tired of the regular email app notifying me at 3 AM that there is a sale at JCPenney. I tried changing it to never check but it kept changing it back so I dumped it). K-9 mail installed went great except I can not send email. When it tries to connect to the outgoing server it says it can not connect. I have verified the SMTP settings, the user ID and password. I can not see anything wrong. Incoming is fine. Anyone else having an issue with outgoing? My next step is to contact the K-9 developers.
     
  2. SSHGuru

    SSHGuru Silver Member

    Joined:
    Nov 23, 2009
    Messages:
    3,824
    Likes Received:
    30
    Trophy Points:
    163
    Location:
    Fort Lauderdale
    Ratings:
    +30
    I've been using K-9 since it came out with no problems at all. Same server settings as the normal email...
     
  3. jhanasik

    jhanasik New Member

    Joined:
    Dec 22, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    OK. Let me ask this question to the forum users. Is anyone using K-9 mail that has Cox Communications (username@cox.net) been sucessful with sending email out from the Droid. I can not seem to fix the error Unable to open connection to SMTP Server even though I have K-9 set to the same SMTP server that I used for the default email and the default worked fine.
     
  4. BayouFlyFisher

    BayouFlyFisher Rescue Squad Rescue Squad

    Joined:
    Dec 10, 2009
    Messages:
    4,960
    Likes Received:
    17
    Trophy Points:
    153
    Location:
    Baton Rouge, LA
    Ratings:
    +17
    I use K-9 and have cox. Cox blocks port 25 and I've found no way around that. I tried other ports and not been successful. When I called Cox service, they said they do not offer support to cell phone users. I use my Gmail account to send now. :mad:
     
  5. jhanasik

    jhanasik New Member

    Joined:
    Dec 22, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thanks for the reply. It is strange though that the default email on the Droid would send or did I just imagine that. I will have to do the same, use GMail.
     
  6. newdroiduser

    newdroiduser New Member

    Joined:
    Mar 23, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    My Droid syncs up well with gmail, no problems. Microsoft Outlook is another problem. I have tried every fix but someone told me that the issue is with POP3 accounts not SMTP Server.Has anyone had any luck with K9 and POP3 accounts and receiving their outlook e-mails?? Any suggestions would be welcome. thank
     
  7. SSHGuru

    SSHGuru Silver Member

    Joined:
    Nov 23, 2009
    Messages:
    3,824
    Likes Received:
    30
    Trophy Points:
    163
    Location:
    Fort Lauderdale
    Ratings:
    +30
    K-9 works perfectly for me. Just make sure in outlook that you make the server save the email for 1 day so it goes to your phone also.
     
  8. BayouFlyFisher

    BayouFlyFisher Rescue Squad Rescue Squad

    Joined:
    Dec 10, 2009
    Messages:
    4,960
    Likes Received:
    17
    Trophy Points:
    153
    Location:
    Baton Rouge, LA
    Ratings:
    +17
    Mine works perfectly with my Cox.net account. I had absolutely no problems receiving emails from my cox.net pop3 account.

    Sending however was a bit of trouble initially. It turned out to be cox had decided to block port 25. I had to manually setup of the account and after much internet searching I found someone that got their cox account to send properly using port 587. It has worked faithfully for me since 11-18-09 using K-9.

    Good luck.
     
  9. PhoenixGTR

    PhoenixGTR Member

    Joined:
    Mar 22, 2010
    Messages:
    573
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Does K-9 have to delete the email from the server when it fetches it?
     
  10. jsh1120

    jsh1120 Silver Member

    Joined:
    Dec 9, 2009
    Messages:
    2,455
    Likes Received:
    1
    Trophy Points:
    103
    Location:
    Seattle, Washington
    Ratings:
    +1
    No. It's an option.
     
  11. PhoenixGTR

    PhoenixGTR Member

    Joined:
    Mar 22, 2010
    Messages:
    573
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Good. I'll give it a try; actually I already downloaded it. Where is the option what to keep/delete on the server? I can only find one for deleting messages. I guess that means the others stay on the server by default?
    Also, what's "expunge"? What are folder "classes" and how do I determine which are which class?
    How do you set when it syncs (or doesn't)?
    Sorry for all the questions but there doesn't seem to be a help file....
     
  12. jsh1120

    jsh1120 Silver Member

    Joined:
    Dec 9, 2009
    Messages:
    2,455
    Likes Received:
    1
    Trophy Points:
    103
    Location:
    Seattle, Washington
    Ratings:
    +1
    Look under account settings to find the option to delete on the server or not. Open the menu and tap "More" to get to account settings. Look under account settings for synching options, as well. But I believe that applies only to looking somewhere other than in the server "inbox." Mine is set to "never" and I get email delivered to K-9 automatically.

    Have no idea what "expunge" is. Wondered myself. It might mean a permanent delete.

    As for folder "classes," I believe they are the equivalent of top level folders with second tier being those contained within them but I haven't experimented with them.
     
  13. deubster

    deubster Member

    Joined:
    Dec 12, 2009
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    The problem is Cox, as correctly pointed out above. Cox does not allow its SMTP servers to be used to send if not connected to their cable network. Their explanation is that it allows them to control junk mail and virus transmission, and it does, in fact. The problem is Cox (I used to have Cox), there is no way to send unless on their cable. Period. End of story.
     
  14. PhoenixGTR

    PhoenixGTR Member

    Joined:
    Mar 22, 2010
    Messages:
    573
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Thanks. Mine's set to "poll never" too; that's the default, isn't it? I guess "poll" means "check for new messages (I thought so but it wasn't sure). One of the reasons I went looking for another email app is cos the default kept "polling" whether I wanted it to or not and "notifying" me of mail I'd read already...
     
  15. jhanasik

    jhanasik New Member

    Joined:
    Dec 22, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Strange, works fine for me to send and receive via COX after someone on this forum told me to change my port.
     
Search tags for this page
k-9 mail not sending
,
k-9 mail won't send
,
k-9 mail won't send email
,
k9 email not sending
,

k9 mail not sending

,
k9 mail unable to open connection to smtp server
,
k9 mail won't send
,
k9 not sending email
,
negative smtp reply 535
,
negative smtp reply 535 k9