Just imported a Motorola Pro on Android 2.2, works on o2, orange but not voda?

Discussion in 'Motorola Droid Pro' started by yodjone, May 27, 2011.

  1. yodjone

    yodjone New Member

    Joined:
    May 27, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Just imported a Motorola Pro on Android 2.2, works on o2, orange but not voda?
    I just imported a Motorola Pro from America, it says its global (which it seems to be) and is on Android 2.2

    It works when I place the SIM card in for O2, or Orange networks, however when I place my main Sim card in (Vodafone) which works in my other android phone (LG optimus gt540 and htc hd2 works) and blackberry but in my motorola pro it won't pick it up (Just says NO SIM DETECTED). the sim card is quite old but in perfect working order, any idea as to why its not working, could it be anything to do with the network settings for android? It won't let me manually add any values for it in android. but usually would pick this kind of stuff up

    ps. all sims are on contract

    do you think this is a software thing or hardware?

    any suggestions appreciated! many thanks!
     
  2. tennvol

    tennvol Member

    Joined:
    Nov 23, 2009
    Messages:
    320
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    Not sure. I've used a mobile, orange, and vodaphone sim (not a vzw voda one) and they all worked fine

    Sent from my DROID PRO using DroidForums
     
  3. yodjone

    yodjone New Member

    Joined:
    May 27, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I don't get why it'd do this, ive never had any problems with the SIM in the past on being recognised by any other phone even though its quite old, but it won't work in the Motorola Pro, and i don't have any other Vodafone sims to test it in to see if thats the issue, but im thinking it may be a software thing
     
  4. yodjone

    yodjone New Member

    Joined:
    May 27, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    nevermind fixed it, just re-set it to "global" in network mode