Jay

Discussion in 'Android General Discussions' started by jamesyboy, Jan 14, 2010.

  1. jamesyboy

    jamesyboy New Member

    Joined:
    Jan 14, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I'm trying to download this program to my Droid and it "says" that I need to have a device that is equipments with Microsoft mobile 2003 or higher. Is there some wis kid out there that can work around this?