1. DroidForums.net is currently undergoing a major software upgrade. If you are experiencing any problems logging in please: Contact Us

Issues with CM7 on the D2G - Rogers GSM network, no APNs?

Discussion in 'Cyanogenmod' started by seventieslord, Oct 10, 2011.

  1. seventieslord
    Offline

    seventieslord New Member

    Joined:
    May 16, 2011
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    0
    I'm posting this on the four android-related forums that I participate in, in hopes that someone has seen this before and knows what to do.

    Here's what I had:

    - Droid 2 Global, unlocked, rooted, with Fission ROM, using Rogers Wireless, a GSM network in Canada
    - it had been working just fine for 5 months

    Here's what I did:

    - Used RSDLite and the SBF loader to flash the stock 2.4.330 firmware as seen here: SBF - The DROID Wiki
    - ended up with a bootloop, as the directions said I would. cleared data and cashe, no problem, phone booted.
    - started up phone, switched to GSM mode, entered APNs, immediately had data service, tested phone functionality, all was well, used APN backup/restore and APN Manager to make backup files of my APNs
    - Used stock recovery mode to upgrade to 4.5.607 (gingerbread) firmware as seen here: 4.5.607 Firmware - The DROID Wiki
    - I used the file linked to from here: Gingerbread Build for the DROID2 Global Leaks - Droid Life: A Droid Community Blog
    - started up phone, switched to GSM mode, entered APNs, immediately had data service, tested phone functionality, all was well, used APN backup/restore and APN Manager to make backup files of my APNs
    - rooted phone using the adb method that is out there. rebooted and confirmed root access. installed a couple apps that need root. tested phone functionality, all was well. used APN backup/restore and APN Manager to make backup files of my APNs
    - As described here, CyanogenMod - The DROID Wiki Installed Droid 2 Recovery Bootstrap and ROM Manager in order to flash CWM. rebooted into CWM, factory reset, installed the latest release (10/06), and rebooted
    - started up phone, switched to GSM mode, phone app crashed immediately (as is to be expected, based on known bugs), rebooted for it to take effect

    Now here's the problem:

    - phone can make calls and receive texts with no problem, but cannot get data. wifi also works.
    - went into wireless settings, mobile networks, access point names, nothing shows up. Clicked "add APN". entered the APN info that had worked for me before at the past two junctions. hit menu button, then save. takes me back to the APN screen, but no APN shows up.
    - repeated this cycle a few times following reboots, etc. Eventually the phone gets to the point where the "add APN" button will not even come up when the menu key is hit.
    - during the above, was also checking the "network operators" setting. The phone does locate all of the networks that are "in the air" but no matter which one I choose it will tell me "your sim card does not allow a connection to this network"
    - used root explorer to check /data/data/com.android.providers.telephony/databases/telephony.db. There is a list of about 1500 APNs. There are multiple entries for Rogers including all of the ones I tried to enter that appeared not to save.
    - used APN backup/restore and APN manager to attempt deleting existing APNs, restoring the ones that were known to work, etc. Nothing works. These programs do work, and when I check the telephony.db file I can see what they have done to the file, but they are unfortnately unable to make any APN "stick" at the APN screen, and apparently that is the only way that it will work.

    more info:

    - I've noticed that the list of rogers entries seems to get larger and larger as I go through this process multiple times. I may be wrong, but it seems that this telephony.db file might not actually get changed or updated when you flash a new kernel/firmware/mod/rom to the phone.
    - I'm sure that the lack of a list of APNs and the "sim card does not allow connection" message are related. For whatever reason there seems to be a bug in CM7 where the telephony.db file has problems "talking" to the APN screen in settings. But it must not affect most people.
    - yes, I have tried a new SIM card.
    - yes, I have tried clearing cache, data, dalvik, and fixing permissions.
    - Anyone else on Rogers Running CM7 on a D2G? If so, I'd love to talk to you. Maybe I could convince you to send me a working CWM backup. I imagine that if you're a conscientious rommer, you have a backup made folling a fresh install of CM7.
Search tags for this page

cm7 apns wont save

,

cm7 network mode

,

cm7 network problem

,

cm7 not saving apn

,

cyanogenmod not save apn

,

fix gsm error on cm7 d2g

,

how to change apn settings on rooted droid x2 cm7

,

htc incredible cm7 no reception gsm sim

,

unable to get provider cannot open database telephony.db