Is it a brick or not a brick

Discussion in 'Droid Rooted Help' started by teddyearp, Apr 13, 2010.

  1. teddyearp
    Offline

    teddyearp Active Member

    Joined:
    Jan 13, 2010
    Messages:
    1,800
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Randle, WA
    OK, Rescue Squad, I've gotta good one for you. I was trying out the "works on any ROM kernel" (this thread http://www.droidforums.net/forum/an...vs-write-kernel-once-have-work-any-rom-2.html) last night and ran into a major roadblock, check my posts there to get started on my background.

    Anyways, as I said, I was wanting to get one of P3Droid's kernels working with my (backed up) DroidMod 1.0 rom, coming from the setup in my sig. I then thought I'd go to P3Droid's website and use the method(s) he had posted there. After all, P3Droid posted that he has modified his kernels using Koush's template so that they would work on "ANY ROM".

    Here's where it gets interesting(?). After using the method on P3Droid's website, my phone went straight to the bootloader screen upon the very next boot. Couldn't get out of it. Every thing I tried got me straight to a bootloader screen. (if anyone has doubts about whether or not I know what this means, google my user name).

    So, I use the ESD56 .sbf file to get myself to a place where I can easily get myself (back) forwards to where I want to (used to) be. The flash completes with a "PASS" message and I quit for the night last night. The only thing that 'nags' me is the fact that no matter what, my phone shows "No Service", a very odd thing as I can power up any old VZW phone here and it will either show Extended Network, or Roaming. I am running WinXP SP2, RSD Lite 4.6, MotoConnect 4.5.0 (needing .NET and installed); ALL working.

    OK, to this morning. Power on the phone, enable USB Debugging, install from unknown sources (basically following my own guides as they're really my own notes), then plug in, get the stuff I want in the right place and run this command:

    adb install dmupdater-10.apk

    Had success with that so went on about my business to root (over WiFi, as the phone shows "No Service") and restore my latest SPR backup (a DM1.0 w/ROM MGR), then went forward to Rom Manager to flash to CMR and restore my latest rom (in me sig). Knowing that all these nandroid backups have NOTHING whatsoever to do with the .03P radio, I then used Rom Mgr to try to update that. BTW, all this time "No Service" is my message, just thought it was due to the fact I still had to do the activation. NOT. The radio update failed with an "asserts" message. So I flashed back to SPR 0.99.3b and then tried every single variation of the .03P baseband update. With SPR I kept getting an "error 7" message.

    So, now, even though my phone 'looks' like it used to, it still shows "No Service" and a date of December 31, 1969.

    Now I must look deeper, and here is what's up. In 'Settings-> About Phone -> Baseband Version' it shows as "unknown".

    I know this post is VERY long, but I thought I should post as much info as I can.

    Moving forward, now whenever (or whatever) .sbf file I use I get to where RSD Lite shows "switching to BP pass-through", it hangs there and then errors out. Phone will show "SW Update in Progress", but eventually it will reboot and RSD Lite shows Flash Failure, error with BP pass-through. The phone is even re-booting every now and then, BUT IT DOES BOOT UP. It will show whatever f/w I choose to put on it, yet the baseband still shows "Unknown".

    I have tried everything I know. I have used the ESD20 .sbf, and used the old update files we had way back when we wanted to update manually to ESD56. I mean everything!

    But there is no way I can get my baseband to show anything but "unknown" and my phone to show anything but "No Service".

    In closing, I just wanted to re-iterate that the phone still re-boots on it's own accord, even when it's plugged into my comp (but not while flashing).

    Thanks.

    Well thank you LtKen for your honesty. I saw this "Rescue Squad" portion of the forum with it's own set of mods, so here's where I started. I then copied and pasted my OP all over the internet last night and got more info, and got it fixed WITHOUT having to get a new/refurb phone. :icon_ banana:

    Here's the answer:

    HowardForums: Your Mobile Phone Community & Resource - View Single Post - When is it my A855 REALLY a brick?

    And here's my answer:

    HowardForums: Your Mobile Phone Community & Resource - View Single Post - When is it my A855 REALLY a brick?

    So, the moral of the story is:

    1). A bricked phone is one that won't even power on, if you got some power, you've got hope.

    2). When using RSD Lite (or any REAL hacking software like that) Your mileage WILL vary.

    3). If you get to the point I was in my OP and don't have another computer, just go ahead and lie and go to the VZW store for a replacement, lol.

    Sure. Basically the solution to try if you have failures on using RSD Lite to flash your phone is to try uninstalling the drivers, RSD Lite, running a registery cleaner (I use ccleaner-free) after uninstall, reboot the computer and reinstall the drivers and RSD Lite. Have you phone in bootloader mode (hold 'up' d-pad key while powering up) then plug it in and let the drivers install before starting the flash. Now, if none of THAT works (it didn't for me), then either try a re-install of your whole OS or using another computer. This software plays nicest with Windows XP pro SP2 or SP3. I know, a re-install of the OS is a pain, but we used to do it every six months when flashing and playing with the old razr's etc.

    Now here's exactly what I did (I figured I'd take the fastest route possible):
    1. I grabbed my laptop which already had the Moto consumer drivers installed.
    2. Installed RSD Lite 4.6
    3. Put the phone in 'bootloader' mode
    4. Plugged it into my laptop, opened RSD Lite and let the additional drivers install
    5. Flashed the .sbf file that has ESD56 in it. Let it show 100% and my message in RSD Lite showed "Please manually power up the phone" and the phone had already powered up and was showing the Android.
    6. Unplugged the phone from my laptop, pressed the upper left, upper right, lower right, and lower left corners of the screen to get away from activation.
    7. Enabled on phone both USB Debugging and Install Apps from unknown sources. (menu -> settings -> applications #'unknown sources button at top'# -> developement #' usb debugging' at top)
    8. On my desktop I already had the "dmupdater-10.apk" file in my android sdk\tools directory, so issued the following command: adb install dmupdater-10.apk BAM!
    9. Fired up WiFi on my phone, opened DMUpdater, it wanted to update to dmupdater .11, then it said I needed to root my phone, let it download the file and followed the instructions, i.e. power off phone, reboot into recovery, etc.
    10. Upon powering phone back on, had to activate it, let it dial the # (*228) then select 1.
    11. Then signed into Google, entered the market and downloaded Rom Manager-free.
    12. The rest is just about history, let Rom Manager flash the CMR, then went to Manage backups, selected the one I wanted and let it restore.
    13. Then just to finish it off went through Rom Manager and did the radio update, I did have to re-activate my phone and using CM roms, you have to slide out your keyboard to use any number keys.

    There's a dozen different ways to get back to root etc. because there's a dozen different roms out there, this is what I did. Also, all the files and software I used are available in my repository below.

    good luck

    p.s. I know now that the first thing I'll be checking if I ever have to flash an .sbf file again is making sure NOTHING shows as "unknown' in menu -> settings -> about phone
    Last edited by a moderator: Apr 15, 2010
  2. gavron
    Offline

    gavron New Member

    Joined:
    Jan 29, 2010
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    0
    Install the latest baseband.
    *22891
    *22892

    If unsure, flash the ***ORIGINAL*** 2.01 SBF for everything. (google whatever you like, I'm not a moron). That will install the old baseband, ROM, etc. Then still *22891 and *22892.

    Your phone is not a brick (google me, really).

    E