Interesting ICS Issue

Discussion in 'Motorola Droid Bionic' started by GrimMeeper, Jun 25, 2012.

Thread Status:
Not open for further replies.
  1. GrimMeeper

    GrimMeeper New Member

    Joined:
    Oct 19, 2011
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hey I don't know if this issue was posted before or not: I briefly flashed ICS to my bionic (the one from a few days ago). At the same time, it so happened that I had to take the cable out of my router, because I wanted to connect it directly to my PC. Despite my router not being connected to my modem, my Bionic STILL SAID that wireless networks were connected, and would automatically disconnect me from 4G, leaving me with nothing but a phantom connection that didn't work. It seems as though it detected the router and could not distinguish if it was a working router or not.

    Is this helpful, or does it basically just read as "I am a Noob"?

    EDIT: i have since used rsd lite and some instructions from this site to return to .902 ---> .905.
     
  2. tcrews

    tcrews Premium Member
    Premium Member Developer

    Joined:
    Jan 27, 2010
    Messages:
    1,353
    Likes Received:
    22
    Trophy Points:
    53
    Location:
    Lexington, SC
    Ratings:
    +22
    A router doesn't need internet access to create a wireless network. So your devices (wireless) will still connect to a router that is on and broadcasting regardless of it having internet or not. This allows a completely private, internet free "internal" network between all your devices in your home (ie....laptop printing to wireless printer, laptop sharing files with pc, etc...).

    Your phone saw the wireless network your router was creating, it doesn't care if that wireless network has internet access. Wireless networks (WiFi) and Internet are two different things.
     
  3. jadesaber2

    jadesaber2 Member

    Joined:
    Dec 18, 2009
    Messages:
    64
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Raleigh, NC
    Ratings:
    +7
    Your router is still running a wireless network, even when it's not connected to the internet. That's what the phone is seeing, and connecting to.
     
  4. GrimMeeper

    GrimMeeper New Member

    Joined:
    Oct 19, 2011
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thanks for the explanation folks. But couldn't a savy smartphone programmer write a program that makes the smartphone "smart"? (i.e. it can actually verify if you'll be able to check your email or whatever, instead of just searching for a working router, before disconnecting 4G?)
     
  5. shaggykid

    shaggykid Member

    Joined:
    Nov 8, 2011
    Messages:
    503
    Likes Received:
    2
    Trophy Points:
    18
    Ratings:
    +2
    Couldn't you just turn wifi off?

    Sent from my DROIDX using DroidForums
     
  6. GrimMeeper

    GrimMeeper New Member

    Joined:
    Oct 19, 2011
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    No, I couldn't just turn my wifi off, because my router has threatened to contact social services if I do anything hurtful or abusive to it.
     
  7. nobreak1970

    nobreak1970 Member

    Joined:
    May 18, 2012
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    +1
    there ya go.
    I always keep wifi off when not using an actual wifi network.
     
  8. GrimMeeper

    GrimMeeper New Member

    Joined:
    Oct 19, 2011
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    my deleted post made no sense. i freely admit when i screw up lol
     
  9. GrimMeeper

    GrimMeeper New Member

    Joined:
    Oct 19, 2011
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    So it makes sense for the phone to say "Hey, I detected wifi...switching over now!" and then actively switch over from a working connection to nothingness? Because I unplugged a cable? Come on....that seems rather vindictive.
     
  10. nobreak1970

    nobreak1970 Member

    Joined:
    May 18, 2012
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Go into your wifi settings pick the network and then click the Forget button.
    Now it won't auto connect anymore.
     
  11. GrimMeeper

    GrimMeeper New Member

    Joined:
    Oct 19, 2011
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thank you so much for trying to help me. Obviously, I want it to auto-connect but only when there is a true internet connection available. Obviously, I want the phone to detect if there is an unplugged cable before disconnecting me from 4G. But thank you for your time, I guess. -GM
     
  12. tcrews

    tcrews Premium Member
    Premium Member Developer

    Joined:
    Jan 27, 2010
    Messages:
    1,353
    Likes Received:
    22
    Trophy Points:
    53
    Location:
    Lexington, SC
    Ratings:
    +22
    It can't and won't do that. It looks only for a WiFi signal. WiFi is not internet. It will connect to a WiFi signal if it sees one that you have connected to before. If you don't want it to do that....turn off your router. Why are you disconnecting your router but not turning it off?

    A wireless router broadcasts WiFi, not the internet. Typically the wireless router is connected to the internet and shares that connection over it's WiFi. If it's not connected to the internet.....it's still
     
Thread Status:
Not open for further replies.
Search tags for this page

meep wont connect to wifi