Incoming call problems w/ 2.0

Discussion in 'Liquid' started by snugenz, Jun 20, 2011.

  1. snugenz

    snugenz New Member

    Joined:
    May 28, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Does anyone else experience a problem when you answer your phone? Meaning the phone will think it's in speaker phone, you can hear the other party, but they can't hear you? Or just general problems of the phone taking forever to answer an incoming call? Also I noticed when a call does come through when I try to hang up it takes forever or will lock up... Just looking to see if this is just me... Thanks guys.
     
  2. rsimpson

    rsimpson Member

    Joined:
    Jan 4, 2010
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    This has been a pretty common issue and one I've experienced as well. I haven't seen any official comments on it. Lots of user chatter though.

    One thing I read somewhere is that custom ringtones can cause wake/lag issues. Try changing to/test a standard "out of the box" ringtone if you are using a custom one. I moved over to a standard ringtone a while back an my phone/wake/answer issues have largely gone away. I can't confirm if this is due to recent LGB updates or the fact that I'm using a standard ringtone.

    Also, not necessarily part of this issue, but a maybe contributing factor, is that in recent LGB updates (not sure it it's LGB or AOSP 2.3.4 specific), the screen turns on much slower than it used to, which to my taste, is rather annoying. I'd rather see the screen snap on from 0 to 100% without any transitional effect (not to be confused with LGB "screen wake animation", which I've unfortunately had to disable because of this "slow screen transition to on" thing).
     
    Last edited: Jun 20, 2011
  3. snugenz

    snugenz New Member

    Joined:
    May 28, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I use standard ringtones already -- I'm going to try setting my min clock to 400 and see if that fixes the issue... best of luck in figuring this one out.
     
  4. rsimpson

    rsimpson Member

    Joined:
    Jan 4, 2010
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Yeah, I tried that one too... with less than desirable results... it didn't seem to help the wake issue.

    FWIW, I've been sporting LGB 2.1 (beta, release candidates, final and release (wait for it) (donate and you too can be in on the fun)) for a bit now and the wake issue is much better. I'm actually going to (cough cough) try the 125 mhz min clock speed for a while.
     
  5. rsimpson

    rsimpson Member

    Joined:
    Jan 4, 2010
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Ok, so my phone doesn't like 125mhz. no way, no how. back to 250 for me.
     
  6. snugenz

    snugenz New Member

    Joined:
    May 28, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I'm using 250 - 800 with the smartass governor -- less problems thus far... We will see...
     
  7. illmatic636

    illmatic636 Active Member

    Joined:
    Jan 4, 2010
    Messages:
    1,420
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    NYC
    Ratings:
    +2
    Does switching out the kernel solve the issue?
     
  8. xtremeosiris

    xtremeosiris New Member

    Joined:
    May 7, 2010
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I have the same issue. Any use reflashing the Rom?
     
  9. snugenz

    snugenz New Member

    Joined:
    May 28, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Did a clean wipe on 3 separate occasions -- the problem also happened with 1.92. I have been using chevy's 125-800 lv kernel.
     
  10. skylordusa1

    skylordusa1 Member

    Joined:
    Aug 19, 2010
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I was experiencing this issue a lot a few days after I flashed LGB2.0. I would see the call come in and then swipe to answer and it would go right to speaker and also kinda lag and freeze. I was also hearing a crazy chirping sound which sounded like it was coming from the inside of my phone. It sounded almost like the phone was gonna blow up ahhahahahhahahh. Outbound calls were working fine. I was only having issues on Inbound calls. I went into Liquid Settings and then into System and ran Fix Permissions. Not sure if that did anything for this issue but it actually has went away. I have been receiving inbound calls fine for the last 2 days since running it. Give it a shot. May help.
     
  11. hrdnhvy

    hrdnhvy Member

    Joined:
    Mar 13, 2010
    Messages:
    613
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    WI
    Ratings:
    +0
    These probs "should" be taken care or in v2.1. (i say should because we all know how temperamental the d1 can be) all I know is they are all fixed on mine.
     
  12. snugenz

    snugenz New Member

    Joined:
    May 28, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Would you mind filling us in on clock frequencies, scaling type, and if you are using SetCPU or the integrated overclocking utility?
     
  13. chris79

    chris79 Member

    Joined:
    Jun 25, 2010
    Messages:
    98
    Likes Received:
    5
    Trophy Points:
    8
    Ratings:
    +5
    I've had that issue too. I've found that it is the SmartAss setting that is causing it. I changed it to On Demand and the issue no longer happens.

    Sent from my Droid using DroidForums
     
  14. JerrethS

    JerrethS New Member

    Joined:
    May 9, 2011
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Arizona
    Ratings:
    +0
    Incoming calls to speakerphone and system hang

    Hey I have been having this problem aswell i have tried all of your ideas none helped. I dont believe it is hardware related as i can go to a stock rom or for instance Peter Alfonso just came out with the 2.3.5 recently aswell and it doesnt have this problem. I would love to use the LGB 2.5 that came out but still having the problem is there any further insight on a fix for this?

    Thanks guys.
     
  15. baggar11

    baggar11 New Member

    Joined:
    Jun 29, 2010
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I've been having this problem on all of the GB releases since v2.2. I happened to install one of CorCor's kernels at the end of last week and am happy to say that I haven't had one incident where I haven't been able to answer my phone since.
     
Search tags for this page

android gingerbread speaker on when answering calls

,

droid gingerbread speaker on when answering a call?

,

what does restricted incoming calls on your android phone me