I hope this is an intelligent question

Discussion in 'Drod2169 - X' started by Ickythekid, May 3, 2011.

  1. Ickythekid

    Ickythekid New Member

    Joined:
    Apr 17, 2011
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I've been reading on rooting, roms, themes, and hacks for about a month now. I have a Droid X and it's rooted. I loaded DS 4.2 and it worked flawlessly, great rom. Now I've loaded Rubix and it's absolutely fantastic. I really liked DS but I think Rubix might be a bit more my style.

    My question is: from the reading that I've been doing I'm under the impression that because the boot loader is locked on the DX we're stuck with whatever kernel our phone had before flashing a rom. So I'm using Rubix, with a froyo base. Is this correct?

    And if that is so, do I want to go back to stock, flash the rooted GB to give the phone the GB base and then re-flash Rubix to gain the advantages of GB under the beauty of Rubix?
     
  2. lerit50

    lerit50 Member

    Joined:
    May 9, 2010
    Messages:
    158
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    This isn't a dumb question, don't worry haha. And it doesn't matter what you have on your phone pre-flashing the rom. I'm not very familiar with dx roms but if Rubix is based off of froyo then it will always have a froyo base. If it is built off of the gingerbread leak then it is a gingerbread rom. This is something you have to investigate with the rom itself.

    Comin' atcha from my fission'ed d2g
     
  3. mcp770

    mcp770 Member

    Joined:
    Nov 21, 2010
    Messages:
    596
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Nashville
    Ratings:
    +0
    Yes and no. Rubix 2.0.1 is froyo based and will only work on 2.3.340. Drod does however have a GB based rom called RUbiX Blurry Bread that can be installed over 2.3.3 rooted then 2.3.3 Deodexed versions of Gingerbread in that order. He hasn't updated to the newest version of GB yet however so in order to run blurrybread you have to install the two versions rooted then deodexed THEN blurrybread.

    I can say it ran very smooth and fast with great battery life. BUT, until he updates Blurrybread the easiest way to run GB unfortunately is to SBF back to stock 2.3.340 froyo then install the liberty toolbox donate version. In the donate version is a rom manager with a one click install to GB .588 and when .591 is done you will be able to just one click update to it as well. This will give you debloated tweaked Liberty GB. Or you could use the TBH app and update to rooted GB .591 leak that still has bloat and no mods if you choose.

    Seems very confusing but GB .591 was just leaked so if you want a tweaked version Apex, Zombie Stomped, and Liberty are all in the works but have GB .588 versions available and are all good roms. Just be careful to read update install instructions very carefully for each.
     
  4. Ickythekid

    Ickythekid New Member

    Joined:
    Apr 17, 2011
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    :icon_eek:

    I feel like my dad when I tell him how to use a computer when I'm reading that.

    I've got some more research to do.
     
  5. lerit50

    lerit50 Member

    Joined:
    May 9, 2010
    Messages:
    158
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Yeah before flashing anything make sure you know what you're doing. If you're new to this read a lot and then make a more informed decision.

    Comin' atcha from my fission'ed d2g