I don't think my Moto Z is auto switching to LTE when not in wifi range.

Discussion in 'Android Support' started by King Bengals, Feb 7, 2017.

  1. King Bengals

    King Bengals Member

    Joined:
    Jan 10, 2017
    Messages:
    46
    Likes Received:
    23
    Trophy Points:
    8
    Location:
    New York City
    Ratings:
    +23
    Current Phone Model:
    Moto Z Force -32G.
    When I'm in my apt I'm always on wifi. I've noticed the last couple times when I walked to the park & was not in wifi range I get a bubble notice "disconnected from wifi network". When I pull up a browser I can not get online. I get taken to a screen that says "choose your wifi provider" & there is a list of companies like TWC, Dish, Direct TV, COX etc.. Its seems like the phone is not automatically switching from wifi to the 4G LTE network when I'm out of the house. I had to manually turn off wifi to get on the LTE network. What I'm I doing wrong, do I have some setting not right?
    Thanks!
     
  2. Sajo

    Sajo Diamond Member

    Joined:
    Jan 25, 2013
    Messages:
    11,511
    Likes Received:
    7,220
    Trophy Points:
    1,863
    Location:
    Tennessee
    Ratings:
    +7,734
    Current Phone Model:
    Moto Droid Z Force
    Good morning. I'm not aware of any setting that should cause this, but it is possible. The phone should auto switch from wifi to LATE as soon as you leave wifi range.

    Sent from my XT1650 using Tapatalk
     
    • Agree Agree x 1
  3. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,546
    Likes Received:
    7,107
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,455
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    Have to agree with Sajo on this one. When you're not connected to wifi, LTE should kick in, even if you still have wifi turned on.

    It's odd to me that it's asking you to select your ISP as well.

    When was the last time you rebooted the phone?

    Has this been a problem since you got it, or just recently?
     
    • Like Like x 2
  4. Sajo

    Sajo Diamond Member

    Joined:
    Jan 25, 2013
    Messages:
    11,511
    Likes Received:
    7,220
    Trophy Points:
    1,863
    Location:
    Tennessee
    Ratings:
    +7,734
    Current Phone Model:
    Moto Droid Z Force
    I don't use WiFi often but connected to my home WiFi this morning before I took my daughter to school. Shortly after leaving the house, I noticed the WiFi icon disappear and the 4G / LTE icon turn white again as the phone auto-switched to LTE. When I dropped her off I unlocked my phone and opened a few apps and nothing popped up asking me anything about WiFi networks. Like Jonny mentioned, it is strange that the message is listing specific Internet & TV providers. It almost sounds like an app is installed that is triggering this popup and preventing the auto-switch to LTE.

    Which browser are you using? The stock Chrome browser?
     
    • Like Like x 1
    • Agree Agree x 1
  5. Sajo

    Sajo Diamond Member

    Joined:
    Jan 25, 2013
    Messages:
    11,511
    Likes Received:
    7,220
    Trophy Points:
    1,863
    Location:
    Tennessee
    Ratings:
    +7,734
    Current Phone Model:
    Moto Droid Z Force
    Does the popup look like this? Found this on another forum from a few years ago with no real solution, other than posts suggesting an app, or malware, was causing it.

    Use_WiFi.png
     
    • Like Like x 1
  6. King Bengals

    King Bengals Member

    Joined:
    Jan 10, 2017
    Messages:
    46
    Likes Received:
    23
    Trophy Points:
    8
    Location:
    New York City
    Ratings:
    +23
    Current Phone Model:
    Moto Z Force -32G.
    Wow Sajo that is exactly the screen I get!! My LTE indicator is on & my wifi indication has an exclamation mark next to it. I get that exact screen shot when I open any browser & try to go to a website.. I tried on Chrome (my default) & Dolphin & get the same error message. I have to manually turn off wifi then it goes to LTE & I can get online. So you think it could be a virus or bug? I hope not, I had an iphone since 2009 & never got a bug. I've had this Moto Z for month & 1/2 & hope I didn't catch something already. I have Avast app on my phone & its run scans before & not found anything. What should I do next?
     
    • Like Like x 1
  7. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,546
    Likes Received:
    7,107
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,455
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    I think it's less likely to be a bug and more likely to be some sort of app that's trying to help you, but getting in your way.

    Have you installed any apps that deal with wifi or connections in any way?
     
    • Like Like x 1
    • Agree Agree x 1
  8. King Bengals

    King Bengals Member

    Joined:
    Jan 10, 2017
    Messages:
    46
    Likes Received:
    23
    Trophy Points:
    8
    Location:
    New York City
    Ratings:
    +23
    Current Phone Model:
    Moto Z Force -32G.
    I uninstalled Avast since it was one of the 1st apps I got & one of the only apps I didn't have on my old iphone. All my other apps are pretty much the same as the one's I had on my iphone. I got all the apps from the Play Store. I don't have any apps that deal with WifiI specifically like a "wifi finder" or "wifi booster". I've been having this issue pretty much the day I got the phone. It took me awhile to notice the problem because I'm rarely not in a Wifi area. I've turned the phone off & on a couple time & still have the issue.
     
    • Like Like x 2
  9. Sajo

    Sajo Diamond Member

    Joined:
    Jan 25, 2013
    Messages:
    11,511
    Likes Received:
    7,220
    Trophy Points:
    1,863
    Location:
    Tennessee
    Ratings:
    +7,734
    Current Phone Model:
    Moto Droid Z Force
    You could try this, the next time you plan on leaving a WiFi connection. Put your phone in Safe Mode. Tap power like you are turning it off, but then long tap the Power Off message on the screen and select Safe Mode. The phone will reboot into Safe Mode and only the apps that came preinstalled will run. Don't manually open any apps. Make sure you are connected to Wifi and then leave as normal. When you lose the wifi connection, try to open a new browser page and see what happens. If you still get the same pop up message, a Play Store app may not be the problem and maybe a browser setting or something else. If you do not receive the pop up message then a Play Store app is probably causing the message. To exit Safe Mode just power off and then power back on again. Safe Mode will not wipe out any user data, but some Play Store apps that require a password may ask you to log in again since they didn't run while in Safe Mode.

    Sent from my XT1650 using Tapatalk
     
    • Like Like x 1
  10. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,546
    Likes Received:
    7,107
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,455
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    Agreed. This is the next step I'd try.

    Sent from my Pixel XL
     
    • Like Like x 1
  11. King Bengals

    King Bengals Member

    Joined:
    Jan 10, 2017
    Messages:
    46
    Likes Received:
    23
    Trophy Points:
    8
    Location:
    New York City
    Ratings:
    +23
    Current Phone Model:
    Moto Z Force -32G.
    Wow that is an interesting idea to try Sajo. I will try it as soon as I have a chance to get outside of my wifi range. I'll let you know what happens. Thanks!
     
    • Like Like x 2
  12. Sajo

    Sajo Diamond Member

    Joined:
    Jan 25, 2013
    Messages:
    11,511
    Likes Received:
    7,220
    Trophy Points:
    1,863
    Location:
    Tennessee
    Ratings:
    +7,734
    Current Phone Model:
    Moto Droid Z Force
    Safe Mode is a good troubleshooting tool any time you think a Play Store app is causing unexpected results, since most Play Store apps don't auto-run when in Safe Mode.

    Sent from my XT1650 using Tapatalk
     
    • Like Like x 1