How to un-set default for calling phone number

Discussion in 'Droid RAZR HD' started by ericsbcn, Mar 5, 2014.

  1. ericsbcn

    ericsbcn Member

    Joined:
    Sep 16, 2010
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    A while ago, when I tapped a phone number in my contacts, the phone would pop up a message asking if I wanted to complete the action with Skype or the phone dialer. At some point, I chose to always use the phone dialer and it doesn't aske me anymore.

    But now, I want to have it ask me again. How do I un-set the default? I tried clearing the defaults for both the contacts and phone apps, but it still doesn't prompt me. Any ideas how to do it?

    Thanks.
    - Eric S.
     
  2. doniago

    doniago Member

    Joined:
    Sep 19, 2010
    Messages:
    184
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Burlington, VT
    Ratings:
    +11
    If you go into Settings->Applications (at least that's how it's configured on my phone), you can click on the current default application and select "Clear Defaults".

    ETA - Just saw the last part of your post. In my experience that should work. Is there possibly another app handling the assignment that needs to be cleared out?
     
  3. ericsbcn

    ericsbcn Member

    Joined:
    Sep 16, 2010
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Well, I guess it's possible that another app is handling the default. But what I'm doing is opening a Contact and tapping on a phone number. It then goes to the dialer and dials the number. So it seems like it has to be either the Contacts or Phone app.

    - Eric S.
     
  4. sajokaz

    sajokaz Gold Member

    Joined:
    Jan 25, 2013
    Messages:
    2,486
    Likes Received:
    624
    Trophy Points:
    278
    Location:
    Tennessee
    Ratings:
    +689
    Current Phone Model:
    Moto Droid Maxx
    There is an option in Settings > Apps > Menu > Reset App Preferences. I believe that clears all "defaults" though, so if you do go that route, you might have to re-select a few other "always use this option" defaults if you have others setup. But that should clear the dialer issue.
     
  5. ericsbcn

    ericsbcn Member

    Joined:
    Sep 16, 2010
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Well, I did that and it didn't help. I still see the same behavior.

    But I have a theory about what's going on. I believe that apps "register" themselves as handlers for different actions. Then, when you do an action, the phone checks for all the apps that have registered for that action. If there are more than one, it pops up the prompt asking you which app you want to use and whether you want to do it once or always. My theory is that the phone can only find one app for the calling action -- the phone app -- and that's why it doesn't prompt me. So something must have happened with Skype that it isn't registered to be a handler for the calling action.

    I uninstalled and re-installed Skype. But that didn't change anything. I also checked the Skype settings to see if there was an option related to this, but didn't see anything.

    Maybe a Skype update caused this problem. I tried downloading a couple of apps that manage app defaults to see if I could find out how to check what actions Skype handles, but no joy so far.

    Maybe I'm just imagining it? Maybe Skype never was a handler for the call action.

    Anyone else have any insights?

    Thanks.
    - Eric S.
     
  6. PereDroid

    PereDroid Gold Member

    Joined:
    Jan 25, 2010
    Messages:
    2,260
    Likes Received:
    816
    Trophy Points:
    308
    Location:
    Cleveland, Ohio
    Ratings:
    +974
    Current Phone Model:
    Moto Turbo
    You reset APP PREFERENCES and it didn't help?
    That's really weird. It totally should have. Something is wrong with Skype then. Skype, as you say, is apparently not registered to handle calls. Try uninstalling Skype. Reset App preferences. Reboot the phone. Install Skype.
     
  7. ericsbcn

    ericsbcn Member

    Joined:
    Sep 16, 2010
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Yes, I reset app preferences and that didn't help.

    I just tried your procedure and that didn't help either. One additional thing I did was make sure Skype was running when I tapped the phone number in my contacts. It still went straight to the dialer.

    - Eric S.
     
  8. ericsbcn

    ericsbcn Member

    Joined:
    Sep 16, 2010
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Ah ha! I think I figured out what's going on. I think the contacts app is hard wired to use the phone app for dialing phone numbers. Here's why: If I have a contact open and it's showing a phone number, there are two icons to the right of the phone number. One is a phone icon and the other is the SMS icon. If I tap the SMS icon, it asks me whether I want to complete the action using Text Messaging, Hangouts, or Skype. But if I tap the phone icon, it goes straight to the dialer without asking me.

    I also just noticed another thing. I have an icon on my home screen to call my wife. If I tap that icon, it DOES ask me if I want to complete the action with Phone or Skype. So I guess THAT is what I was remembering and I indeed have that functionality back. It's possible that it never asked me which action I wanted when I tapped the phone icon in a contact.

    So, mystery solved... maybe. But unfortunately, I don't (and maybe never did) have the ability to choose Skype when I tap on a phone number in my contacts.

    Thanks.
    - Eric S.
     
Search tags for this page

android recent call default

,

droid turbo phone app recent calls default

,

how do i un default dialer for phone calls

,

how to set default number on droid max

,

how to set my phone number

,

how to undefault calls

,

how to undefault skype on phone