How to keep WiFi from continually activating???

Discussion in 'Samsung Galaxy S4' started by kevsgroove, Aug 12, 2013.

  1. kevsgroove
    Offline

    kevsgroove Member

    Joined:
    Jul 29, 2010
    Messages:
    262
    Likes Received:
    15
    Trophy Points:
    18
    Location:
    St. Louis, MO
    It seems that with my S4, WiFi wants to go active often. I then have to turn it off, only to find it on again within the next 30 minutes. Problem is, I only want it active when I'm at home, not everywhere it detects a wifi signal is available. I've gone through all the settings to the best of my knowledge, to only have it see (and activate) when I'm at home. Both Notify me and Auto-connect are unchecked. WiFi at work is weak and disconnects often so I stay on 4g there. Strange thing is, sometimes when I notice the wifi is on and searching and I turn it off, when I get home, it doesn't automatically activate.

    This was one of the great things about using Motorola's Smart Actions. WiFi would automatically turn on when I got home, then off when I left. Any thoughts or solutions, thanks.
  2. mountainbikermark
    Online

    mountainbikermark DF Super Moderator Staff Member Premium Member

    Joined:
    Sep 5, 2010
    Messages:
    3,368
    Likes Received:
    459
    Trophy Points:
    83
    Juice Defender will do the auto on/off based on location for you. There's a free and paid version on the Play store.
    I use toggle widgets for my Wi-Fi, data network and Bluetooth radios so I don't have to go into settings. There's a bunch out there both free and paid. Curvefish (the developer) ones are free and work very well along with having a small on-screen footprint. I use Easy Switch but it wasn't free.
    Hope that helps.

    Support Our Troops!!!
    <><
    A Rezound phone was used for this Tapatalk post
  3. dezymond
    Offline

    dezymond Tech Support Mod Staff Member Premium Member

    Joined:
    Nov 11, 2009
    Messages:
    10,782
    Likes Received:
    574
    Trophy Points:
    113
    Location:
    Bay Area, California
    BatteryGuru claims to control wifi based on your location, but I never had it enabled when I used it. I don't recall it allowing any custom location setting to leave wifi off though, JuiceDefender may offer that option.

    I don't get why your wifi seems to be turning itself on though, mine doesn't do that. I would check the boxes again, uncheck, then restart. After the restart then check to see if the settings are still as you left/want them.
  4. m3incorp
    Offline

    m3incorp New Member

    Joined:
    Sep 19, 2011
    Messages:
    116
    Likes Received:
    6
    Trophy Points:
    0
    Did you uncheck the box under WiFi settings where it says Auto-connect?
  5. FoxKat
    Offline

    FoxKat DF Super Moderator Staff Member Premium Member

    Joined:
    Apr 2, 2010
    Messages:
    8,612
    Likes Received:
    824
    Trophy Points:
    113
    Location:
    Pennsylvania
    Not trying to be adversarial here, just trying to clarify things. The OP said that Smart Actions would turn WIFI on when you arrive home and off when you leave. From what I remember, Smart Actions bedded WIFI on all the time in order for any location based actions to work. In fact Verizon created the Wifi Auto on-off on the Google Play Store (no longer there), to address this very concern.

    I used to use Verizon WIFI Auto on-off in conjunction with Smart Actions so the phone would make other changes based on where I was. I also used it to turn WIFI on and off depending on whether I was at home or at work. There are plenty of threads addressing this very peculiarity of Smart Actions. It was explained by both Motorola and Verizon that Smart Actions used WIFI and cellular towers, combined with GPS to increase location accuracy.

    Now on to the problem.

    There is a new app that replaces the Verizon app which was pulled. The new app is Wi-Fi Matic Auto WI-Fi On Off by Carlos Prados. It works exactly the same as the former Verizon app. Thus app may not cure the problem you're having, but once you resolve the WIFI coming on by itself, this will bring back the functionality you mention having before.

    As for the root problem, there are two screens in WIFI settings. The first is where you set it to Auto-turn on Wi-Fi (see first image)...

    View attachment 65403

    The second is the advanced settings, which odds reached by clicking the menu button and choosing Advanced. (see second image)

    uploadfromtaptalk1376457061257.jpg

    The settings in these two screens can be made to match mine, as I don't have that same problem. If that doesn't fix it, let us know. Good luck! :)

    Sent from my DROID RAZR using Tapatalk 2
    1 person likes this.
  6. kevsgroove
    Offline

    kevsgroove Member

    Joined:
    Jul 29, 2010
    Messages:
    262
    Likes Received:
    15
    Trophy Points:
    18
    Location:
    St. Louis, MO
    Yes, both the Notify Me and Auto-connect boxes are unchecked.










    Here's the screenshot from the Advanced WiFi settings. Looks like on the S4 they're setup a little different than the Razr Maxx.

    Screenshot_2013-08-14-20-56-07.png
  7. kevsgroove
    Offline

    kevsgroove Member

    Joined:
    Jul 29, 2010
    Messages:
    262
    Likes Received:
    15
    Trophy Points:
    18
    Location:
    St. Louis, MO
    Just installed the Wi-Fi Matic Auto WI-Fi On Off app by Carlos Prados. From the description, this is exactly what I'm looking for. It detected home WiFi immediately, and I'll see how it does in the morning when I leave for work. Thanks for the assist.
    1 person likes this.
  8. FoxKat
    Offline

    FoxKat DF Super Moderator Staff Member Premium Member

    Joined:
    Apr 2, 2010
    Messages:
    8,612
    Likes Received:
    824
    Trophy Points:
    113
    Location:
    Pennsylvania
    Glad it's working for you..but I knew it would so I had an advantage! :D

    Don't forget to add the work wifi to the profile. I'm sure this will solve your phone issues, and it allows location based tools which use wifi as a location identifier to work as well.

    Sent from my DROID RAZR using Tapatalk 2
Search tags for this page
galaxy s3 wifi keeps turning on
,

galaxy s4 keeps turning on wifi

,

galaxy s4 wifi keeps turning on

,
how to keep wifi off on galaxy s4
,
how to stop wifi from turning on galaxy s4
,
s4 wifi keeps turning on
,
samsung galaxy s4 wifi keeps turning on
,
why does my wifi keep turning on android
,

why does my wifi keep turning on galaxy s4

,
why does wifi keep turning on galaxy s4
,
wifi keeps turning on galaxy s3
,

wifi keeps turning on galaxy s4