[HOW TO] Fix Superuser Apps. Not Working After Installing Custom ROM

Discussion in 'Android Roms' started by maverick31210, Aug 31, 2010.

  1. maverick31210
    Offline

    maverick31210 New Member

    Joined:
    Aug 29, 2010
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    0
    (Not sure if this is in the right place, if not please move to appropriate location.)

    After installing Bugless Beast V0.4 for the first time, I noticed that none of my apps that required root access were working. I searched around the forums and only found partial answers. I went ahead and started a new thread and got the help I needed. So I am going to put that info here for anyone else who might be having a similar issue.

    Here is my original post, if this seems like your issue this is how to fix it.

    I have tried installing a few different roms and am having some issues. Would like to get these taken care of so I can go ahead and use some custom roms. Here's the breakdown; moto droid 1 p3 droid low voltage 1 ghz kernel on stock rooted froyo. I have tried installing the following roms;

    Bugless beast 4.4: installs but no apps that require root/superuser permissions work(rom manager, setcpu, etc...). I like this rom a lot and would like to know how to fix this issue.

    Chevyno1 simply stunning latest build: will replay droid logo and boot animation over and over. Does not revert to motorola logo, just droid and boot animation...not sure if that counts as a bootloop.

    Ultimate droid latest build: same exact issue as simply stunning rom.

    What could be causing these issues? Why does BB kill my root access and why won't the other roms get past boot screen? And how do I fix said issues?

    Thanks.


    First off, if you are rooted with EasyRoot, you will need to manually root your phone. Apparently EasyRoot has been known to be the culprit in many similar cases so let's go ahead and root manually. It's nothing to be afraid of. I was very leery to attempt this process but after actually diving in and doing it I realized that it is not a hard thing to do. Just make sure you follow instructions to a "T". It has been said before and I will say it again, it is very hard to brick your phone. Chances are you will mess up and have to start again which is time consuming but nonetheless will not break your phone.

    Start by manually rooting your phone with the information found here:
    http://www.droidforums.net/forum/rescue-squad-guides/74028-root-droid-1-regardless-os-version.html
    ^^^^^^^^^^^^^^^^^^^^^^^^^^
    This is where you want to closely follow directions. They are spelled out extremely well and everything you need to complete the procedure is listed for you. Go ahead and follow the entire process in that thread.

    -------------------------------------------------------------------------

    After following the process above, I was still having the same issues. I went ahead and performed a factory system restore. This may or may not be necessary seeing as how I did this before figuring out what the most likely cause of the issue was. So follow the next step before you do the factory restore.

    After you are manually rooted and your custom ROM is installed if your root access apps are still not working properly;

    Go to your home page.
    Touch menu.
    Select settings.
    Select applications.
    Select manage applications.
    Look through and find your Super User Permissions app. and select it.
    Go ahead and select clear data for the app.

    Now go ahead and try to access one of your root apps. They should now be working properly. If not go ahead and reboot your system normally and all should be well.

    Hope this clears up any issues you guys have just like I did.

    (It's been said before and I'll say it again. Myself and any author or contributor to any of the threads mentioned here are not responsible for any sort of damage done to your device.)

    Once again, Droid most Definitely Does :motdroidvert:

    -Maverick.
Search tags for this page
custom rom superuser
,
fix superuser permissions android
,
how to make super user work
,
my super user is not working
,
my superuser root did not work
,
rooted with poot but superuser stll not updating or working
,
super user app not working
,

superuser app not working

,
superuser fix permissions
,

superuser not showing any apps

,

superuser not working

,
superuser stopped working