[How To] Fine Tune Virtual Memory (Only In Bugless Beast!) 6/15/10

Discussion in 'Bugless' started by peteralfonso, Jun 16, 2010.

  1. peteralfonso

    peteralfonso Premium Member Premium Member Developer

    Joined:
    Mar 18, 2010
    Messages:
    844
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    *For Advanced Users Only*

    *If you adjust these settings I will not provide support*

    Navigate to /system/etc/sysctl.conf

    As you can see there are some virtual memory tweaks already in there that you all have been testing (in V0.2) and probably didn't even know it (I warned you by stating "experimental" in my ROM topic).

    These tweaks may or may not be causing your shutdown/reboot issues. I have raised the minimum clock speed to 250 and my shutdown/reboot issues completely stopped with me still using these tweaks.

    You can Google "sysctl.conf" or use bit.ly/aKp0zg as a reference for things you can add to the file and tweak.

    Enjoy, the added sysctl.conf support only found in Bugless Beast (for now until it's Kanged!) dancedroid
     
    Last edited: Jun 19, 2010
  2. Phxphenom

    Phxphenom Member

    Joined:
    May 12, 2010
    Messages:
    287
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I am not exactly sure what you want us to do here. I went into Root Explorer and found the following at sysctl.conf:

    vm.swappiness=0
    vm.dirty_writeback_centisecs=800
    vm.dirty_ratio=30
    vm.min_free_kbytes=2048
    vm.laptop_mode=1

    So please elaborate what is to be done. Thanks in advance, Pete.

    Marc
     
  3. peteralfonso

    peteralfonso Premium Member Premium Member Developer

    Joined:
    Mar 18, 2010
    Messages:
    844
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0

    More info will be found in V0.2.1, just preparing early :)
     
  4. Samurai26

    Samurai26 Member

    Joined:
    May 1, 2010
    Messages:
    330
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    +1, the refrences you suggested above are way above my head in terms of level of understanding
     
  5. Hacim

    Hacim New Member

    Joined:
    May 12, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    still rebooting

    Thanks for the update.
    I upped my clock to 250 and changed kernels and I'm still shutting down randomly. Its happened once in 30 minutes since I changed but ill continue testing.
     
  6. Phxphenom

    Phxphenom Member

    Joined:
    May 12, 2010
    Messages:
    287
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0

    Waiting on a tweet, lol
     
  7. peteralfonso

    peteralfonso Premium Member Premium Member Developer

    Joined:
    Mar 18, 2010
    Messages:
    844
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Its available now :)
     
  8. actngrezy

    actngrezy Active Member Developer

    Joined:
    Mar 21, 2010
    Messages:
    1,074
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    delaware
    Ratings:
    +2
    So im guessing you did a little bit more for this version then just fix the reboot problem:) Always working. you are the man
     
  9. peterpressure

    peterpressure Member

    Joined:
    Dec 21, 2009
    Messages:
    247
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I erased the "#" marks before each line, rebooted and am running fine with these tweaks!

    Thanks Pete!
     
  10. peteralfonso

    peteralfonso Premium Member Premium Member Developer

    Joined:
    Mar 18, 2010
    Messages:
    844
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    No problem, you should see increased performance and battery life :)
     
  11. breakingjessica

    breakingjessica Member

    Joined:
    Apr 18, 2010
    Messages:
    173
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Pittsburgh, PA
    Ratings:
    +0
    I'm running them as well. Thanks, Pete!
     
  12. Glueeater

    Glueeater Member

    Joined:
    Jun 9, 2010
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Just applied your settings…

    Will let you know if I get random reboots…

    edit: Your ROM also runs 10x smoother than stock FRF27 for me. Really appreciate you enhancing the experience.
     
  13. hexdaemon

    hexdaemon New Member

    Joined:
    Jun 6, 2010
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I entered su godmode and su sysrw in the terminal, but can't edit sysctl.conf in Astro. I can open them up in the file editor, but there is no way to save them. Am I doing something wrong?
     
  14. droidand1

    droidand1 New Member

    Joined:
    Jan 6, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    download root explorer, browse and hold click on the file and c)lick edit text editor :)
     
  15. droidand1

    droidand1 New Member

    Joined:
    Jan 6, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    pete, i know that you said that you are not supporting this,
    but i downloaded this pdf reference files and it blew my
    mind i could not comprehend.

    if i may ask, what values should i put if i want background apps to NOT be closed so fast (for example, currently my podcasts or browser is killed if I open new foreground apps)
    Thank you!
     
Search tags for this page
dirty ratio android
,
dirty writeback centisecs
,
dirty writeback centisecs android
,
min free kbytes android
,
sysctl android 2.1
,

sysctl.conf android

,
tuning vm performance android
,
vm min free kbytes
,
vm tuning android
,

vm.min free kbytes