How do you Delete Autofill Email Contacts?

Discussion in 'HTC Droid Incredible' started by ntech, Apr 6, 2011.

  1. ntech

    ntech New Member

    Joined:
    Apr 6, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I noticed with my Droid Incredible that previous email recipients are autofilled when I type in a letter that is the same as other email addresses I regularly send messages to.

    A lot of these contacts are people that I have emailed once and do not plan on emailing again. Does anybody know how to clear these autofill email addresses from the autofill memory? These are NOT email addresses in my contact list/address book.
     
    #1 ntech, Apr 6, 2011
    Last edited: Apr 6, 2011
  2. smtom

    smtom Member

    Joined:
    Oct 26, 2010
    Messages:
    281
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    The South
    Ratings:
    +0
    Are contacts saved on gmail and to the device? If they are not a gmail contact, perhaps something else containing contacts, like facebook? What else is synched?

    Sent from my ADR6300 using DroidForums
     
  3. ntech

    ntech New Member

    Joined:
    Apr 6, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thank you for your reply. I don't sync any contacts onto my phone. I don't use gmail or facebook. I have entered my contacts by manually setting up my contact list. As a matter of fact I don't sync anything.

    The email autofill feature is very similar to the calls placed feature on cell phones, however I am unable to erase the emails made that are stored in autofill memory.
     
  4. kjsasala

    kjsasala New Member

    Joined:
    Apr 13, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I have a Droid Pro and this has bothered me since I got the phone. Had some time today so decided to try and troubleshoot. I'm assuming here these phones are similar enough that you can follow the same steps on yours.

    What I noticed was the contacts that were popping up for me were people I've never even heard of. On closer inspection I was able to figure out that this lovely phone is saving EVERY address that's ever sent me an email or been included in an email (ie; forwards). I found my friends' aunts, uncles, brothers, you name it. My phone is not synced to any of my email accounts, yet if I delete a contact on my phone and later want to send them an email from my desktop, they are nowhere to be found. That being said, here's how to take the contacts from your history;

    from your messaging screen, select
    menu
    message settings
    email
    manage address history
    choose email account (if necessary)
    now the fun part, select EACH email addy you don't want and delete.

    I'd imagine this should be done every so often to keep them from piling up.

    Maybe there's an easier way, I am certainly no pro (especially with this Droid)
    Hope it works for you...
     
  5. hookbill

    hookbill Premium Member
    Premium Member

    Joined:
    Nov 30, 2009
    Messages:
    19,502
    Likes Received:
    8
    Trophy Points:
    168
    Location:
    N.E. Ohio
    Ratings:
    +8
    ntech, you have a Google phone. When you don't sync anything you don't have a back up.

    You should syng your Google account. It will also allow you to do more things with your phone using Google. Trying to avoid this is like spitting in the wind.
     
  6. ntech

    ntech New Member

    Joined:
    Apr 6, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thanks for your suggestions. Unfortunately my menu options are different from yours and I didn't see a "manage address history" selection. I will keep looking for it.
     
  7. hjc

    hjc New Member

    Joined:
    May 12, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    The answer is MENU-SETTINGS-APPLICATIONS- MANAGE APPLICATIONS- SELECT RUNNING- MAIL- FORCE STOP - CLEAR DATA- THEN REINSTALL YOUR EMAIL ACCOUNT.
     
  8. shstrang98

    shstrang98 New Member

    Joined:
    Jan 26, 2011
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
     
  9. shstrang98

    shstrang98 New Member

    Joined:
    Jan 26, 2011
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    You have to setup each mail account again? That seems like a bigger pain than deleting each address in manage address history. If you only have one account then I guess it's easy enough.
     
  10. yoppity

    yoppity New Member

    Joined:
    Sep 29, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    #$%€**+/#$€%

    c'mon lads...someone has to have a workaround for this.
    so annoying having incorrectly entered email addresses dropdown every single time, if I'm in a rush I keep accidentally clicking the wrong email address.
     
  11. knight1fox3

    knight1fox3 New Member

    Joined:
    Nov 17, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Great discussion! I've been trying to find a solution to this as well. I actually stopped in the Verizon store the other day to ask a tech. if they knew how to do this and of course the answer was, "hmm....not really sure". Wow, thanks a lot. Anyway, I thought about just removing the account and then adding it again but that is going to get pretty old. There has to be a better way. When I go into my "manage applications", and then the mail app that is running, the "clear data" button is grayed out. I forced a stop but the "clear data" never un-grayed (is that a word?). Hopefully we can find a work-around for this. BTW, I don't have a droid phone, but HTC. Same problem though. Hope we can come up with something.
     
  12. shovelgrrrl

    shovelgrrrl New Member

    Joined:
    Jun 6, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Actually, and oddly, the misspelled, corrupted (or just unwanted) email really is in your contact list or address book - it has wormed its way into your contacts, and must be fixed from a PC. I have never found a way to fix this from the phone. My Droid Mini syncs in the background and I think they all do, whether your have your contacts synced or not.

    Log into your email program from your PC, whether this issue is in Exchange or Gmail - log into the problem email, and go to "Suggested Contacts" or possibly "Other Contacts", and use the search box to search for the misspelled email exactly as it is wrong. A wrong suggested contact is in there, if its not those, it is in your main contacts as an incomplete contact, so keep searching in all the contact folders or sub-folders until you find it.

    Once you find it, select it and delete it. When your email syncs, it will delete the wrong or corrupted email address and stop auto-filling. Good luck.
     
Search tags for this page
android delete email address history
,
android email autocomplete
,
clear android email history
,
clear email history android
,
delete autofill email address android
,
delete email history android
,

how to delete autofill email address on android

,

how to delete email contacts on android

,

how to remove email contacts from android

,
remove email contacts android