How do I make my Droid X always have a data connection?

Discussion in 'Motorola Droid X' started by 05_GTOGUY, Jul 31, 2010.

  1. 05_GTOGUY
    Offline

    05_GTOGUY New Member

    Joined:
    Jul 31, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I searched the forums, but can't come up with a solid answer. I basically want my phone to be receiving data at all times so I instantly know when a new email comes in. I also like surfing the web, so right now I am connected to my WiFi connection at home. I went into the advanced settings as directed by another thread and selected that my phone "never" disconnect from the WiFi connection which is great when I am home. However, when I leave the connection range, I want the phone to be smart enough to then switch over to 3G automatically. I tested this before. I was connected to my WiFi connection and all is well. I then drove away some distance and when to use my phone, it showed the phone dropping the WiFi connection and then I opened my browser and got the could not load the page error. However, then my 3G connection kicked in as I was ok again. Basically, I had to use my phone to get it to realize it needed to switch back over to 3G. Obviously, I wouldn't be receiving email updates during this period. Is there anyway to make it do this transparently in the background? I love the phone, but this is kind of annoying me. I also did the little things like force data push. Let me know, thanks.
     
  2. mountaineerndixie
    Offline

    mountaineerndixie Active Member

    Joined:
    Feb 22, 2010
    Messages:
    1,073
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Charleston, WV
    Ratings:
    +2
    Go into "Accounts and Syc" in the settings and go to each account and select at what interval you want them to check for new messages and keep autosync on. I think I explained that right.

    Opening your phone was probably just coincidental to the 3G kicking in, as your voice service does not need the 3G to work. Sounds like it's already set up to kick in the 3G when a wifi connection isn't available so you should be ok.
     
  3. 05_GTOGUY
    Offline

    05_GTOGUY New Member

    Joined:
    Jul 31, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Yeah, I have my phone set to automatically push data as it arrives so that there should not be a delay when receiving new emails. However, if pushing is not available for whatever reason, I have the phone set to fetch the data every 15 minutes.

    I did some further testing today. I changed the WiFi setting to remain on only when plugged in. When I do it, it seems to stay on even when the phone is not plugged in, but after long periods of inactivity, the phone goes over to 3G. Then when I use it again, it goes back to WiFi. I will have to test it more tomorrow when I leave my WiFi radius again. By setting the phone to "never" to off the WiFi connection, I am wondering if that was causing some of my issues since it would constantly be looking for the WiFi connection and not use 3G. It is kind of weird how it all works.

    Again, I just want to make sure that my phone is receiving data at all times, even when I am not connected to WiFi, but I would like it to use WiFi when I am in range. I wish Android would give us a few more options or settings in this regard. Thanks for the help though.
     
  4. pilot25
    Offline

    pilot25 Member

    Joined:
    Nov 2, 2009
    Messages:
    697
    Likes Received:
    3
    Trophy Points:
    18
    Ratings:
    +3
    There is a problem with the WIFI and the X. It doesn't do WEP. If you have WEP switch it to WPA and the WIFI won't drop off.

    Rumor is it will be fixed in an update but don't hold your breath.
     
  5. GrillMouster
    Offline

    GrillMouster Member

    Joined:
    Nov 23, 2009
    Messages:
    289
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    When you turn on wifi the phone looks for available networks. If it detects a network to which it has connected in the past, it will automatically connect to that network. The moment the phone realized that your home wifi network was no longer in range, it was probably scanning the other wifi networks available. If your neighborhood is anything like mine, there are a hundred wifi networks available within walking distance. Eventually, when the phone realized that it cannot connect to any of them, it will switch to 3G. However, until the phone needs to sync data or an app/service requests network access, the 3G connection isn't actively pulling data. That's probably why there was a little delay when you first opened the browser outside of yoour home wifi area. If you hadn't opened the browser, an app would eventually try to sync or something, and that would have opened the 3G floodgate.
     
  6. 05_GTOGUY
    Offline

    05_GTOGUY New Member

    Joined:
    Jul 31, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0

    I am already using WPA. My WiFi connection is fine and it is never dropped. My issue was having the phone automatically switch over to 3G in the background (even when locked) when the WiFi connection was no longer in range. I seem to have fixed the problem. I set my phone to never disconnect from the WiFi connection when plugged in. Now, if I am not plugged in, it still tries to use the WiFi connection first. If I am out of range, it automatically knows to use 3G, even when the phone is locked. However, it will still switch to 3G even if I am in range of a WiFi connection if the phone has been locked for a while, but this is not a big deal since as soon as I unlock it, it uses the WiFi again if I am in range. So now, my phone is receiving data at all times and I am ok with that. :)
     
  7. renthorin
    Offline

    renthorin New Member

    Joined:
    May 20, 2010
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Dexter, MI
    Ratings:
    +0
    Is it true that if you enable wifi it will become the active connection, even if you have 3g connection?
     
  8. 05_GTOGUY
    Offline

    05_GTOGUY New Member

    Joined:
    Jul 31, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    In my experience, if you have WiFi enabled and it is in range then yes, it will become the active connection which is a good thing since WiFi is faster. However, if you are not in range of the WiFi connection, 3G is there.
     
Search tags for this page
android how to keep network connection alive when you turn display off
,

android keep data connection alive

,
can i make my droid x share its data connection.
,
droid x data connection
,
how to get better connection on a droid x
,

how to keep 3g connection alive on android

,
how to set data always on 3g android
,
keep 3g connection alive android
,

keep data connection alive android

,
make sure you have a data connection