1. DroidForums.net is currently undergoing a major software upgrade. If you are experiencing any problems logging in please: Contact Us

help with custom boot animation

Discussion in 'Android Themes' started by BlooS, Mar 19, 2010.

  1. BlooS
    Offline

    BlooS New Member

    Joined:
    Dec 25, 2009
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    0
    i tried to create my own bootanimation but when I restarted my phone I only got a black screen after the motorola M. I created the desc.txt folder and pasted the info in there and then copied the png images to part0. I followed the comrehensive guide for custom bootanimation.
  2. iliketigobittys
    Offline

    iliketigobittys New Member

    Joined:
    Apr 10, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Bump, same problem here.
  3. dief601
    Offline

    dief601 New Member

    Joined:
    Mar 7, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I am running into the same thing. I can load bootanimations made by others without any problems.
    But when i make one it will not play. I have one boot animation that is completely original.
    I made a second where i took the FKApple bootanimation and changed it a little but did not change the size of the png files or alter the desc file. I don't know if it is the way i compress it, I have tried both winzip and winRar (both trial version)
  4. liquidzgrl
    Offline

    liquidzgrl Premium Member Premium Member Developer

    Joined:
    Apr 10, 2010
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    PA
    I'm not sure without seeing the desc file or your pngs for the animation but some things to double check and consider...
    if you open your desc let's say for example this is what is inside:
    480 427 30
    p 1 0 part0
    p 1 0 part1
    p 0 0 part2

    the 480 427 is referring to the screen resolution size that will play on the screen

    the 30 is referring to the frames per second rate and how fast the animation will move

    the next three lines i have pasted above are showing part = p 1 0 part0 which is basically saying in laymans terms that part0 folder is going to play one time and not loop after the first time

    same for part1
    but part2 is going to loop and then stop when the phone boots

    as for the files in those part0, part1 and part2 folders you must make sure that your image names are correct and in sequence I have found it easiest to use my screen size for labeling 480_427_00000 like this but if you do make sure you have 5 digits at the end for some reason it doesnt like it when i use less

    the next image would be 480_427_00001, then 480_427_00002 and so on ...

    when you are all finished make sure they are all pngs all in sequential named order and that your desc is correct. After verifying, when zipping you must use STORE method because compressing the images at all during the zip process will cause it to malfunction.

    when you load it on the phone you MUST name is bootanimation.zip exactly like that or the phone will not recognize it as far as I have been able to tell.

    hopefully this helps a little. :)

    I have a thread with some custom animations in it if you wanna check it out you can download one of my animations and check out the structuring of my files and desc text if it might help.
  5. T2noob
    Offline

    T2noob New Member

    Joined:
    Mar 22, 2010
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    0
    Also make sure that you dont compress the .zip file because if the zip gets compressed you get a black screen.
    Most zipping programs have a store option or a no compression option, use one of these options and if the rest is right it should work.
  6. Dr01d
    Offline

    Dr01d New Member

    Joined:
    Jan 18, 2010
    Messages:
    133
    Likes Received:
    0
    Trophy Points:
    0
    Yes, that's what tripped me up for awhile.
  7. jmabry111
    Offline

    jmabry111 New Member

    Joined:
    Jun 2, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    It doesn't seem to matter what I put in the desc.txt for the width and height or framerate, everytime I reboot, the animation is squeezed down in height. Also, I'm getting a brief pause before the animation loops. My desc.txt looks like this:

    320 480 30
    p 1 0 part0
    p 0 0 part1


    and my png files are all 320px wide and 480px high.

    Any help or advice?