Help me please droid x problem

Discussion in 'Android Tech Support' started by Shazam91, Aug 21, 2010.

  1. Shazam91
    Offline

    Shazam91 New Member

    Joined:
    Dec 10, 2009
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    i rooted my droid x

    ran an update zip for 2.2

    then when i turned it back on it stayed at the m logo but the sounds continued and the phone worked normally except for the screen not changeing from the m.

    i also couldnt even go to the reboot recovery menu.

    how can i fix this
    its working for some strange reason but i when i turned it off again it had the same problem.

    PLEASE HELP ME!!!!!
  2. Shazam91
    Offline

    Shazam91 New Member

    Joined:
    Dec 10, 2009
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Bump for help
  3. Abe21599
    Offline

    Abe21599 DF Super Moderator Rescue Squad

    Joined:
    Dec 22, 2009
    Messages:
    6,345
    Likes Received:
    29
    Trophy Points:
    48
    Location:
    Ohio
    battery pull not fix anything? cant get into the bootloader?
  4. Shazam91
    Offline

    Shazam91 New Member

    Joined:
    Dec 10, 2009
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    First off thank you for taking a look.

    In answer no I can't go to the bootloader or the recovery. And the apps that I used to used to force a reboot into recovery aren't working. And cus of that I can't sbf the thing. And no the battery pull fixed nothing. After the 5th one it turned on again but still no recovery or bootloader.
  5. Abe21599
    Offline

    Abe21599 DF Super Moderator Rescue Squad

    Joined:
    Dec 22, 2009
    Messages:
    6,345
    Likes Received:
    29
    Trophy Points:
    48
    Location:
    Ohio
    so you have a dead screen but you can get it to work sometimes?
  6. Shazam91
    Offline

    Shazam91 New Member

    Joined:
    Dec 10, 2009
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Well sort of it gets stuck on the m logo screen. But other than the screen the phone works fine. I mean it made calls and reacted normally only I had to guess where icons were. And yes I got it to eventually turn the actual screen on.
  7. Shazam91
    Offline

    Shazam91 New Member

    Joined:
    Dec 10, 2009
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Bump for help
  8. Abe21599
    Offline

    Abe21599 DF Super Moderator Rescue Squad

    Joined:
    Dec 22, 2009
    Messages:
    6,345
    Likes Received:
    29
    Trophy Points:
    48
    Location:
    Ohio
    sorry for not replying i got so many threads in my subscrptions tehy just get lost..

    but i think id call vzw and tell them. i dont think you can fix this..

    still in the 30 days? take it back for a replacement
  9. Jonny Kansas
    Offline

    Jonny Kansas Premium Member Rescue Squad Premium Member

    Joined:
    Jan 21, 2010
    Messages:
    2,686
    Likes Received:
    10
    Trophy Points:
    0
    Location:
    Michigan's Upper Peninsula
    You got the actual screen to show up, as in the M logo was gone and your screen looked like it should when fully booted up? Did you try booting into recovery when that happened?

    If you can eventually get the actual screen to show up, I'd recommend uninstalling and reinstalling your app(s) for forcing a boot into recovery to see if that works.

    When the actual screen comes on, do you still have root? Wondering if that's part of the issue...

    Emitted from X.
  10. Shazam91
    Offline

    Shazam91 New Member

    Joined:
    Dec 10, 2009
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    i cant get into recovery mode at all. i uninstalled all the apps that do it and reinstalled them to no avail.

    when the actual screen comes back i am still rooted.
  11. Shazam91
    Offline

    Shazam91 New Member

    Joined:
    Dec 10, 2009
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Bump for help
  12. Abe21599
    Offline

    Abe21599 DF Super Moderator Rescue Squad

    Joined:
    Dec 22, 2009
    Messages:
    6,345
    Likes Received:
    29
    Trophy Points:
    48
    Location:
    Ohio
    while powering up, hold camera and volume down. can you get a screen to come up?
  13. Shazam91
    Offline

    Shazam91 New Member

    Joined:
    Dec 10, 2009
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    yes i get a screen to pop up. then i tried using that screen to sbf it and that didnt work the m logo stuck their again. i tried it twice. help please.
  14. Abe21599
    Offline

    Abe21599 DF Super Moderator Rescue Squad

    Joined:
    Dec 22, 2009
    Messages:
    6,345
    Likes Received:
    29
    Trophy Points:
    48
    Location:
    Ohio
    did you boot into recovery and wipe data/cache after the SBF flashed?
  15. Kerryoot
    Offline

    Kerryoot New Member

    Joined:
    Nov 27, 2010
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
  16. Abe21599
    Offline

    Abe21599 DF Super Moderator Rescue Squad

    Joined:
    Dec 22, 2009
    Messages:
    6,345
    Likes Received:
    29
    Trophy Points:
    48
    Location:
    Ohio
  17. skennelly
    Offline

    skennelly Active Member

    Joined:
    Oct 27, 2010
    Messages:
    579
    Likes Received:
    29
    Trophy Points:
    28
    Location:
    Illinois
    I am having the exact same issue. Whenever I power down my X, I turn it back on and get the M logo. I can hear the phone starting like Jonny says. I have to pull battery 1-3 times to get it to boot properly. I can't force into recovery and just tonight downloaded quick boot to try to get into recovery but that did not work either.

    I am on my second X now (first one the camera quit working). Motorola is really pi$$ing me off. They build junk!

    I think this one will be going back too.
  18. MAD450r
    Offline

    MAD450r Theme Developer Theme Developer

    Joined:
    Apr 21, 2010
    Messages:
    1,297
    Likes Received:
    1
    Trophy Points:
    0
    Just a suggestion

    when it does boot ok go in settings and do a system reset. I full reset I had this issue on my first one. I fixed it before the new one showed up so I still sent it back but it was needing a data reset fully then I was able to sbf it. Otherwise it was failing the sbf. Most likely the cause for the fail is removed bloatware :(