Help Installing Liberty ROM

Discussion in 'Android Roms' started by sycosquirl18, Aug 1, 2011.

  1. sycosquirl18

    sycosquirl18 New Member

    Joined:
    Aug 1, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hey all, I've tried my best to search for a similar problem on the forums and elsewhere but no solution has quite worked right. I installed Liberty ROM 2.0.1 a few months ago onto my Droid 2, using Droid 2 Bootstrapper. I followed the instructions (that I got from many sources), to wipe the cache before install, backup, etc. Liberty loaded onto my phone correctly, but with some problems:

    * Camera did not work (oops! could not connect to camera error or similar upon opening camera app. I tried the stock, blur, and liberty camera apps with no success).
    * The accelerometer was not functioning. Fortunately the keyboard could be used to turn the screen sideways, but this made many apps impossible to use.
    * Youtube videos and mp3's could not be played. (Very oddly, I couldn't even send mp3's via email. Other files would send fine, but mp3's would always be sent as an empty file.)
    * There were daily crashes/hot reboots. This I don't mind very much, but the other 3 problems were crippling.

    I finally got rid of Liberty (after reflashing it at least 4 times, so as to rule out an unlucky install) and flashed the gingerbread 2.3.320 sbf onto my phone for the heck of it, and have left it at that. So my question is, what did I do incorrectly? Do I need to have a certain sbf/rom on my phone BEFORE I flash Liberty? Did I use the wrong version of Liberty? (They all say DX rather than D2, but I could not find one labeled D2).

    --
    Also, to help me better understand what is going on myself, if somebody could explain the difference between an sbf and a rom that would be very helpful. I noticed that an sbf flash requires me to reactivate my phone, while a rom flash only makes me reconnect my google account.