Solved Headset controls always launch Audiobook app

Discussion in 'Android Support' started by Lauris, Apr 28, 2015.

  1. Lauris

    Lauris New Member

    Joined:
    Jan 25, 2015
    Messages:
    10
    Likes Received:
    3
    Trophy Points:
    3
    Ratings:
    +4
    Current Phone Model:
    Samsung Galaxy S2+ CMOD 12.1
    I want to use my headset controls to control music currently playing, but the function is always hijacked by Smart Audiobook Player. Not so smart after all, eh?

    What can I do about it?
     
    • Funny Funny x 1
  2. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,531
    Likes Received:
    7,090
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,437
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    There should be an option in the main settings menu of the phone under accessories that I'm fairy sure is causing this issue. Depends on the device, of course, but I'd think that's where the problem lies.
     
  3. Lauris

    Lauris New Member

    Joined:
    Jan 25, 2015
    Messages:
    10
    Likes Received:
    3
    Trophy Points:
    3
    Ratings:
    +4
    Current Phone Model:
    Samsung Galaxy S2+ CMOD 12.1
    I haven't seen any such settings. Running Lollipop 12.1.
     
  4. Jeffrey

    Jeffrey Premium Member
    Premium Member

    Joined:
    Jan 30, 2012
    Messages:
    6,686
    Likes Received:
    3,548
    Trophy Points:
    1,578
    Location:
    Thailand
    Ratings:
    +4,036
    Current Phone Model:
    iPhone 7 Plus JB
    Do you use Smart Audiobook Player? If not disable it.
     
  5. Lauris

    Lauris New Member

    Joined:
    Jan 25, 2015
    Messages:
    10
    Likes Received:
    3
    Trophy Points:
    3
    Ratings:
    +4
    Current Phone Model:
    Samsung Galaxy S2+ CMOD 12.1
    Can you elaborate? You answer seems self-contradictory :). Disable what?
     
  6. Jeffrey

    Jeffrey Premium Member
    Premium Member

    Joined:
    Jan 30, 2012
    Messages:
    6,686
    Likes Received:
    3,548
    Trophy Points:
    1,578
    Location:
    Thailand
    Ratings:
    +4,036
    Current Phone Model:
    iPhone 7 Plus JB
    I asked if you use Audiobook Player. If you do not use it, disable the App and it will not hijack your music App.
     
  7. Lauris

    Lauris New Member

    Joined:
    Jan 25, 2015
    Messages:
    10
    Likes Received:
    3
    Trophy Points:
    3
    Ratings:
    +4
    Current Phone Model:
    Samsung Galaxy S2+ CMOD 12.1
    Oh, of course I do use it, otherwise I wouldn't even have it installed :).
     
  8. Jeffrey

    Jeffrey Premium Member
    Premium Member

    Joined:
    Jan 30, 2012
    Messages:
    6,686
    Likes Received:
    3,548
    Trophy Points:
    1,578
    Location:
    Thailand
    Ratings:
    +4,036
    Current Phone Model:
    iPhone 7 Plus JB
  9. Lauris

    Lauris New Member

    Joined:
    Jan 25, 2015
    Messages:
    10
    Likes Received:
    3
    Trophy Points:
    3
    Ratings:
    +4
    Current Phone Model:
    Samsung Galaxy S2+ CMOD 12.1
    You're right, I installed Google Play Music and it seems to work fine!
    I also tested whether it would hijack the controls when playing an audiobook, but it's not the case, seems to work perfect now, thanks! :)
     
    • Like Like x 1
  10. Jeffrey

    Jeffrey Premium Member
    Premium Member

    Joined:
    Jan 30, 2012
    Messages:
    6,686
    Likes Received:
    3,548
    Trophy Points:
    1,578
    Location:
    Thailand
    Ratings:
    +4,036
    Current Phone Model:
    iPhone 7 Plus JB
    Glad you got it resolved..
     
  11. thunderbolt_nick

    thunderbolt_nick Thunderbolt Rescue Squad
    Rescue Squad

    Joined:
    Nov 22, 2011
    Messages:
    1,194
    Likes Received:
    603
    Trophy Points:
    1,268
    Location:
    Orlando, FL
    Ratings:
    +724
    Current Phone Model:
    Nexus 6P
    Twitter:
    @nickburress2k2
    There is a setting in Smart AudioBook player to where it will take control of headsets and launch the app. Open Smartbook Audio Player. Click on the Hamburger Menu in the upper right and go to Settings then Playback. There's an option called 'Play on Headset Connect.' Make sure that is unchecked.
     
    • Like Like x 1
Search tags for this page

smart audiobook player headphone button

,

smart audiobook player headset