Have to hit refresh to get email?

Discussion in 'Android General Discussions' started by Candice, Feb 11, 2010.

  1. Candice
    Offline

    Candice Member

    Joined:
    Feb 8, 2010
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Minnesota
    Ratings:
    +0
    Yesterday, (D-1 of droid ownership) my email worked flawlessly. I was receiving email in a timely manner (I didn't compare online to phone because I didn't care too much.) But today, I've been working on my computer and I noticed that I haven't received one single email. (which is weird) So I logged into gmail and I had 10 sitting in my inbox and not a single one pushed to my droid. I hit refresh on my droid, and they showed up.

    So my question, is this just a gmail/verizon/service issue at the moment, or will I always have to hit refresh to get my email? Or is there some setting that needs to be adjusted? (I didn't change anything between last night and this morning, that i know of anyway.)

    If this question has been asked before, I apologize.
  2. joshua117
    Offline

    joshua117 Member

    Joined:
    Dec 8, 2009
    Messages:
    207
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    first welcome:)

    now go to your setting and make sure that you have put a check mark on "sync settings" for Gmail. if that does not work try powering off your phone turn it back on and go to the google talk (it should sign in with your gmail info. you don't have to do anything with gtalk after its signed in) don't ask me why but thats what i had to do for mine. then my email worked fine after that. hope that helps
  3. Candice
    Offline

    Candice Member

    Joined:
    Feb 8, 2010
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Minnesota
    Ratings:
    +0
    Well it works now. I didn't do anything, but I did check to see if sync was on. (It was) I'm hoping it was just a fluke thing.

    Thanks for the help though. :)
  4. joshua117
    Offline

    joshua117 Member

    Joined:
    Dec 8, 2009
    Messages:
    207
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    no problem, glad to hear it started working for you.
  5. Scribble
    Offline

    Scribble Member

    Joined:
    Jan 21, 2010
    Messages:
    387
    Likes Received:
    6
    Trophy Points:
    18
    Ratings:
    +6
    perhaps you were just not receiving cell reception? :p
  6. dazer.tv
    Offline

    dazer.tv New Member

    Joined:
    Dec 27, 2009
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    While we are on the topic... I have several none gmail accounts the I check through my Droid using the @email program that comes with the Droid and it never checks my emails for me I always have to go through each account manually and refresh each one. Even when I use the "combined inbox" button.
    What should I do????
  7. Candice
    Offline

    Candice Member

    Joined:
    Feb 8, 2010
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Minnesota
    Ratings:
    +0
    That would make sense cuz I get crappy service in my house (thank GOD for wifi and standing by the window to make a call, lol) but I shut off the wifi before I went to bed last night and I still got email until 3am. Then I turned on the wifi when I got up and nothing....

    *shrug* I don't know what the deal was. And now that I've just checked, I had to hit refresh again. But this time, wifi had turned itself off? *eyeroll*

    Hopefully I'll get it figured out. I don't want to have to keep refreshing every time I think I might be getting an email. That kind of defeats the purpose, right? lol
  8. Scribble
    Offline

    Scribble Member

    Joined:
    Jan 21, 2010
    Messages:
    387
    Likes Received:
    6
    Trophy Points:
    18
    Ratings:
    +6
    Wifi by default is setup to disconnect when the phone goes into sleep mode. So you need to change that in the wifi advanced settings menu.


    Also check your gmail settings and see how long it's set to wait between syncing.
  9. Jonny Kansas
    Online

    Jonny Kansas DF Super Moderator Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    4,757
    Likes Received:
    759
    Trophy Points:
    258
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +807
    Current Phone Model:
    Note 4
    Twitter:
    jonny_ks
    I believe there's a setting in the Email program about e-mail check frequency, though it did seem to not always be very accurate when I used it.

    You can allow gmail to check your other e-mails by following this advice, http://www.droidforums.net/forum/dr...66-droid-hints-pop3-gmail-forwarding-you.html

    Or you should check out the market app called K9. It's an e-mail app and I've heard nothing but good things about it.

    As to the original poster, I was in another thread on this same topic a couple days ago. We figured out that if you clear the cache from your gmail app once in a while, it seems to do a better job at bringing in newer mail. Since gmail is supposed to push mail to the phone, not sure if that's actually the case, but we all feel like we saw results after trying it...
  10. Candice
    Offline

    Candice Member

    Joined:
    Feb 8, 2010
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Minnesota
    Ratings:
    +0
    Changed the wifi settings.

    But even without changing any settings, it comes and goes at will it seem. For an hour it works fine, getting true up-to-the-minute email alerts, then the next it's just sort of haphazard, then fine again. *shrug*
  11. Candice
    Offline

    Candice Member

    Joined:
    Feb 8, 2010
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Minnesota
    Ratings:
    +0
    But I've only had my phone for 24 hours, I received maybe 2 dozen emails between last night and this morning. Would that small amount cause that kind of problems?
  12. mjw51
    Offline

    mjw51 New Member

    Joined:
    Dec 23, 2009
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    eyahoo email on droid x fri 1 14 11

    instead of email appearing
    i need to hit refresh any ideas why

    thanks
  13. rosem119
    Offline

    rosem119 Member

    Joined:
    Aug 21, 2010
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Make sure you have the power control widget loaded on one of your homescreens and that the sync button on the widget is on.

    Sent from my DROID2 using DroidForums App
  14. mjw51
    Offline

    mjw51 New Member

    Joined:
    Dec 23, 2009
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    never had to do that before
  15. rosem119
    Offline

    rosem119 Member

    Joined:
    Aug 21, 2010
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    You should only have to do it once, and then leave it there.

    Sent from my DROID2 using DroidForums App
Search tags for this page
android email refresh rate
,
change email refresh times galaxy s4
,
email doesnt refresh galaxy s4
,
i have to refresh to check email
,
i phone 4 doesnt get emails when one is sent you have to refresh
,
refresh email on droid
,
why do i have to keep hitting refresh to get my new emails
,

why do i have to refresh my email

,
why do i have to refresh my email to receive new emails on g
,
why do i have to refresh my phone to get emails