1. DroidForums.net is currently undergoing a major software upgrade. If you are experiencing any problems logging in please: Contact Us

Has anyone gotten Exchange mail working on 2.2 yet? I can't

Discussion in 'Android Roms' started by lokiju, Jun 6, 2010.

  1. lokiju
    Offline

    lokiju New Member

    Joined:
    Nov 7, 2009
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    0
    RESOLVED!!! - Has anyone gotten Exchange mail working on 2.2 yet? I can't

    Doing the ultimatedroid froyo, everything goes fine but I cannot get my exchange email work to save my life.

    I do all the same settings I did in 2.1 and it tells me that my settings are incorrect.

    I've tried every possible way to set the settings as well (I'm a sys admin that manages exchange fwiw) and I can't figure it out, it's like it just can't work for some reason.

    Has anyone else been able to get their exchange email working on 2.2?

    Update: SUCCESS!!!!!!!

    It was the IIS 7 cert setting for active sync.

    It was set to accept and after changing it to ignore and recycling IIS it's working!!! YES!!!
    Last edited: Jun 7, 2010
  2. Rated_R
    Offline

    Rated_R New Member

    Joined:
    Dec 29, 2009
    Messages:
    184
    Likes Received:
    0
    Trophy Points:
    0
    UD roms are not supported here. Go check blackdroidmods.com for support.
  3. dmacleo
    Offline

    dmacleo Premium Member Premium Member

    Joined:
    Jan 12, 2010
    Messages:
    1,479
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Etna,ME
    is exchange log showing any connection errors? unsupported devices allowed in ESM?
    wonder if its a device policy issue.
  4. lokiju
    Offline

    lokiju New Member

    Joined:
    Nov 7, 2009
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    0
    Unsupported devices is enabled and I even disabled all the security/pin requirements for testing, which works fine in 2.1 but not 2.2.
  5. dmacleo
    Offline

    dmacleo Premium Member Premium Member

    Joined:
    Jan 12, 2010
    Messages:
    1,479
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Etna,ME
    don't know then, had not yet installed foyo. however with this report I think I will hold off.
    you ex 2007, 2010, or 2003?
  6. peterpressure
    Offline

    peterpressure New Member

    Joined:
    Dec 21, 2009
    Messages:
    247
    Likes Received:
    0
    Trophy Points:
    0
  7. dmacleo
    Offline

    dmacleo Premium Member Premium Member

    Joined:
    Jan 12, 2010
    Messages:
    1,479
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Etna,ME
    what server?
    running exchange 2003 here and have not tried yet.
  8. CrunchSA
    Offline

    CrunchSA New Member

    Joined:
    Dec 7, 2009
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I had problem when going through the Accounts & Sync portin of Settings, but when I tried through the Email app, I was presented with a Manual Setup option the allowed me to set up my account successfully.
  9. lokiju
    Offline

    lokiju New Member

    Joined:
    Nov 7, 2009
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    0
    2007, which was a clean build out of 2007 at the time even, not upgrading from 2003 or anything that could carry over legacy issues.
  10. sdorn
    Offline

    sdorn New Member

    Joined:
    Feb 19, 2010
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    0
    I am also running the Froyo version you can download from mydroidworld (not the Ultimate Droid ROM), and my exchange email works just fine. Setup was just like before, and it synced right up. Might be an issue with the ROM you are using.
  11. dmacleo
    Offline

    dmacleo Premium Member Premium Member

    Joined:
    Jan 12, 2010
    Messages:
    1,479
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Etna,ME
    sorry, no way to run 2007 here so can't test anything.

    what version of exchange do you hook to?
  12. LewiNC
    Offline

    LewiNC New Member

    Joined:
    Nov 26, 2009
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    RE:

    It works on Exch 2007 SP1 for me no problem. I did have to go into exchange and delete the prior device association.
  13. dmacleo
    Offline

    dmacleo Premium Member Premium Member

    Joined:
    Jan 12, 2010
    Messages:
    1,479
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Etna,ME
    Was thinking on this last night and was going to ask about that, good to know.

    Sent from my Droid using Tapatalk
  14. Quantify
    Offline

    Quantify New Member

    Joined:
    May 9, 2010
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    0
    Works just fine with Exchange 2003 as well. Only downside is no more HTML email. However, the benefits (vastly improved calendaring) are worth it.
  15. tcrews
    Offline

    tcrews Premium Member Premium Member Developer

    Joined:
    Jan 27, 2010
    Messages:
    1,354
    Likes Received:
    22
    Trophy Points:
    38
    Location:
    Lexington, SC
    Works fine with Exchange 2007 for me.
  16. lokiju
    Offline

    lokiju New Member

    Joined:
    Nov 7, 2009
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    0
    I tried that version of the ROM and get the same result.
  17. lokiju
    Offline

    lokiju New Member

    Joined:
    Nov 7, 2009
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    0
    Ah, I'll try that!

    Doh, didn't make a difference. :(
    Last edited: Jun 7, 2010
  18. lokiju
    Offline

    lokiju New Member

    Joined:
    Nov 7, 2009
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    0
    Does anyone here have access to Exchange or is an Exchange admin that has verified this works?

    Can you tell me all the settings you have configured for activesync, and devices so we can compare?
  19. dmacleo
    Offline

    dmacleo Premium Member Premium Member

    Joined:
    Jan 12, 2010
    Messages:
    1,479
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Etna,ME
    wondering if you are using ssl on owa/oma connection and are having a cert issue on the phone.
    if I get chance to load froyo today I can tets exchange 2003 but I use touchdown not the default app.

    also, wonder if its a domain name/user id issue? did you try using domain/user id under username?
  20. lokiju
    Offline

    lokiju New Member

    Joined:
    Nov 7, 2009
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    0
Search tags for this page
accept/require client certificates were found
,
android 2.2 exchange email setup
,
android 2.2 exchange not getting mail
,
android 2.2 exchange unable to open connection to server
,
android cannot get exchange mail
,
android email app exchange 2010 connection error
,
android froyo 2.2 activesync unable to open connection to se
,

android unable to open connection to server due to security

,
cannot figure out how setup exchange email on gs3
,
exchange 2003 set the iis configuration to ignore client cer
,
exchange 2010 ignore client certificates
,
exchange activesync accept/require client certificates were
,
how to get exchange email on android 2.2
,
unable to open connection to server android exchange 2007
,
wwwlkijouã±