GPA15 Dialer problem driving me nuts

Discussion in 'Bugless' started by Force1stiptopped, May 10, 2011.

  1. Force1stiptopped

    Joined:
    Jul 28, 2010
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I believe this problem was mentioned before and everyone said it seemed to be fixed in GPA 15.. this is not the case for me.

    The problem: Every time I get an incoming call, the dialer force closes and one of two things happens.. either:
    1) The phone keeps vibrating even when the I am able to have a conversation with the person. It continues and eventually the call randomly ends.
    2) the call is answered and works fine, but when i go to hang up, the phone is frozen at the force close screen of the dialer and I must do a battery pull to reboot the phone.

    Does anyone have a fix for this issue? anyone heard anything from Pete regarding it?

    Edit:

    Should add that this makes the phone extremely hot, 105+ and I am using Petes V.02 800 MHZ kernel, with his autooverclock zip.
     
  2. AndyMan

    AndyMan Member

    Joined:
    Nov 16, 2009
    Messages:
    167
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I have the issue too, nothing I have found to fix it.. just tell the person to hang up, and then you call them back..

    really annoying
     
  3. joe1980

    joe1980 Member

    Joined:
    Sep 29, 2010
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I had this problem for quite a while until I did the following:
    1. Used Titanium Backup to backup all my apps and data
    2. Wiped my phone 3x
    3. Installed 4/23 build of GPA15
    4. Used Titanium Backup to restore only user apps + data (no system data)
    I'm sticking with the stock kernel that comes with the 4/23 build of GPA15. I tried Pete's v0.2 kernel, and I started noticing a lot of lag. So, I reverted to the stock kernel and everything has been running pretty much perfectly. I have not had that dialer issue for almost 3 weeks now.

    BTW, I'm using SetCPU and have my phone running at 1000/250. I'm not using Pete's autooverclock.zip.

    I have no idea if this will help you, but it got rid of the annoying problem for me.
     
  4. Bobbar

    Bobbar Member

    Joined:
    Jul 8, 2010
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Central Ohio
    Ratings:
    +0
    Never had this problem. Did you start with a clean install, manual app restore?
     
  5. buymagicfish

    buymagicfish New Member

    Joined:
    Dec 7, 2009
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Berkeley, CA
    Ratings:
    +0
    I have this problem as well. Started with full wipes (3x) and did a fully manual restore except used Titanium Backup to restore data only on just a small handful of apps. Issue doesnt happen every time, but often enough that its annoying.
     
  6. jimmypop13

    jimmypop13 Member

    Joined:
    Apr 7, 2010
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I have this problem too and I hate it! I have to pull the battery when it keeps vibrating. I also get random hang ups during phone calls and I never get data back after a call. I always wipe several times, use the stock kernel, and use the market to restore all apps. I've had these problem with all the GPA builds, including the current gpa15
     
  7. gertman

    gertman Member

    Joined:
    Mar 6, 2010
    Messages:
    208
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Just FYI I have had this problem on Project Elite and Cynogenmod Gingerbread ROMs. So don't think u guys are alone and of course I have NOT found a fix yet :(
     
  8. Tabs

    Tabs Member

    Joined:
    Dec 3, 2009
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I had to go back to Froyo last night due to this issue and the no data/green icons after making a call issue.

    I realize it's probably not Peter's fault (as gertman said, it happens with other GB ROMs too) but it really was a showstopper for me. Basically any call that came in was locking up the phone. I'd make calls too and the phone would lock up at the end when I went to hang up... Just got sick of having to pull the battery just to end calls and stuff.

    Hopefully 2.3.4 / GPA16 is fixed.
     
  9. C.o.m.m.a.n.d.e.r

    C.o.m.m.a.n.d.e.r New Member

    Joined:
    Jun 16, 2010
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Irving, Texas
    Ratings:
    +0
    i havent had any of those problems but right now when i answer a call no one can hear me and i cant hear them......this needs to be fixed
     
  10. myriad46

    myriad46 Member

    Joined:
    Nov 23, 2009
    Messages:
    473
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Upstate, NY
    Ratings:
    +0
    I've always had this problem with GB Roms (first gpa14). CM7 did not do this for me, but ate up my battery life. I think it's related to the kernels. I had no problem with CM7 until I tried flashing another kernel. First call, I got the continual vibrating on answering. I would have stayed with the stock kernel, but the battery life on CM7 sucked. I just tried loading GPA15 and it still does it. I wonder if that is why it is sproadic. Everybody's phone handles kernels differently.

    If you can live without your phone vibrating, that is a workaround. I don't think 2.3.4 is going to fix it. I think its a voltage issue associated with the phone vibrating. Oh well. This wouldn't be so bad if TiBu restores would transfer between Froyo and Gingerbread, but it's a pain in the ass to not be able to get data back for the system and even some apps. My angrybirds crash if I restore data from froyo-gb or the other way around.
     
  11. yorkwall

    yorkwall New Member

    Joined:
    Dec 7, 2009
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Indiana
    Ratings:
    +0
    I have had this problem as well its really annoying.

    I sorta found a fix, still doing some testing. I install Advanced Task Killer, changed the Security Level to "Low", Auto Kill Level to "Aggressive", and Auto Kill Freq to "When screen is off". Now you have to go into Advanced Task Killer and ignore things that are always running (Google Services, etc.)

    Let me know if this works for you. Good luck

    Sent from my Droid using DroidForums
     
  12. Tabs

    Tabs Member

    Joined:
    Dec 3, 2009
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Wait so this is specific to vibrate mode? That would actually make sense - I always have my phone in vibrate actually.
     
Search tags for this page
android 2.3 samsung galaxy phone dialer issue
,
android 2.3.4 dialer hangs when call ends
,

droid x2 dialer problems

,
galaxy s dialer closes
,
galaxy s dialer crashes
,
s advance activity dialer gets hang