GPA12 Camera issue

Discussion in 'Bugless' started by Sileem, Mar 2, 2011.

  1. Sileem

    Sileem Member

    Joined:
    Apr 25, 2010
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    The camera either refuses to open somestimes, others it will make the clicking sounds like it's about to open, but most of the time the camera button just causes the phone to vibrate, is anyone else haveing trouble with the camera?

    EDIT: just tried it again and got the error "Cannot connect to camera" Im not sure if this is because of the ROM or if the clicking did some damage to it
     
  2. mursepaolo

    mursepaolo Member

    Joined:
    Mar 16, 2010
    Messages:
    190
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    i have the multiple clicking issue from time to time.
     
  3. Sileem

    Sileem Member

    Joined:
    Apr 25, 2010
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    But now mine just refuses to work, restarted twice and now i get the error "Cannot connect to camera"
    EDIT: Barcode scanner tells me there is an error with my camera as well
    EDIT2: Restored back to Saphire 2.0.2, works fine, this is a GPA12 issue
     
    #3 Sileem, Mar 2, 2011
    Last edited: Mar 2, 2011
  4. me_droid

    me_droid Member

    Joined:
    Dec 14, 2009
    Messages:
    79
    Likes Received:
    2
    Trophy Points:
    8
    Ratings:
    +2
    GPA14 same issue

    FWIW, just flashed GPA14 and also have exact same issue. It's the ONLY thing on my OG Droid that does not work with Pete Alfonso's amazing rom. Sour grapes! Hoping that his GPA 15 may fix this.
     
  5. peteralfonso

    peteralfonso Premium Member
    Premium Member Developer

    Joined:
    Mar 18, 2010
    Messages:
    844
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    The camera has worked in all of my GPA builds. The "clicking noise" is hardware, opening and focusing the shutter, it has happened in every Android version.
     
  6. Sileem

    Sileem Member

    Joined:
    Apr 25, 2010
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I found out what the problem is, turns out, it doesn't work if you delete camera_click.ogg, so I replaced it with a blank ogg file, I'll upload it when I get home for anyone else who hates the camera sounds. Thanks Pete!
     
  7. Bobbar

    Bobbar Member

    Joined:
    Jul 8, 2010
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Central Ohio
    Ratings:
    +0
    I've always had problems with stuttering video since switching to GPA.
     
  8. me_droid

    me_droid Member

    Joined:
    Dec 14, 2009
    Messages:
    79
    Likes Received:
    2
    Trophy Points:
    8
    Ratings:
    +2
    Sileem, I discovered the same thing last night and sorry for posting this in both GPA12 and GPA14. Let me know where to find your blank ogg, much appreciated.

    Pete, thanks again for all the hard work, have a tall one on me. Is there a way you can put the donate button in the mobile version of your site?
     
  9. sbenson

    sbenson Silver Member

    Joined:
    Jan 19, 2011
    Messages:
    2,370
    Likes Received:
    61
    Trophy Points:
    113
    Location:
    Virginia/DC Metro Area
    Ratings:
    +61
    Where is the camera focus sound (the "dink dink" not the "tick tick tick") located? I want to get rid of that too, I didn't see it with the rest of the ui sounds.
     
  10. Sileem

    Sileem Member

    Joined:
    Apr 25, 2010
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    No, it's the snap when the camera takes the picture, I figure it would be located in /system/media/UI I don't know what they would be called.

    And here is my "blank" ogg file, put it in /system/media/UI. If you want to mute any other sound, you can just rename this file.
    camera_click.ogg
     
  11. sbenson

    sbenson Silver Member

    Joined:
    Jan 19, 2011
    Messages:
    2,370
    Likes Received:
    61
    Trophy Points:
    113
    Location:
    Virginia/DC Metro Area
    Ratings:
    +61

    No, I already took care of that file. I need to get rid of the focus sound.


    Sent from my Droid using DroidForums App
     
  12. eyarberry

    eyarberry New Member

    Joined:
    Sep 17, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Same deal here. I took one picture with the camera and realized that obnoxious shutter sound was back so the first thing I did was to rename it. Suddenly the camera doesn't work anymore. Rename it back to the original filename, reboot and we're back in business.

    Thanks, Sileem, for the blank .ogg!

    I, too, would like to know what the shutter focus sound name is so I can get rid of that one as well. I know I could just use SilentCam, but I'd rather not install another app to do what the phone should already be capable of doing.