Google voice to text does not allow voice input

Discussion in 'Android Support' started by vpelton, Oct 27, 2017.

  1. vpelton

    vpelton New Member

    Joined:
    Jul 16, 2012
    Messages:
    14
    Likes Received:
    2
    Trophy Points:
    3
    Ratings:
    +2
    When using Google Maps (& anything using the keyboard input), I tap on the microphone icon so I can input text via speech. But now, when I do that, I get the white window with the green button in the middle & "Google" at the bottom, but I don't get the beep that tells me to start talking. If I talk anyway, it does not do anything.

    As far as I know, I didn't change anything, but who knows if that's really true. I tried a power down/restart about 2 times but that didn't help. Any one know how to fix this? Thanks so much.

    Samsung S6
    Android version 7.0
     
  2. Sajo

    Sajo Diamond Member

    Top Poster Of Month

    Joined:
    Jan 25, 2013
    Messages:
    14,894
    Likes Received:
    10,543
    Trophy Points:
    2,063
    Location:
    Tennessee
    Ratings:
    +11,089
    Current Phone Model:
    Moto Z2 Force
    A Google search brought up a lot of similar results for Galaxy S7 devices running the Google GBoard keyboard. I found this and might be worth checking, see what your speech-to-text input is set to:

    "The Google commands are not in the "default keyboard" for Samsung devices.
    Here is where you need to go:
    Settings/General Management/Language and Input/Speech-Text to Speech
    there you will see it have the options Samsung text-to-speech engine and Google Text-to-speech Engine.
    Mine, by default, was set with Samsung"

    Sent from my XT1650 using Tapatalk
     
    • Like Like x 1
  3. vpelton

    vpelton New Member

    Joined:
    Jul 16, 2012
    Messages:
    14
    Likes Received:
    2
    Trophy Points:
    3
    Ratings:
    +2
    I found text to speech but no speech to text settings.
     
  4. Sajo

    Sajo Diamond Member

    Top Poster Of Month

    Joined:
    Jan 25, 2013
    Messages:
    14,894
    Likes Received:
    10,543
    Trophy Points:
    2,063
    Location:
    Tennessee
    Ratings:
    +11,089
    Current Phone Model:
    Moto Z2 Force
    Is it set to Samsung or Google?


    I have a very old Samsung as my company provided work phone, but here is the Setting I believe they were talking about. Mine is set to Samsung. Try changing yours to Google Text To Speech engine.

    [​IMG]

    Sent from my XT1650 using Tapatalk
     
    #4 Sajo, Oct 28, 2017
    Last edited: Oct 28, 2017
  5. vpelton

    vpelton New Member

    Joined:
    Jul 16, 2012
    Messages:
    14
    Likes Received:
    2
    Trophy Points:
    3
    Ratings:
    +2
    It's set to sansung but i also tried google but it still does not work. On S8 others say to turn off samsung speech to text but i can't find that.
     
  6. Sajo

    Sajo Diamond Member

    Top Poster Of Month

    Joined:
    Jan 25, 2013
    Messages:
    14,894
    Likes Received:
    10,543
    Trophy Points:
    2,063
    Location:
    Tennessee
    Ratings:
    +11,089
    Current Phone Model:
    Moto Z2 Force
    It sounds like something has taken over microphone permissions and not letting Google apps have access to the mic. Have you installed any new apps lately that would use / need access to the mic?

    Also, have you checked App Permission Settings > tap Microphone > see if Google has permission slid to On?

    Sent from my XT1650 using Tapatalk
     
  7. vpelton

    vpelton New Member

    Joined:
    Jul 16, 2012
    Messages:
    14
    Likes Received:
    2
    Trophy Points:
    3
    Ratings:
    +2
    No new apps lately. Where is App Permission Settings ? I went to settings; apps; app mgr but mic did not appear as it's not an app.
     
  8. Sajo

    Sajo Diamond Member

    Top Poster Of Month

    Joined:
    Jan 25, 2013
    Messages:
    14,894
    Likes Received:
    10,543
    Trophy Points:
    2,063
    Location:
    Tennessee
    Ratings:
    +11,089
    Current Phone Model:
    Moto Z2 Force
    On my phone that's accessible from Settings > Apps > Gear symbol > App Permissions

    Sent from my XT1650 using Tapatalk
     
  9. vpelton

    vpelton New Member

    Joined:
    Jul 16, 2012
    Messages:
    14
    Likes Received:
    2
    Trophy Points:
    3
    Ratings:
    +2
    app mgr had permissions but there is no mic app. maps does not list mic. google app had mic on but does not work. when i use voice recorder, mic works.
     
  10. Sajo

    Sajo Diamond Member

    Top Poster Of Month

    Joined:
    Jan 25, 2013
    Messages:
    14,894
    Likes Received:
    10,543
    Trophy Points:
    2,063
    Location:
    Tennessee
    Ratings:
    +11,089
    Current Phone Model:
    Moto Z2 Force
    Don't try looking for the mic app, you need to look for the Mic permissions. Which apps have permission to use the mic? This is what it looks like on my phone, yours may be slightly different to get to these Settings. Somewhere on your phone, normally in the App Settings, you should see the Permission Settings.

    [​IMG]



    [​IMG]

    Sent from my XT1650 using Tapatalk
     
    #10 Sajo, Oct 28, 2017
    Last edited: Oct 28, 2017
  11. vpelton

    vpelton New Member

    Joined:
    Jul 16, 2012
    Messages:
    14
    Likes Received:
    2
    Trophy Points:
    3
    Ratings:
    +2
     
  12. Sajo

    Sajo Diamond Member

    Top Poster Of Month

    Joined:
    Jan 25, 2013
    Messages:
    14,894
    Likes Received:
    10,543
    Trophy Points:
    2,063
    Location:
    Tennessee
    Ratings:
    +11,089
    Current Phone Model:
    Moto Z2 Force
    Somewhere on your phone is Permission Settings. Samsung has their own way of displaying Settings, but Permissions is an Android feature and it should be burried in there somewhere.

    Sent from my XT1650 using Tapatalk
     
Search tags for this page
azs
,
best cameras
,

google voice