Google Voice SMS Issue

Discussion in 'Android General Discussions' started by natty_lite, Jan 6, 2010.

  1. natty_lite
    Offline

    natty_lite New Member

    Joined:
    Dec 25, 2009
    Messages:
    185
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Philly
    Has anyone figured out why GV forwards a SMS to your default messaging application whenever someone text your GV number? I'm starting to smell Verizon conspiracy, because I know for a fact this did not happen on my G1 or Hero.
  2. DroidFan
    Offline

    DroidFan New Member

    Joined:
    Nov 9, 2009
    Messages:
    322
    Likes Received:
    0
    Trophy Points:
    0
    Do you have the forwarding on your GV SMS option checked? You'll have to log on to the GV account on the web and check. I also use GV SMS, and none of my SMS's get forwarded to my VZW SMS... but I know I have that option unchecked.
  3. takeshi
    Offline

    takeshi New Member

    Joined:
    Nov 29, 2009
    Messages:
    4,600
    Likes Received:
    0
    Trophy Points:
    0
    You definitely have SMS forwarding enabled. Check your GV settings. IIRC you need to do this via the GV web interface. It's covered in many, many threads. Please use the search feature.
  4. gatorbait
    Offline

    gatorbait New Member

    Joined:
    Nov 23, 2009
    Messages:
    170
    Likes Received:
    0
    Trophy Points:
    0
    Like the poster above me said, it is a setting in Google Voice that needs to be disabled. Presumably it is there for GV users who have phones without a GV app.
  5. natty_lite
    Offline

    natty_lite New Member

    Joined:
    Dec 25, 2009
    Messages:
    185
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Philly
    Of course it is unchecked, hence my conundrum.. If it was that simple this thread would not exist.
  6. thebowers
    Offline

    thebowers Premium Member Theme Developer Premium Member

    Joined:
    Nov 24, 2009
    Messages:
    2,548
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Iowa
    So when you log into GV, go to settings, then phones. Select your mobile phone and edit. Where it says receive sms on this phone (mobile phones only) is unchecked?
  7. natty_lite
    Offline

    natty_lite New Member

    Joined:
    Dec 25, 2009
    Messages:
    185
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Philly
    Ok, I will say that I officially stand corrected. I was wrong. Every thing that I reference referred to voiemail/sms tab, and not the edit mobile number option itself. I set mine to just shoot me an e-mail when a text comes so I can turn off the notifications.

    Thank you, and sorry the snide remark.