"Google Serivces" killing battery

Discussion in 'Samsung Galaxy S4' started by fishacura, Jul 16, 2013.

  1. fishacura

    fishacura Member

    Joined:
    Aug 30, 2011
    Messages:
    253
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    My battery drained ~40% overnight and the cuprit looks to be something called "google services". Not sure all this encompasses but here's what I did:Removed "google play music" and "google play video" apps since I never use themSet all apps back to default settings (in effect turning all location services back to off for now)Went into my google account and unchecked all the "sync" options with the exception of calendar, and gmailAnything else anyone can think of? Not sure if this will even correct the issue but I'm optimistic. I have a feeling it was just trying to sync everything on somewhat of a regular basis.
     
  2. leeshor

    leeshor Gold Member

    Joined:
    Jan 30, 2012
    Messages:
    4,363
    Likes Received:
    1,437
    Trophy Points:
    358
    Location:
    Norcross, GA - USA
    Ratings:
    +1,676
    Sounds like you're on the right track. I have WiFi and locations services on 24/7 and only see 4% (at most) battery use overnight. But I don't think that Google Services is where the problem is. It shows as my number one user of battery but under "data" it's number 8. Do you have any power saving apps installed, like Battery Guru, (which I think helps a lot)?
     
  3. fishacura

    fishacura Member

    Joined:
    Aug 30, 2011
    Messages:
    253
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I have juice defender which is why I am shocked this happened. I wish there were a "one stop shop" to see all the individual apps/settings I need to focus on. I'm hunting and pecking here and it still looks high to me but I really need to wait until overnight to get a better sense for what's going on. I think what happened was that when I reset the phone I opted into a bunch of "location" type settings for ALL apps so chrome, music, etc. were all running in the background and doing things I didn't want them to do. Just a hunch...
     
  4. Sydman

    Sydman Premium Member
    Rescue Squad Premium Member

    Joined:
    Jul 18, 2010
    Messages:
    3,871
    Likes Received:
    609
    Trophy Points:
    243
    Location:
    Austin, Tx
    Ratings:
    +678
    Current Phone Model:
    Nexus 6P
    Google Services usually runs high when I am using Google Now, I pretty much keep that and all the location services off and it never gets high anymore.
     
  5. fishacura

    fishacura Member

    Joined:
    Aug 30, 2011
    Messages:
    253
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Can you tell me how you keep them off (what specific settings)? That would be a tremendous help as I'm not sure where they may be in the menu structure.
     
  6. Sydman

    Sydman Premium Member
    Rescue Squad Premium Member

    Joined:
    Jul 18, 2010
    Messages:
    3,871
    Likes Received:
    609
    Trophy Points:
    243
    Location:
    Austin, Tx
    Ratings:
    +678
    Current Phone Model:
    Nexus 6P
    Settings>Location Access>Access to my location

    Google + Settings from your APP drawer is another one to turn off.
     
  7. dezymond

    dezymond Tech Support Mod
    Staff Member Premium Member

    Joined:
    Nov 11, 2009
    Messages:
    12,079
    Likes Received:
    1,506
    Trophy Points:
    573
    Location:
    Bay Area, California
    Ratings:
    +1,670
    Current Phone Model:
    Google Pixel
    Try running the phone with JuiceDefender off. It may be causing conflict which is why your battery is draining so fast.

    Last night for the sake of an experiment I left sync, mobile data, and wifi on and I only lost 6% over 9hrs (I usually turn off mobile, sync, and wifi). I closed all apps and cleared memory via the built in Task Manager before doing so. I'm also using BatteryGuru and Greenify, so those two apps also came into effect
     
  8. magdalena

    magdalena New Member

    Joined:
    Jul 16, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I noticed my battery draining more after the update!
     
  9. magdalena

    magdalena New Member

    Joined:
    Jul 16, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Where is the task manger? I dont recall seeing this
     
  10. dezymond

    dezymond Tech Support Mod
    Staff Member Premium Member

    Joined:
    Nov 11, 2009
    Messages:
    12,079
    Likes Received:
    1,506
    Trophy Points:
    573
    Location:
    Bay Area, California
    Ratings:
    +1,670
    Current Phone Model:
    Google Pixel
    Hold down the Home button and you'll be able to select it
     
  11. fishacura

    fishacura Member

    Joined:
    Aug 30, 2011
    Messages:
    253
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    But if you turn this particular blanket setting off, doesn't it mean you won't be able to:1. Get weather updates for your location2. Use maps based on your locationetc.??? Unless that is you simply turn it on only when needed.
     
  12. magdalena

    magdalena New Member

    Joined:
    Jul 16, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Got it. Thanks so much! I will at least do this before I go to bed each night. After the update I lost more 50% battery life overnight. Before the update it it was more like 10%!
     
Search tags for this page
google services battery drain galaxy s4
,

google services is killing my battery

,

google services killing battery

,
google services killing battery s4
,
google services using battery on galaxy s4
,
how to turn off google services on android galaxy s4
,
s4 google services battery
,
turn off google services galaxy s4
,
why is google services killing my battery
,
why is my s4 battery draining so fast