Google search locks up Droid X

Discussion in 'Droid X Tech Support' started by gabrown2, Mar 14, 2011.

  1. gabrown2

    gabrown2 New Member

    Joined:
    Jan 20, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    FL
    Ratings:
    +0
    Hello All,

    I have noticed the last few weeks that when I now go to use my Google Search, I begin typing in the letters for the search but as soon as I hit the second letter the X locks up. Google search becomes unresponsive unless you wait about 30 seconds between each letter. I end up hitting the home menu button and that may give you the force close/report option for google search or take you to your home menu. Nevertheless, it is becoming a huge hassel as I use Google search quite a bit during the day. Ideas, comments, questions, suggestions? Thanks all.
     
  2. skennelly

    skennelly Active Member

    Joined:
    Oct 27, 2010
    Messages:
    577
    Likes Received:
    29
    Trophy Points:
    28
    Location:
    Illinois
    Ratings:
    +29
    go to menu>applications>manage & find google search and clear data/cache & force close. That should help.

    Sent from my DROIDX in Western Illinois
     
  3. gabrown2

    gabrown2 New Member

    Joined:
    Jan 20, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    FL
    Ratings:
    +0
    Thanks for the feedback. I walked through these steps, started up Google search once again and after hitting the second letter of my search it stops again with the force, wait, post screen. I force it closed, then wait a few seconds, start up search again and it stalls a bit after the first letter then allows me to type my full search. Odd thing i now notice is as I start typing the letters of the search, it is popping up results for the drop down as apps that are currently on my X. did not notice that before. Any ideas on why it still wants to stall/lock? Thanks again.
     
  4. CD95YJ

    CD95YJ Member

    Joined:
    Nov 2, 2010
    Messages:
    868
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Colorado, USA
    Ratings:
    +1
    Are you rooted? If so use either rom manager or root tools to run "fix permissions" to see if that helps the stalling.

    Sent from my DROIDX using DroidForums App
     
  5. gabrown2

    gabrown2 New Member

    Joined:
    Jan 20, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    FL
    Ratings:
    +0
    Sorry, no, not rooted. It is a new X.
     
  6. thinman72069

    thinman72069 Member

    Joined:
    Feb 2, 2011
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I've had the same issue. Even posted a discussion about it. But all anyone knew was that it seems to happen to a lot of people.
    I'm running stock also. Very annoying problem.

    Sent from my DROIDX using DroidForums App
     
  7. zamslam

    zamslam New Member

    Joined:
    Jul 16, 2010
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    The workaround I found was to turn off app searching - just letting it search the inet, which is all I usually want.

    Not really google's fault if some apps are slow to respond to search requests.
     
  8. thinman72069

    thinman72069 Member

    Joined:
    Feb 2, 2011
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Thank's for the tip Zam.

    I just went into the settings and changed it to only search the web. It was also set to search Apps and Voice Search.
    If that does the trick, you deserve some sort of forum trophy.

    Sent from my DROIDX using DroidForums App
     
  9. lghtngblt02

    lghtngblt02 New Member

    Joined:
    Apr 4, 2010
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Mechanicsburg, Pa
    Ratings:
    +0
    This worked for me... I just simply turned off the App Search option under settings and VIOLA!
     
  10. thinman72069

    thinman72069 Member

    Joined:
    Feb 2, 2011
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Yep. I've been spreading the word of zamslams workaround ever since I first set up to search only the web.
    Works like a charm.

    Sent from my DROIDX using DroidForums
     
  11. criyi

    criyi New Member

    Joined:
    Mar 3, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Excellent! Worked great, thanks.

    For those not as droid savy

    Settings>search>searchable items> uncheck everything except web.
     
Search tags for this page
android google search locking up
,
google maps locks up droid x
,
google search android locks up
,
google search app locks up
,

google search locks up android

,
google search locks up phone
,
i only type two letters on google search and google stops