Google Navigation doesn't work

Discussion in 'Bugless' started by dhinged, Jan 22, 2011.

  1. dhinged

    dhinged Member

    Joined:
    Apr 10, 2010
    Messages:
    205
    Likes Received:
    3
    Trophy Points:
    16
    Ratings:
    +3
    I tried accessing Google Navigation and it simply says "Checking Availability" forever. Nothing I do helps, including killing apps or rebooting. Is this a BB .6 issue?
     
  2. dmdj232

    dmdj232 Member

    Joined:
    Nov 12, 2009
    Messages:
    90
    Likes Received:
    1
    Trophy Points:
    8
    Ratings:
    +1
    I too am having the same problem. I'm running Liquid Gingerbread 1.0
     
  3. Alastrionia

    Alastrionia Sourcery Themer / Designr
    Theme Developer Premium Member

    Joined:
    Sep 27, 2010
    Messages:
    359
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Sunnyside, WA
    Ratings:
    +4
    have the same problem
    however
    if I go into maps, and from there get into navigation
    then it works just fine
     
  4. Slagg3r

    Slagg3r New Member

    Joined:
    Apr 2, 2010
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Having the same issue on the newest stable bb

    Sent from my Droid using DroidForums App
     
  5. Jason R

    Jason R Member

    Joined:
    Apr 11, 2010
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
  6. styx

    styx Member

    Joined:
    Dec 14, 2009
    Messages:
    161
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Mine didn't work but as soon as I went to maps then back to Nav. it worked.
     
  7. afingerh

    afingerh New Member

    Joined:
    Jan 23, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Along the same lines...

    My navigation app works, but it definitely has some issues. I have recently made 2 trips that the navigation really took me out of the way on and I am not sure what is happening. It took me almost 3 hours to drive somewhere that should only take 2 hours and over an hour to go somewhere that is about 45 minutes (traffic was not an issue either time). I have "avoid highways" and "avoid tolls" both unchecked under options. Any ideas as to why this navigation is taking me so far out of the way here??? Short trips it seems to be working fine, but I am lost for an answer otherwise.
     
Search tags for this page

android navigation doesn't work

,

google navigation doesn't work

,

google navigation wont work

,
navigation app doesn't work
,
navigation doesn't work
,

navigation doesn't work droid

,
navigation doesn't work on android
,
navigation doesnt work
,
why doesnt my navigation app work
,
why doesnt my navigation work