"google" is using all my battery

Discussion in 'Android General Discussions' started by Nelson886, Mar 16, 2010.

  1. Nelson886

    Nelson886 New Member

    Joined:
    Feb 23, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    When I use my spare parts app to look at the partial wake usuage it says "google" and the bar is completely full. It has been running nonstop for the last three days. I uninstalled everything I added from three days ago but it is still running. I have no idea what is cauing this. The battery wears down quicker and the phone is lagging more than normal.
     
  2. jsh1120

    jsh1120 Silver Member

    Joined:
    Dec 9, 2009
    Messages:
    2,454
    Likes Received:
    1
    Trophy Points:
    103
    Location:
    Seattle, Washington
    Ratings:
    +1
    Have you pulled the batery or at least power cycled the phone?
     
  3. gruve

    gruve Member

    Joined:
    Dec 29, 2009
    Messages:
    232
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Minneapolis, MN
    Ratings:
    +0
    Are you using google as your start page on your web browser? It will try to grab your location which for me was running down the battery quite rapidly.
     
  4. Nelson886

    Nelson886 New Member

    Joined:
    Feb 23, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I previously rebooted the phone which didn't work, but i just pulled the battery for the first time. Even after the pulled battery "google" is still constantly running. Any ideas what that even is? It doesn't appear to be any apps, unless an update triggered it. I even used a task manager to kill all my tasks just to see what would happen. No luck though.
     
  5. Nelson886

    Nelson886 New Member

    Joined:
    Feb 23, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Google is my start page....thanks it does always seem to be open I will try that
     
  6. KevinJ

    KevinJ Member

    Joined:
    Dec 24, 2009
    Messages:
    363
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    Ratings:
    +0
    For as long as I can remember I've used a "blank" start page on all my computer's browsers, so that was the first thing I did with my phone.
     
  7. eliassami5

    eliassami5 Member

    Joined:
    Nov 21, 2009
    Messages:
    774
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Bay Area, Cali
    Ratings:
    +0
    just go to google.com on your phone, scroll to the bottom and press settings, turn off "always use of device location". It wont search for your location anymore when you open up the browser.
     
  8. jsh1120

    jsh1120 Silver Member

    Joined:
    Dec 9, 2009
    Messages:
    2,454
    Likes Received:
    1
    Trophy Points:
    103
    Location:
    Seattle, Washington
    Ratings:
    +1
    Another alternative is to use either XScope or Dolphin Browser as your default browser. Neither activates the "Near Me Now" functionality on the Google Search Page as the default browser does.
     
  9. Tabs

    Tabs Member

    Joined:
    Dec 3, 2009
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    If it's the Browser doing it though, it will say "Browser" in the battery use list, not "Google". Have you gone into Manage Applications and filtered to "Running" to see if you can figure out what it is?
     
  10. Nelson886

    Nelson886 New Member

    Joined:
    Feb 23, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Great Idea, somehow it just stopped and I tried so many different things I am not sure what fixed it or what it even was. I was using a task manager and the running services to see what was running. If it happens again I will try it your way i didn't even know that was possible. Thanks