Google Calendar Sync?

Discussion in 'Droid 2 Tech Issues' started by ThundarPanda, Aug 12, 2010.

  1. ThundarPanda
    Offline

    ThundarPanda New Member

    Joined:
    Aug 10, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Hi, I picked up a Droid 2 and its my first android phone. After doing a bit of research, I read that the Android Calendar app should sync with Google Calendar automatically. However, when I first open the Calendar app it says"

    "There are no calendar events currently synced. You can set up a calendar to sync in Accounts"

    When I go to Accounts (under Settings or My Accounts, they are the same) I see my google account/gmail account. When I open that, I see "Sync Contacts" and "Sync Gmail". There is no mention of Google Calendar anywhere.

    When I try to add an event to the Calendar app, it says: "You must synchronize a calendar before adding a new event"

    When I hit the menu button in the Calendar app and hit "Calendars", the list is completely blank, with only "OK" and "Cancel" buttons at the bottom.

    Sooo basically, my question is how do I get my Google Calendars to sync?

    Much love to anyone who can help me out :heart:
  2. ZPrime
    Offline

    ZPrime New Member

    Joined:
    Aug 12, 2010
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    0
    Is your gmail account a real Gmail account, or "google apps for your domain" (GAFYD) account?

    The calendar option has to be enabled if it's a GAFYD account, otherwise it won't sync.
  3. ThundarPanda
    Offline

    ThundarPanda New Member

    Joined:
    Aug 10, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Its a real gmail account. It SHOULD be syncing automatically, I'm told.
  4. ZPrime
    Offline

    ZPrime New Member

    Joined:
    Aug 12, 2010
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    0
    And presumably you already have a calendar setup on the GMail account too, right? I'm not sure what to tell you, mine is syncing OK (although I don't really have many appointments on it as I keep most of my stuff in Exchange).
  5. ThundarPanda
    Offline

    ThundarPanda New Member

    Joined:
    Aug 10, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Yup, I do!

    Although, I did set up the calendar AFTER activating this phone with this Google account. Under accounts, there is only "Sync contacts" and "sync gmail". No "sync calendars". Do you think the fact that I set up calendars after activating the phone has anything to do with it?

    Hmmmmz....
  6. ZPrime
    Offline

    ZPrime New Member

    Joined:
    Aug 12, 2010
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    0
    Yes, that could be it. With GMail accounts on a Droid, the first account you setup is "special" as it is tied to the Market and various other things. Unfortunately the only way to re-setup that account is to reset the phone to factory settings and start over.

    When you set it up, don't do the account at the initial setup screen. Skip it then, and manually add it later, so that way you can see if Calendar shows up as one of the things that is going to sync.

    I honestly don't know if this will matter or not though. It's possible that you might just be able to wait and then the Calendar option could show up later. Have you tried rebooting the phone? (Power off and back on.)
  7. Sal
    Offline

    Sal New Member

    Joined:
    Jan 30, 2010
    Messages:
    345
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    D.C.
    ...and maybe a battery pull too? Also, would it help -- does any one know -- if she went into the "manage app" menu and rest data, cache or whatever for the calandar app?
  8. ThundarPanda
    Offline

    ThundarPanda New Member

    Joined:
    Aug 10, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Okay, since I just got this phone and haven't even gotten the chance to download millions of apps and customize a bunch of settings, I went with the factory reset to see what happens

    NOW "Sync Calendars" is showing up under accounts, along with contacts and Gmail! I'm assuming its going to sync now and all will be well.

    Thanks so much to both you guys! :heart:
  9. rouge1
    Offline

    rouge1 New Member

    Joined:
    Aug 13, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I had this same problem, tried reboot and pulling the battery with no luck.

    What worked was creating another Google account w/calendar setup before adding the account to the phone. Once I did that, the original Google account used showed the calendar sync option. After that I removed the account I just creating and I am syncing with no problems.
  10. DayDay
    Offline

    DayDay New Member

    Joined:
    Aug 12, 2010
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    0
    Once you log in you should be good to go for auto syncing all the time. (calender, contacts) If not, I use mIQ to manage this, makes it easy to see everything and does a backup of your phone.
  11. trippysht
    Offline

    trippysht New Member

    Joined:
    Aug 15, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    rouge- you're a genius! it worked like a charm. As soon as i added the dummy account, it picked up both calendars. thanks
  12. sobxals
    Offline

    sobxals New Member

    Joined:
    Aug 15, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Kind of same problem here. No problem synching my original gmail account/calendar, however I just added another calendar to my gmail profile which is not synching. Any help? Want to avoid any master reset....seems like a pain.

    Should there be this many problems gmail synching?
    Thanks!
    Scott
  13. trippysht
    Offline

    trippysht New Member

    Joined:
    Aug 15, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    set up first

    Make sure when you make a new gmail account that you log in and 'set up' the calendar before you sync the account to your droid. it's a one step process, but if it's not done BEFORE the sync, you wont ever find it.

    hope that helps?
  14. sobxals
    Offline

    sobxals New Member

    Joined:
    Aug 15, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Thanks Trippy!

    All squared away after setting up another account. All my calendars are now synching correctly. What a stupid process to get through, you'd think there would be a simpler solution!

    Thanks again!
  15. Rocinante
    Offline

    Rocinante New Member

    Joined:
    Aug 22, 2010
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Houston, TX
    Worked like a charm!! Thanks!! I convinced a friend to get a D2 because I love my D1 so much and this has been driving him nuts... Motorola support told him he had to do a reset but he didn't want to go back to square one on his setup..
  16. littlemay
    Offline

    littlemay New Member

    Joined:
    Oct 17, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    YES! This works beautiful. Easy way to get calendar to synch is to create a dummy google account. Use your primary google e-mail to share your calendar with the dummy account. Than Add the dummy GOOGLE account to the phone and the "Synch calendar" option will show up on account. After you confirm your primary google account has the "synch calendar" option, delete the dummy google account. TADA! calener is working now. THANK YOU!!! dancedroid
  17. Danilla Ice
    Offline

    Danilla Ice New Member

    Joined:
    Dec 8, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Thanks rouge1!

    Your suggestion of creating another google account worked perfect for me. The calendar sync on my original account magically appeared. Thanks for the info!
Search tags for this page
google calender droid 2
,

google sync for dummy

,
no sync calndars button
,
sync droid 2 calendar