google and facebook problems

Discussion in 'Android General Discussions' started by serveitup911, Jan 30, 2010.

  1. serveitup911
    Offline

    serveitup911 Member

    Joined:
    Dec 19, 2009
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Recently, google.com shows up as a blank page on my Droid.
    Also, touch.facebook doesn't fully load, and won't respond to any taps on the page. Is this happening to anyone else?
     
  2. KZIWarrior
    Offline

    KZIWarrior Silver Member

    Joined:
    Dec 31, 2009
    Messages:
    2,609
    Likes Received:
    2
    Trophy Points:
    103
    Location:
    Nashville, TN
    Ratings:
    +2
    Both are showing up fine for me. But I do use a non-stock browser (xScope is AWESOME). Power cycle the phone and try with another browser and see what happens.
     
  3. droider4life
    Offline

    droider4life Member

    Joined:
    Dec 28, 2009
    Messages:
    463
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I have been having the same problem also... most everything web related has been super slow! I was assuming it was due to crappy weather....
     
  4. bcnu53
    Offline

    bcnu53 New Member

    Joined:
    Jan 14, 2010
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Wyoming
    Ratings:
    +0
    I was having the same problem. but it cleared up and starting working yesterday? not sure what fixed it
     
  5. serveitup911
    Offline

    serveitup911 Member

    Joined:
    Dec 19, 2009
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I just downloaded and started using xScope based on KZI's suggestion.
    Everything is working fine now, and I really like xScope!