Gmail problem

Discussion in 'Android General Discussions' started by kamileon, Feb 28, 2010.

  1. kamileon

    kamileon Member

    Joined:
    Dec 4, 2009
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Phoenix, AZ
    Ratings:
    +0
    My gmail on my Droid says under my messages in my inbox No Connection and has a retry button. Button does nothing and tried hitting refresh in the menu. Also tried powering the phone off and battery pull with no results. As a last ditch attempt I swallowed the bullet and called VZW tech support. They told me to remove the gmail account and re install it. But the phone gave me a warning that the only way to do that was to reset the phone to factory defaults, and I dont want to do that, so they told me that was the only way to fix it and they couldnt help me. So I bring it to you guys. Thought that maybe goggle might be having server issues but can log onto my gmail through my browser. And couldnt find any one else here reporting the same problem.
     
  2. Sinbad

    Sinbad New Member

    Joined:
    Nov 22, 2009
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Reset

    Just reset the phone back to factory defaults, all of your contacts and apps are stored in the cloud (Google) VIA your GMail account. You have to re-activate the phone, but that is no big deal. Your micro-sd card will still contain all of it's data., no worries. Peace
     
  3. bass_lover1

    bass_lover1 Member

    Joined:
    Nov 18, 2009
    Messages:
    116
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Quite a drastic step for a rather simple fix.


    OP:

    Settings> Applications >Manage Applications

    Hit the menu button, change the filter to All. Scroll down to Gmail, then tap Clear Data. Hit the back button, go to Gmail Storage and tap Clear Data.

    Go back to your Gmail app and tap the retry button.

    Also, I'm just checking but if that doesn't work by chance did you change your gmail PW? You should get a notifaction about that in the notification bar. It should allow you to re-enter your password when you tap on that notification.
     
    #3 bass_lover1, Feb 28, 2010
    Last edited: Feb 28, 2010
  4. kamileon

    kamileon Member

    Joined:
    Dec 4, 2009
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Phoenix, AZ
    Ratings:
    +0
    That worked perfectly. Thanks alot.
     
  5. jsh1120

    jsh1120 Silver Member

    Joined:
    Dec 9, 2009
    Messages:
    2,454
    Likes Received:
    1
    Trophy Points:
    103
    Location:
    Seattle, Washington
    Ratings:
    +1
    A big round of applause for that bit of advice.
     
  6. aminaked

    aminaked Silver Member

    Joined:
    Jan 10, 2010
    Messages:
    2,183
    Likes Received:
    0
    Trophy Points:
    101
    Location:
    California, USA
    Ratings:
    +0
    Wifi might be causing the problem in the first place. As I've found in a couple of places on the web, the handover from wifi to 3G may cause a problem authenticating with google's servers--perhaps other servers too as I had pop email stop polling too. I've stopped using wifi and so far no problems. If you want to use wifi, this might work: toggle it on when in range of the signal and just remember to toggle it off when you are done.

    The syncing problem happens randomly and not everyone experiences it. Right now, my best guess is that wifi is the problem. Perhaps those people not having the problem have different wireless router setups. I for one, wander in and out of 2 wifi networks, one encrypted and the other not. I have no non-stock apps running in the background and have never used a task killer. I'm just saying this because people have told me that the syncing problem is "user error". For any responders with that opinion: what error am I making?