Gmail Notifications not Working

Discussion in 'Motorola Droid X' started by AlexRogers, Aug 5, 2010.

  1. AlexRogers
    Offline

    AlexRogers New Member

    Joined:
    Jul 16, 2010
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    0
    All of a sudden, gmail is no longer letting me know when a new email arrives. The settings are still the same, but now I have to go in to gmail and refresh the app. After the refresh, I get a notification. What could be going on here?

    Sent from my DROIDX using Tapatalk
  2. jimbo1mcm
    Offline

    jimbo1mcm New Member

    Joined:
    Jun 30, 2010
    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    0
    Battery Pull

    Do a battery pull and reset your notifications
  3. soulpatch
    Offline

    soulpatch New Member

    Joined:
    Jan 3, 2010
    Messages:
    327
    Likes Received:
    9
    Trophy Points:
    0
    Location:
    Downingtown, PA
    You didnt turn off your sync did you?
  4. aminaked
    Offline

    aminaked New Member

    Joined:
    Jan 10, 2010
    Messages:
    2,186
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    California, USA
    You basically never need to pull your battery out of your droid. I think that's a blackberry thing.

    Re-check all settings and make sure sync is on for your account.

    You're not using a task killer are you? Don't.

    After all that, you may need to clear "gmail storage" data via phone settings > applications > manage applications
  5. RadRyan122
    Offline

    RadRyan122 New Member

    Joined:
    Jul 16, 2010
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    I've been having trouble with this too. I went to check the sync settings for my gmail account and it didn't have a check box for me to turn it on for any of the services. I can force it to sync manually, but it won't let me turn the automatic sync on. Any ideas what might be causing this?
  6. dbigdawg
    Offline

    dbigdawg New Member

    Joined:
    Dec 30, 2009
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    0
    Did you disable background update or is your task killer killing it?
  7. AlexRogers
    Offline

    AlexRogers New Member

    Joined:
    Jul 16, 2010
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    0
    Ok. Ive just tried everything and it's still not working. I don't have a task killer either. Where are the background settings?


    Sent from my DROIDX using Tapatalk
  8. aminaked
    Offline

    aminaked New Member

    Joined:
    Jan 10, 2010
    Messages:
    2,186
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    California, USA
    on droid x it should be:

    setting> data manager > data delivery

    let us know if turning that on works
  9. RadRyan122
    Offline

    RadRyan122 New Member

    Joined:
    Jul 16, 2010
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    On my X I don't even have a task killer, I have background updates turned on, and everything else syncs up fine. The only time I have trouble syncing is with my google account.
  10. aminaked
    Offline

    aminaked New Member

    Joined:
    Jan 10, 2010
    Messages:
    2,186
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    California, USA
    You said there was no checkbox next to your account. If you go to phone settings > accounts and sync > choose your account, you should see a checkbox next to gmail. Is it checked?

    Are you totally sure you have background data checked? You might want to double check under settings > data manager. When I uncheck background data, it removes the checkboxes I was talking about.
  11. RadRyan122
    Offline

    RadRyan122 New Member

    Joined:
    Jul 16, 2010
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    It's not checked, because it doesn't exist. When I go to Settings > Accounts > My Google Account, it shows me the options to sync all three, and I've seen screenshots with a checkbox to the right, but for some reason it just isn't there. I have no idea why, either.
  12. aminaked
    Offline

    aminaked New Member

    Joined:
    Jan 10, 2010
    Messages:
    2,186
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    California, USA
    that's odd. On the droid X when I go to phone settings > accounts > click on main gmail account, it takes me to a screen where I can check "Sync gmail"
  13. ncolliso3188
    Offline

    ncolliso3188 New Member

    Joined:
    Aug 7, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    It's not checked, because it doesn't exist. When I go to Settings > Accounts > My Google Account, it shows me the options to sync all three, and I've seen screenshots with a checkbox to the right, but for some reason it just isn't there. I have no idea why, either.[/QUOTE]

    I have the same exact problem! Only have the three sync options; Calendar Contacts and Gmail. I don't have a check box or anything. I even removed the account and re-added the account and still don't have the sync option. Its very annoying to refresh the mail to get the notifications
  14. aminaked
    Offline

    aminaked New Member

    Joined:
    Jan 10, 2010
    Messages:
    2,186
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    California, USA
    Maybe try toggling background data off then on in phone settings > data manager

    Also, if you have the power widget installed, make sure that the two arrow in a circle is turned on (that's sync).

    I know this for sure: if I toggle off background data, the checkboxes next to gmail, contacts, and calendar disappear.

    You might have found a bug.
  15. dulaney22
    Offline

    dulaney22 New Member

    Joined:
    Jul 15, 2010
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    0
    Mine has been acting up for a couple days. It wouldn't auto sync and it put my new mail in the "All" box instead of "Inbox." Now when I try to open the app it FCs.
  16. RadRyan122
    Offline

    RadRyan122 New Member

    Joined:
    Jul 16, 2010
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    That was it, thanks. Apparently I had it turned off on the widget, which just overrides the settings option in the Data Manager instead of changing them.
  17. terryharrison
    Offline

    terryharrison New Member

    Joined:
    Dec 8, 2009
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Dothan, AL
    There is an app called gmail notifier, works great. Gives a notification of every new email. Without it I was only getting a notification of the first new email. If I didn't check my email on that first notification then the next new email that came in gave me no notification. Gmail notifier solved that problem.
  18. aminaked
    Offline

    aminaked New Member

    Joined:
    Jan 10, 2010
    Messages:
    2,186
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    California, USA
    Cool radryan, glad you got it sorted out.

    That's a different problem:
    http://www.droidforums.net/forum/dr...il-keeps-closing-when-i-try-scroll-inbox.html

    I thought they fixed that in the 2.1 update. Maybe not, according to this:
    http://code.google.com/p/android/issues/detail?id=4190

    Wow, google has "declined" the enhancement.
Search tags for this page

android gmail notification not working

,

android gmail notifications not working

,
gmail android notifications not working
,

gmail notification android not working

,
gmail notification not working in droid x
,
gmail notification not working on android
,
gmail notification on android not working
,

gmail notifications android not working

,

gmail notifications not working

,

gmail notifier not working on android

,
gmail on droid x