Gmail not syncing on Droid 2??? I tried to research no luck.. Pls help

Discussion in 'Motorola Droid 2 Global' started by gianboy, Mar 28, 2011.

  1. gianboy
    Offline

    gianboy New Member

    Joined:
    Mar 28, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I had my Droid 2 Global for 3 weeks now, I setup my gmail account the day I got it. But for the past week my incoming gmail hasn’t been coming in unless I hit the refresh botton- before I would get emails instantly. I went to application and clear data and cleared cache, I even pulled out battery still not luck… I haven’t changed any setting. What could be the problem? I even created a 2nd gmail account to see if it does the same and no luck… I tried to delete gmail account but it won’t let me unless I factory reset phone. Which I don’t too or I will lose all my apps.

    Any ideas???


    Thanks John
  2. hapster
    Offline

    hapster New Member

    Joined:
    Mar 7, 2010
    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    USA, Kentucky
    I'm on a D1 and I've been having Gmail probs the past few days. I'd read msgs, close Gmail and open it again to find those same msgs sitting there as unread, even if I'd deleted them.

    I was beginning to think it was related to the SS5.2 rom I installed on Fri, but as of this morning, all seems to be working again. I hope so. Otherwise, I'll be doing another wipe/install of my rom.

    Sent from my Moto Droid
  3. leobg
    Offline

    leobg Member

    Joined:
    Jun 9, 2010
    Messages:
    658
    Likes Received:
    2
    Trophy Points:
    18
    Go to settings/accounts and tap on your google account. Make sure checkmark before "sync Gmail" is checked (and the others if you care about contacts and calendar).
    Then go to settings/data manager/data delivery and make sure background data checkbox at top is enabled.
  4. louy99
    Offline

    louy99 New Member

    Joined:
    Jan 4, 2011
    Messages:
    565
    Likes Received:
    1
    Trophy Points:
    0
    If you open settings/applications/manage applications. Select gmail and then clear data. That should help it sync again. I have to do that every once in a while.

    Sent from my DROID2 using DroidForums
  5. 13th angel
    Offline

    13th angel Developer Developer

    Joined:
    Jan 16, 2011
    Messages:
    2,102
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Auburn, Alabama
    I had that problem until I figured out what it was.... somewhere in setting (I can't remember where anymore) there's a battery saver thing, if its set on night time then it wont sync unless you manually sync.

    Sent from my Liberated D2G
  6. turnpike
    Offline

    turnpike New Member

    Joined:
    Feb 8, 2011
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    0
    syncing my gmail through a wireless connection this past week has been 10x slower then usual
Search tags for this page

droid global 2 gmail contact not syncing