Getting that android Os percentage down

Discussion in 'Samsung Galaxy Nexus' started by bsmith0731, Jan 21, 2012.

  1. bsmith0731

    bsmith0731 Member

    Joined:
    Nov 18, 2011
    Messages:
    386
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Virginia
    Ratings:
    +4
    Suggestions?

    What do you recommend??

    I'm running stock...

    Anyone else running stock that has mastered this??




    Sent from my Galaxy Nexus using DroidForums
     
  2. WookieClaws

    WookieClaws Member

    Joined:
    Sep 20, 2011
    Messages:
    244
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Oregon
    Ratings:
    +1
    Some people have reported that changing the radio file helps. I haven't tried it, but I'm considering rooting etc.

    My Xoom just got the 4.0.3 update and the Android OS percentage and time is way, way less. So i'm really hoping the 4.0.3 ota update fixes this. I heard there is an update coming in January, but no real specifics.

    Sent from my Galaxy Nexus using DroidForums
     
  3. Nealius

    Nealius Member

    Joined:
    Jul 3, 2010
    Messages:
    361
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    I'm on my third nexus. Finally I am getting good battery life. Currently at 7 hours with 54%. I just checked the os has used 17% not great but lower than the other 2 phones I had.
    One thing I did notice is my radio is I515.10 instead of .09
    I can't remember how to do a screen shot or I would have added them

    Sent from my Galaxy Nexus using DroidForums
     
  4. BayouFlyFisher

    BayouFlyFisher Rescue Squad
    Rescue Squad

    Joined:
    Dec 10, 2009
    Messages:
    4,958
    Likes Received:
    17
    Trophy Points:
    168
    Location:
    Baton Rouge, LA
    Ratings:
    +17
    As noted in a lot threads on a lot of forums, there are some phones that have a problem with the Android OS and the "Keep Awake" time. There seems to be an issue with some phones not truly going to sleep when the power button is used to turn off the screen as opposed to letting the screen turn off automatically when the screen times out. This results in a very high time in the Settings/Battery/Android OS/Keep Awake menu.

    In stock form and with every rom that I have installed, my "Keep Awake" time was always about 50-60% of my total battery time. If the phone had been off charger for 8 hours, I'd have 4-6 hours of Andorid OS "Keep Awake" time. This was true even if the phone had been in my pocket unused and seems to be exacerbated by my habit of turning the screen off manually with the power button every single time. I used to never let the screen timeout.

    There seems to be two "fixes" according to Franco (of kernel fame). One concerns the camera. Seems the camera is started and then turned off during startup. But in so doing, it leaves a sensor active and this prevents the phone from actually going to sleep. So he recommends starting and using the back button to go back to the home screen. The other is DRM Protected Content. He recommends this be disabled or frozen. A third, that I don't believe I recall seeing him recommend but that I have seen on his thread at XDA (down for blackout right now) is to disable Maps.

    I have done all three of those and my Keep Awake time has gone from 40-50% of my total battery time down to a few percentage points. I mean if I don't use my phone it will now show less than a minute of Keep Awake time per hour.

    Good luck
    [FONT=&quot][/FONT]
     
  5. bsmith0731

    bsmith0731 Member

    Joined:
    Nov 18, 2011
    Messages:
    386
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Virginia
    Ratings:
    +4
    Thanks for your Suggestions...

    Not sure I can completely disable Maps... as I am a Tour bus Driver... and I rely on that very heavily!


    The other 2 you have mention Bayou, i have disabled!

    Nealius.. What is your reasoning that you tell Verizon why you need a new phone? Just curious so I could possibly use the same excuse...

    Wookie, how is 4.0.3 on the Xoom?
     
  6. Nealius

    Nealius Member

    Joined:
    Jul 3, 2010
    Messages:
    361
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    I bought my phone thru a premier retailer if Verizon first reason it was showing the mgr my 4 hour battery life. My os was thru the roof. 2nd phone was the next with massive dropped calls I swapped to a rezound for less than a day. It was doing a reboot loop. Finally on my 13 th day I got this nexus
    I had to use a bit of force and remind them I am the customer I just hope this one is the one

    Sent from my Galaxy Nexus using DroidForums
     
  7. HikenGruven

    HikenGruven Member

    Joined:
    Aug 28, 2010
    Messages:
    163
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Towson, MD
    Ratings:
    +0
    How do you go about disabling maps in stock? It only gives me an option to uninstall updates.

    Sent from my Galaxy Nexus using DroidForums
     
  8. steveil

    steveil Member

    Joined:
    Sep 4, 2010
    Messages:
    116
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I force stop maps but it seem to start running again - not sure why.
     
  9. Nealius

    Nealius Member

    Joined:
    Jul 3, 2010
    Messages:
    361
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    uninstall updates first then the button will change to disable.
     
  10. ruvy01

    ruvy01 Member

    Joined:
    Sep 22, 2010
    Messages:
    135
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Wastefield, New England
    Ratings:
    +4
    you have to uninstal updates first..then you can disable it.
     
  11. HikenGruven

    HikenGruven Member

    Joined:
    Aug 28, 2010
    Messages:
    163
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Towson, MD
    Ratings:
    +0
    Thanks! Bites that I have too uninstall the updates first. Sometimes I just don't need it for a couple of weeks.

    Sent from my Galaxy Nexus using DroidForums
     
  12. prowler85

    prowler85 Member

    Joined:
    Mar 2, 2010
    Messages:
    497
    Likes Received:
    8
    Trophy Points:
    18
    Location:
    Arizona
    Ratings:
    +8
    And the 4th option would be to let your phone time-out on its own (i.e., don't use the power button to turn off the screen). I did this for a few days and it does fix the problem. Seems like a much better option to me than to disable Maps (which seems like you're disabling a prime feature of all smartphones).
     
Search tags for this page

android os battery percentage

,
android os percentage battery
,
android os percentage high
,
android os running high
,
android os using 41 percent power
,
how can i reduce my andriod os percentange?
,
how come my android system percentage so high?
,
how to decrease screen percentage on nexus 7
,
my android battery percent reduce by 2 percents
,
why is my android os so high