Get swype working for D2 on your leaked rooted GB!

Discussion in 'Motorola Droid 2 Development' started by drinksprite, Mar 30, 2011.

DroidForums.net is the premier Android Forum - Registered Users do not see these ads. Please Register - It's Free!
  1. drinksprite
    Offline

    drinksprite Member

    Joined:
    Jan 26, 2011
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    After countless hours trying to figure out how to fix the swype keyboard, I had a revelation...to just uninstall and reinstall it haha.

    Anyway here's how:

    1.Download Root Uninstaller from the app market. Uninstall, or "backup" swype to the sd card.

    2.Get the swype installer from beta.swype.com. You're gonna have to register to get the download link. It sends a link to your email right away.

    3. Run the swype installer (you'll need to change permissions to allow installation of non market apps). It even has a cool tutorial at the end that taught me some tricks I never knew before.

    4.*UPDATE* Generate License!*

    Enjoy! Hope it works for you. It should. I now like my phone again :)


    Sent from my DROID2 using DroidForums
    Last edited: Mar 30, 2011
  2. briantek
    Offline

    briantek New Member

    Joined:
    Dec 23, 2009
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thanks man this worked great. BTW I like the new look of swype too!
  3. drinksprite
    Offline

    drinksprite Member

    Joined:
    Jan 26, 2011
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    yea it looks pretty cool I just wish we had the option to change it's appearance/color

    Sent from my DROID2 using DroidForums
  4. drinksprite
    Offline

    drinksprite Member

    Joined:
    Jan 26, 2011
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    *update* I noticed that you have to click "generate license" during the install to keep it working after reboot. If u dont then youll have to do it over again.

    Sent from my DROID2 using DroidForums
    Last edited: Mar 30, 2011
  5. udaykiran0
    Offline

    udaykiran0 New Member

    Joined:
    Nov 2, 2010
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thanks man works good for me
    Last edited: Mar 31, 2011
  6. Bert336
    Offline

    Bert336 New Member

    Joined:
    Jul 15, 2010
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    does anyone know of a better fix? i reboot my phone after i install apps or uninstall (perhaps there's no reason for me to do so but i do it anyways) but after every reboot i have to regenerate the license of the Beta Swype... it takes 3 mins to do so but i would use those 3 minutes browsing the forum instead of regenerating the swype license :)
  7. drinksprite
    Offline

    drinksprite Member

    Joined:
    Jan 26, 2011
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Hit Menu>Settings>Language & Keyboard.

    Disable swype then enable it. This works whenever it stops working randomly.
  8. YourAverageJD
    Offline

    YourAverageJD Member

    Joined:
    Feb 12, 2011
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    SD
    Ratings:
    +0
    Worked. Yes.

    Sent from my DROID2 using DroidForums
  9. nerdslogic
    Offline

    nerdslogic Silver Member

    Joined:
    Nov 20, 2010
    Messages:
    2,540
    Likes Received:
    1
    Trophy Points:
    103
    Location:
    Cybertron
    Ratings:
    +1
    I keep getting an error "parsing package" and I don't see no generate license thingy
  10. nerdslogic
    Offline

    nerdslogic Silver Member

    Joined:
    Nov 20, 2010
    Messages:
    2,540
    Likes Received:
    1
    Trophy Points:
    103
    Location:
    Cybertron
    Ratings:
    +1
    well got past that part and now I am lucky enough to have constant force closes....