Gallery Closing

Discussion in 'Motorola Droid X' started by kwod8832, Feb 2, 2011.

  1. kwod8832
    Offline

    kwod8832 New Member

    Joined:
    Sep 10, 2010
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    0
    I noticed a few days ago anytime I tried to open my Gallery it would start to open then shut within a couple of seconds after I attempted to open it. I have restarted my DX numerous times and even resorted to a battery pull. I can access my photos and videos through Astro but it takes a while to load all of my photos. Any suggestions?

    I am rooted with Z4root.
  2. Ern3
    Offline

    Ern3 New Member

    Joined:
    Nov 8, 2009
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Chicago, IL
    I am having the same problem...please help!

    I was trying to take a video yesterday, and it wouldn't save right and I plugged it into the computer to try and access thr video... But it was not playing. Now I cannot aces the gallery, same as op...

    Sent from my DROIDX using DroidForums App
  3. Ern3
    Offline

    Ern3 New Member

    Joined:
    Nov 8, 2009
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Chicago, IL
    Oh, and I am stock...



    Sent from my DROIDX using DroidForums App
  4. nakhleh926
    Offline

    nakhleh926 New Member

    Joined:
    Nov 26, 2010
    Messages:
    398
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Michigan
    I had this issue too, I don't know what caused it but a format fixed it.
    by format I mean re flashing the rom I was on, but since you're stock I would try formatting :/.

    Sent from my DROIDX using DroidForums App
  5. mwshows
    Offline

    mwshows New Member

    Joined:
    Jan 26, 2011
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    0
    I had this problem after downloading icon packs and had like 1000 icon pics show up in my gallery. The next day evetytime i tried to open the gallery it would open for a second and then just close.

    Anyway, i found a fix after doing some research on this and other forums. It worked for me like a charm.

    You need to go into Settings/Applications/Manage Apps. From here click on the show all tab and clear the cache for all of the following:

    Gallery
    Media Storage
    Media Container Service

    It is not enough to clear just the Gallery cache. You have to clear all of them and then reboot your phone.

    Now when i did this i noticed 2 important things. First, i lost my deisignated contact ringtones so i had to go back into my contacts that i had special ringtones for and reset them. Second, the gallery took around 7 minutes to reload because it had to build the thumbnails again. You might also notice that you have to reset some settings in your texting app, but all of this is much better than having to reformat your SD card...at least in my opinion.

    Hope this helps. As i said it was posted elsewhere and it worked perfectly for me.

    Sent from my DROIDX using Tapatalk
  6. kwod8832
    Offline

    kwod8832 New Member

    Joined:
    Sep 10, 2010
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for the help, but I had to do a factory restore. What a pain in the a$$.
  7. BMWBig6
    Offline

    BMWBig6 New Member

    Joined:
    Aug 4, 2010
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    0
    I bet your thumbnail cache is corrupt.

    If the cache method doesn't work, try installing a 3rd party gallery app like 3D Gallery. Once that was installed, it reset all the thumbnails and my stock gallery started working again all by itself!
  8. dtsig
    Offline

    dtsig New Member

    Joined:
    Oct 22, 2010
    Messages:
    117
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Tigard, Oregon
    Also, after 3d gallery is installed look for any 'picture' which just shows a black square. this is usually the corrupt thumbnail. Delete it and you should be good after a restart. Or instead of a restart you can get sdrescan which will do the same thing.
  9. xmguy
    Offline

    xmguy New Member

    Joined:
    May 5, 2010
    Messages:
    1,070
    Likes Received:
    4
    Trophy Points:
    0
    Location:
    RURAL TN
    I had the same issue. Move all of your files from the memory card. Format the card. Move them back and it should work.
  10. jray2855
    Offline

    jray2855 New Member

    Joined:
    Dec 18, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    When you clear the cache you don't lose all the pictures do you??
  11. jray2855
    Offline

    jray2855 New Member

    Joined:
    Dec 18, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    I'm having the same problem :( I've been trying to open my gallery to look at my pictures and it just closes. There was a suggestion on this post earlier about clearing the cache but I'm afraid I will lose my pictures. Will they get lost? Any help would be appreciated.

    Thanks !
  12. xliderider
    Offline

    xliderider New Member

    Joined:
    Nov 6, 2009
    Messages:
    1,396
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Where Diamond Head stay
    No, clearing the caches does not cause any pictures to be lost.

    Just a word of caution to anyone having problems with your sd card. Other members have reported their sd card failing lately. This could be a sign that your card is about to cr@p out. If you reformat the card, keep your backed up files on your computer, if your card fails, you won't lose anything. If you fix the problem by clearing the caches, make a backup to your computer as well.
  13. timrock
    Offline

    timrock New Member

    Joined:
    Aug 21, 2010
    Messages:
    578
    Likes Received:
    0
    Trophy Points:
    0
    i had this problem months ago. i reformatted my card (after transferring all of its contents to my pc first) then put all my stuff back on the card, and it worked. i have not had this issue since.
  14. Natey2
    Offline

    Natey2 Active Member

    Joined:
    Oct 23, 2010
    Messages:
    1,339
    Likes Received:
    4
    Trophy Points:
    38
    I get this problem once in a while with both the Motorola stock gallery, and the 3D gallery.
    In my case, one file in the gallery is corrupt/won't display, and the WHOLE gallery won't start up at all.
    So much for Motorola's error handling capability...
    I need to use a File Browser and manually locate and delete the bad file (it is NOT a cache issue), and the sub-standard galleries will work again, until the next time it occurs.

    The only gallery that can withstand a corrupt file is JustPictures! by Kounch.

    Sent from my DROIDX using DroidForums App
  15. mwshows
    Offline

    mwshows New Member

    Joined:
    Jan 26, 2011
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    0
    Same answers as above. I could not find a "black" or blank picture in my gallery, but still assumed it was a corrupt thumbnail gallery. The cache fix hasn't worked for everyone. It just seems to be one of those small pain in the butt things we have to put up with until there is a fix for this obvious issue.

    Along with everyone else here, i strongly reccomend backing up your SD card onto your computer, as it seems people have been having issues with them. I have been lucky so far lol.

    Sent from my DROIDX using Tapatalk
  16. Natey2
    Offline

    Natey2 Active Member

    Joined:
    Oct 23, 2010
    Messages:
    1,339
    Likes Received:
    4
    Trophy Points:
    38
    I wish there was an option to turn off the cache for those sub-standard galleries. Things will be slower, but at least they'll still work if the images go out of synch with the cache, or if it was a cache problem.

    Since I almost lost a couple of hundred pics once on my DroidX (I had to use a PC-based file-recovery program to recover the images from the SD card), I've learned never to leave any picture I value on my DroidX for more than a couple of days.
  17. Lex_Luthor
    Offline

    Lex_Luthor New Member

    Joined:
    Aug 2, 2010
    Messages:
    317
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Washington State
    I had this problem and i think it must have been a rogue app that messes with this because i noticed this after downloading one or two wallpapers downloading apps. But even after i uninstalled those the gallery still didnt work. I had the reflash my ROM to get it work but its probably what they stated before. Just do a factory wipe and you should be fine.
  18. jray2855
    Offline

    jray2855 New Member

    Joined:
    Dec 18, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    Factory wipe? Won't that delete my pictures?? And... how do you do it?
  19. Lex_Luthor
    Offline

    Lex_Luthor New Member

    Joined:
    Aug 2, 2010
    Messages:
    317
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Washington State
    no the factory/data reset wont delete your pictures. It will only delete/format the data and caches in the phones internal memory, it wont touch anything in your SD card(thats where your pics should be at). Its going to delete you apps but google makes backups of those, but leave it alone while its redownloading them or else you will have to manually download them. Also when you reboot you phone you will have to set everything back up the way it was, its a bumer but you know your phone isnt going to be goofy. The way to do this is to go to settings and it should be under privacy. If you dont want to do that then you can go to settings/applications/manage apps/ find the gallery app and clear data and cache and then reboot. Im not sure if this method works but you can try, it wont mess anything up since its already messed up. But try uninstalling any apps that you downloaded before the gallery went kaput and then clearing the data and cache and rebooting. If you need any clarifications, ask
  20. GeXX
    Offline

    GeXX New Member

    Joined:
    Feb 7, 2011
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    0
    This was happening to me, my fix was to clear one of the gb's, not the gallery, but I remember databases.. It reset my ringtones and gallery, maybe media storage?

    Once I did that I reboot the phone and it rebuilt the gallery db & I had to reset my ringtones.
Search tags for this page

closing a gallery

,

gallery auto closes

,
gallery is closing automatically
,
if i clear data for gallery will it delete all my photos
,
if i clear data from gallery app will i loose my photos
,
if i clear data on gallery what happens
,
if i clear my gallery cache/data, will it delete all my phot
,
if you clear data on gallery app will it delete photos
,
what happens if i clear the cache for my gallery
,

what happens to gallery app if you clear data and force clos

,
will clear data in gallery remove my pixs
,

will gallery app delete photos if you clear data and force c

,
will i delete my pics if i clear cache in gallery
,

will i lose my pictures if i clear data on the gallery app

,
will i lose my pictures if i delete the gallery app?