For the OCD - Stop the home button from waking the screen (And Save Battery)

Discussion in 'Drod2169 - X' started by ShadowfoxXXX, Mar 13, 2011.

  1. jr1421

    jr1421 New Member

    Joined:
    Nov 21, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    It definitely does work better on GB. Now, when using the widget "No Lock," the hard buttons will not wake the phone even when you have the No Lock widget set to Unlocked. This means, for me, that I can completely bypass the slide-to-unlock screen altogether, and simply press the power button to unlock directly. On froyo, with the No Lock widget set to Unlocked, the hard buttons would still wake the phone (at least it did for me). Now I don't have to use the Antilock app anymore :)
     
  2. timfromthegym

    timfromthegym New Member

    Joined:
    Apr 16, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    SO, I tried to download your file by right clicking, and it took me to an invalid dropbox site. I thought this was the problem, so i tried to download it via a right click of the file... when i right clicked and did "save as" it downloaded the text from the error webpage into the cdma_shadow_keypad.kl.

    I replaced the original file with this error file, and now every button wakes up my phone and there is no lock on the phone whatsoever. It did the complete opposite of what I expected!

    Does anyone have the original cdma_shadow_keypad.kl, or the revised file that ShadowfoXXX put out so that I can have my phone actually have buttons that dont wake.

    This is truly terrible as now when the phone is in my pocket all the hard buttons including the volume rockers and camera wake the phone up and i pocket dial people let alone KILL my batter on the X.

    HELP!

     
  3. jr1421

    jr1421 New Member

    Joined:
    Nov 21, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Here you go - this is the edited one.

    Forgot to mention, after you unzip it and place it in system/usr/keylayout, change the permissions to read/write for user, and just read for group/others. Once you've changed the permissions, reboot before testing it out.
     
    #27 jr1421, Apr 16, 2011
    Last edited: Apr 16, 2011
  4. mebobio

    mebobio New Member

    Joined:
    May 25, 2010
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    rooted?

    Do you need to be rooted to access the permissions from the root file?
     
  5. jr1421

    jr1421 New Member

    Joined:
    Nov 21, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I cannot get this procedure to work with gingerbread .591. I've tried editing the .kl file and manipulating the permissions, but the hard buttons still wake my phone. Has anyone else had success with gingerbread .591?
     
  6. SuperChargedJ

    SuperChargedJ New Member

    Joined:
    Feb 15, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    +1

    This seriously annoyed the crap out of me this morning when I couldn't get it to work. Looking forward to the fix for this as well.
     
  7. jr1421

    jr1421 New Member

    Joined:
    Nov 21, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    *Bump* Has anyone gotten this to work with .591?
     
  8. Scallywag1

    Scallywag1 Member

    Joined:
    Oct 21, 2010
    Messages:
    179
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Its driving me crazy!!

    Sent from my Liberty GB v5 DX
     
  9. jr1421

    jr1421 New Member

    Joined:
    Nov 21, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Update - have not been able to get it to work on .595 either. Still looking into it...
     
  10. ShadowfoxXXX

    ShadowfoxXXX Member

    Joined:
    Jan 16, 2011
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Im on it. give me a bit...
     
  11. jr1421

    jr1421 New Member

    Joined:
    Nov 21, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Ok great let us know if you make any progress.
     
  12. paulp04

    paulp04 New Member

    Joined:
    Oct 25, 2010
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Ive been looking into this myself and Its puzzling me.... nothing seems to disable the home/wake button.... has anyone had any success?
     
Search tags for this page

android disable home button unlock

,
disable home button unlock
,
disable home key unlocking s4
,
disable home key wake up galaxy s4
,
disable keyboard slide screen wake
,
galaxy s4 prevent home button from waking phone
,
gingerbread home button wake
,
how to disable home button unlock
,
how to disable home button unlock s4
,
stop unlock with home button android