For the OCD - Stop the home button from waking the screen (And Save Battery)

Discussion in 'Drod2169 - X' started by ShadowfoxXXX, Mar 13, 2011.

  1. ShadowfoxXXX
    Offline

    ShadowfoxXXX Member

    Joined:
    Jan 16, 2011
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I was becoming very agitated because my phone screen was continually turning on in my pocket, wasting battery, because the home button was getting pressed.
    Well no more!

    I'm not hosting this file anymore, It's so easy to do manually there's no point.

    GINGERBREAD
    ____________________________________
    Open /system/usr/keylayout/sholes-keypad.kl
    remove "Wake_Dropped" And/or "Wake" after any entries for:
    HOME
    MENU
    SEARCH
    BACK
    VOLUME UP
    VOLUME DOWN
    _________________________________________

    FROYO
    _________________________________________
    Open /system/usr/keylayout/cdma_shadow-keypad.kl
    remove "Wake_Dropped" And/or "Wake" after any entries for:
    HOME
    MENU
    SEARCH
    BACK
    VOLUME UP
    VOLUME DOWN
    __________________________________________

    Now the only button that wakes the screen is the power button.


    Dont remove anything other than what I've listed above, do not remove wake from you power button, or you may not be able to wake your phone at all (untested)

    You MUST remove wake/wake_dropped from ALL of the entries listed as only removing wake from home causes all the buttons except home to wake the screen.

    PROBLEMS?
    ||
    ||
    \ /
    \/

    Make sure you change permissions as well (Credit to humungus)


    Last edited: May 17, 2011
  2. drod2169
    Offline

    drod2169 Premium Member Premium Member Developer

    Joined:
    Apr 12, 2010
    Messages:
    677
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I'll sticky this, this is a nice find. Honestly, I never had this issue when I had an X, so I never thought to implement anything like it. WHENEVER the next rubiX may be, this will be included (hopefully I don't forget it with my crappy memory)
  3. PerCompLLC
    Offline

    PerCompLLC Member

    Joined:
    Dec 20, 2009
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Northern Virginia
    Ratings:
    +0
    Nice! Thank you! :)
  4. humungus
    Offline

    humungus Member

    Joined:
    Aug 8, 2010
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Beautiful. Thanks.
  5. bishyaler
    Offline

    bishyaler New Member

    Joined:
    Dec 15, 2009
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I've waited for this fix for so long, especially because it would keep the voice search from activating in my pocket. Problem: I copied the file, rebooted, but the front keys still wake the phone?
  6. humungus
    Offline

    humungus Member

    Joined:
    Aug 8, 2010
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Did you change the file's permissions? They need to be RW-R-R. Long press on the file in Root Explorer, go to 'Permissions' and make sure there are only checkmarks for:

    User: Read, Write
    Group: Read
    Others: Read

    Then reboot.

    Also, when I downloaded the file it added an extra .kl to the end of the filename (it was XXX.kl.kl). Make sure you delete 1 of the .kl's.
  7. bishyaler
    Offline

    bishyaler New Member

    Joined:
    Dec 15, 2009
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    That fixed it. Thank you!
  8. mugsy77
    Offline

    mugsy77 Member

    Joined:
    Oct 17, 2010
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Dallas
    Ratings:
    +0
    Great find indeed! Thanks!
  9. ShadowfoxXXX
    Offline

    ShadowfoxXXX Member

    Joined:
    Jan 16, 2011
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I did not even think about permissions, I will add this this right now.
  10. OnMy2ndGP
    Offline

    OnMy2ndGP Member

    Joined:
    Sep 27, 2010
    Messages:
    212
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I thought I'd like this but I didn't realize just how often I actually use the home button to wake up my DX. DRod, if you do remember to add this, please make it an option to enable or disable.

    But now I something else to play with within that file.
  11. ShadowfoxXXX
    Offline

    ShadowfoxXXX Member

    Joined:
    Jan 16, 2011
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Its not hard to switch on and off.
    Honestly I've never once used the home button to wake the screen, never made any sense to me at all. Id pull it out of my pocket all the time and the screen would already be on.
    With this hack ive noticed a marginal increase in battery life, but its mostly just to abate my OCD
  12. OnMy2ndGP
    Offline

    OnMy2ndGP Member

    Joined:
    Sep 27, 2010
    Messages:
    212
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    LOL! I feel ya.
  13. SuperChargedJ
    Offline

    SuperChargedJ New Member

    Joined:
    Feb 15, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I tried this hack and it didn't work. I checked to make sure that onlythe right boxes were checked in the permissions and after I rewrote the file, it showed up correctly. When I rebooted the phone it loaded all the way but the screen would stay frozen after the widgets loaded. The power button would not respond. The other buttons didn't do anything as well (which is a good thing, I guess).

    The one thing I think may be the problem is after rewriting the file it showed a "cdma_shadow-keypad.kl.bak" file underneath the "cdma_shadow-keypad.kl". There was not double .kl.

    Any help would be greatly appreciated.
  14. ShadowfoxXXX
    Offline

    ShadowfoxXXX Member

    Joined:
    Jan 16, 2011
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    The BAK file is automatically created as a backup of the original file by some apps.
    The only thing I can think if is whether you did a battery pull or soft reboot,
    Also try opening permissions and checking ALL the boxes.
    If nothing works restore the BAK to .fl and overwrite the new one to go back to how it was.

  15. SuperChargedJ
    Offline

    SuperChargedJ New Member

    Joined:
    Feb 15, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Ok, I got this to work now. I noticed that when used no lock and I disabled the lock I could turn the phone on with the home and other buttons. When the lock was enabled, the menu, home, back and search do not wake up the screen. :)



    Sent from my DROIDX using DroidForums App
Search tags for this page

android disable home button unlock

,
disable home button unlock
,
disable home key unlocking s4
,
disable keyboard slide screen wake
,
galaxy s4 prevent home button from waking phone
,
gingerbread home button wake
,
how to disable home button unlock
,
how to disable home button unlock s4
,
how to disable samsung s4 home button from unlocking phone
,
stop unlock with home button android