[FIX] 12.11 MIUI music play when unplugging headphones

Discussion in 'Team D1-MIUI' started by yakitori, Dec 15, 2010.

  1. yakitori

    yakitori Premium Member Theme Developer Premium Member

    Joined:
    Sep 7, 2010
    Messages:
    2,548
    Likes Received:
    10
    Trophy Points:
    103
    Location:
    DFW Texas
    Ratings:
    +10
    To fix this issue.

    Use root explorer (or another method of your choic).

    1. Move miuimusic.apk from /system/app to /sdcard

    2 reboot

    3 move miuimusic.apk from /sdcard to /system/app

    4 change permissions to rw-r--r--

    5 reboot.


    No more annoying force starts when you unplug your headphones or aux jack.
     
  2. BullDroid

    BullDroid Member

    Joined:
    Jan 19, 2010
    Messages:
    251
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    hmmm this is odd because ever since I have been running this Rom I have not had that issue once! And I use my phone to listen to music all the time in fact HALF of my sd card is music! lol Glad there is a fix for others with the issue though! I did have this issue once but it was on Sapphire's Rom.
     
  3. yakitori

    yakitori Premium Member Theme Developer Premium Member

    Joined:
    Sep 7, 2010
    Messages:
    2,548
    Likes Received:
    10
    Trophy Points:
    103
    Location:
    DFW Texas
    Ratings:
    +10
    Did you wipe?

    Sent from the shadows of Kuro
     
  4. BullDroid

    BullDroid Member

    Joined:
    Jan 19, 2010
    Messages:
    251
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Ive been installing Rom's since Adamz's smoked glass was the most popular Rom and yes I always always wipe! :) not sure why yuou asked though because I dont have the music playing unplugging issue. I did when I was on Sapphire but that was the only Rom I've ever had that issue on. And now my only issue with MIUI is I get soft reboots fairly often.
     
  5. seang

    seang Member

    Joined:
    Jan 23, 2010
    Messages:
    312
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    i get this issue. i always triple wipe.
     
  6. seang

    seang Member

    Joined:
    Jan 23, 2010
    Messages:
    312
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    not only that, i just noticed while i was on my bluetooth, my music widget was going ape****, skipping through songs.
     
  7. yakitori

    yakitori Premium Member Theme Developer Premium Member

    Joined:
    Sep 7, 2010
    Messages:
    2,548
    Likes Received:
    10
    Trophy Points:
    103
    Location:
    DFW Texas
    Ratings:
    +10
    I know others have reported this issue as well.

    I was asking if a wipe was done before installing 12.11 because I did wipe and install fresh...and manually reloaded my apps one by one. I dont use a backup tool to restore apps.

    I noticed this because I listen to pandora in my car through aux and when I pulled it out to get out of my car...my miuimusic was going like (pause, play, pause, play, pause, play)...and then would just play altogether.

    Moving out of /system/app and back...stopped the issue.

    You only need to wipe one time for data and cache...then partitions menu..format boot, format system...then install zip. Data and cache are formatted during the wipe, so no need to format them twice.
     
  8. jamezelle

    jamezelle Premium Member Premium Member Developer

    Joined:
    Apr 11, 2010
    Messages:
    620
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    thats odd I've never had this issue with MIUI
     
  9. yakitori

    yakitori Premium Member Theme Developer Premium Member

    Joined:
    Sep 7, 2010
    Messages:
    2,548
    Likes Received:
    10
    Trophy Points:
    103
    Location:
    DFW Texas
    Ratings:
    +10
    possibly a corrupt download.

    hey Jamezelle. Quick question...lol.

    Where is the widget icon for the miui music 4x4 widget located? Changing the icon as I normally would does not apply to the 4x4 widget, only works on the 4x1. I just need the name of it. I could try logo_4.png I guess.

    Just thought I would ask. I have dug for 2 days and cant find it anywhere.
     
  10. driggity

    driggity New Member

    Joined:
    Aug 12, 2010
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thanks for the fix. It worked for me. I didn't have this on previous versions of MIUI but it started as soon as I updated to 12.11. Unlike Yakitori I did not wipe when going from 12.03 to 12.11.
     
  11. mattcrecelius

    mattcrecelius Member

    Joined:
    Jul 4, 2010
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I tried this and it's still force starting. I guess I'll try again

    Sent from my Droid using Tapatalk
     
  12. mattcrecelius

    mattcrecelius Member

    Joined:
    Jul 4, 2010
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Okay nevermind, it worked. Thank you for the fix, that was really annoying.

    Sent from my Droid using Tapatalk
     
  13. seang

    seang Member

    Joined:
    Jan 23, 2010
    Messages:
    312
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I tried the fix, and it didn't work.
    I just left the miuimusic apk on my sd, and use winamp.
     
  14. yakitori

    yakitori Premium Member Theme Developer Premium Member

    Joined:
    Sep 7, 2010
    Messages:
    2,548
    Likes Received:
    10
    Trophy Points:
    103
    Location:
    DFW Texas
    Ratings:
    +10
    try it again...be sure to reboot in between moves.

    It should fix.

    nice hair.
     
  15. yakitori

    yakitori Premium Member Theme Developer Premium Member

    Joined:
    Sep 7, 2010
    Messages:
    2,548
    Likes Received:
    10
    Trophy Points:
    103
    Location:
    DFW Texas
    Ratings:
    +10
    just an update. I pulled the headphones and it did it again. It hadnt done this for a while, but eventually it started playing again.

    I moved miuimusic.apk from /system/app to /data/app...and rebooted.

    Now...it seems to be fine again...no autostart when I unplug the aux jack. Lets hope it stays this way. I find it very annoying.

    If the first fix didnt work for you, try to move to /data/app and reboot. See if that fixes your prob.
     
Search tags for this page
bluetooth headphones fix apk index
,
bluetooth headphones player apk
,
loud miui player apk
,
miui headphones fix
,

miui headset

,
miui headset control
,
miui music fix
,
miui music player apk fix
,
miui sound coming through phone and headphones
,
play music through bluetooth miui